summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-09 20:37:55 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-09 20:37:55 +0000
commit73c9ff1c8213a9b66b1902475f83fa0ec035361c (patch)
treeb8afd53ffbb48acb2ca6a608b221669c797bac4b /dev-libs/atk
parentVersion bump for Gnome 2.32 (diff)
downloadgentoo-2-73c9ff1c8213a9b66b1902475f83fa0ec035361c.tar.gz
gentoo-2-73c9ff1c8213a9b66b1902475f83fa0ec035361c.tar.bz2
gentoo-2-73c9ff1c8213a9b66b1902475f83fa0ec035361c.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/ChangeLog9
-rw-r--r--dev-libs/atk/atk-1.32.0.ebuild43
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index 5458c58ca96e..3d43e5e51efd 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.205 2010/10/07 20:01:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.206 2010/10/09 20:37:55 pacho Exp $
+
+*atk-1.32.0 (09 Oct 2010)
+
+ 09 Oct 2010; Pacho Ramos <pacho@gentoo.org> +atk-1.32.0.ebuild:
+ Version bump for Gnome 2.32: upstream bugfixes and translation updates.
+ Update HOMEPAGE, don't waste time building tests (bug #226353) and remove
+ DISABLE_DEPRECATED flags.
07 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> atk-1.30.0.ebuild:
ppc64 stable wrt #324077
diff --git a/dev-libs/atk/atk-1.32.0.ebuild b/dev-libs/atk/atk-1.32.0.ebuild
new file mode 100644
index 000000000000..68ba58ddab3f
--- /dev/null
+++ b/dev-libs/atk/atk-1.32.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.32.0.ebuild,v 1.1 2010/10/09 20:37:55 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +introspection"
+
+RDEPEND="dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ sys-devel/gettext
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Remove DEPRECATED flags
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
+ tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
+}