summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 20:54:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 20:54:03 +0000
commit3af2c59fded3f1ef52f4c83803e778e7cb35fdae (patch)
tree1de56cc963994456214c5937bd0d57a4b25603d9 /dev-libs/apr
parentRevision bump to punt translations. Only l10n is allowed to do them. (diff)
downloadgentoo-2-3af2c59fded3f1ef52f4c83803e778e7cb35fdae.tar.gz
gentoo-2-3af2c59fded3f1ef52f4c83803e778e7cb35fdae.tar.bz2
gentoo-2-3af2c59fded3f1ef52f4c83803e778e7cb35fdae.zip
Version bump.
(Portage version: 2.2.0_alpha32_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog8
-rw-r--r--dev-libs/apr/apr-1.4.4.ebuild87
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 67bb08c389ae..9674a64f2ec1 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.167 2011/02/18 17:02:48 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.168 2011/05/09 20:54:03 arfrever Exp $
+
+*apr-1.4.4 (09 May 2011)
+
+ 09 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +apr-1.4.4.ebuild:
+ Version bump.
*apr-1.4.2-r1 (18 Feb 2011)
diff --git a/dev-libs/apr/apr-1.4.4.ebuild b/dev-libs/apr/apr-1.4.4.ebuild
new file mode 100644
index 000000000000..0fdc73bcef46
--- /dev/null
+++ b/dev-libs/apr/apr-1.4.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.4.4.ebuild,v 1.1 2011/05/09 20:54:03 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools eutils libtool multilib
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility +urandom +uuid"
+RESTRICT="test"
+
+RDEPEND="uuid? ( !elibc_FreeBSD? ( >=sys-apps/util-linux-2.16 ) )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # Ensure that system libtool is used.
+ sed -e 's:${installbuilddir}/libtool:/usr/bin/libtool:' -i apr-config.in || die "sed failed"
+ sed -e 's:@LIBTOOL@:$(SHELL) /usr/bin/libtool:' -i build/apr_rules.mk.in || die "sed failed"
+
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ epatch "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+
+ if use urandom; then
+ myconf+=" --with-devrandom=/dev/urandom"
+ else
+ myconf+=" --with-devrandom=/dev/random"
+ fi
+
+ if ! use uuid; then
+ local apr_cv_osuuid
+ export apr_cv_osuuid="no"
+ fi
+
+ CONFIG_SHELL="/bin/bash" econf \
+ --enable-layout=gentoo \
+ --enable-nonportable-atomics \
+ --enable-threads \
+ ${myconf}
+
+ rm -f libtool
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ find "${ED}" -name "*.la" -print0 | xargs -0 rm -f
+
+ dodoc CHANGES NOTICE README
+
+ if use doc; then
+ dohtml -r docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${D}usr/$(get_libdir)/apr.exp"
+}