summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-12-15 14:24:41 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-12-15 14:24:41 +0000
commit355383f9db31d07821f9744c64e5082fd3bfa77d (patch)
treecc6b83a54ba679e3640c1c9ddc9a320864dca8dd /dev-libs/apr
parentadd sni use flag for apache (diff)
downloadgentoo-2-355383f9db31d07821f9744c64e5082fd3bfa77d.tar.gz
gentoo-2-355383f9db31d07821f9744c64e5082fd3bfa77d.tar.bz2
gentoo-2-355383f9db31d07821f9744c64e5082fd3bfa77d.zip
version bump; #200947
(Portage version: 2.1.4_rc8)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog8
-rw-r--r--dev-libs/apr/apr-1.2.12.ebuild (renamed from dev-libs/apr/apr-1.2.9.ebuild)25
-rw-r--r--dev-libs/apr/apr-1.2.8.ebuild86
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.123
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.83
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.93
6 files changed, 28 insertions, 100 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index e5965c0078fa..5a552416fd15 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.99 2007/11/16 20:38:53 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.100 2007/12/15 14:24:41 hollow Exp $
+
+*apr-1.2.12 (15 Dec 2007)
+
+ 15 Dec 2007; Benedikt Böhm <hollow@gentoo.org> -apr-1.2.8.ebuild,
+ -apr-1.2.9.ebuild, +apr-1.2.12.ebuild:
+ version bump; #200947
16 Nov 2007; nixnut <nixnut@gentoo.org> apr-1.2.11.ebuild:
Stable on ppc wrt bug 198866
diff --git a/dev-libs/apr/apr-1.2.9.ebuild b/dev-libs/apr/apr-1.2.12.ebuild
index 99e31aef049a..aefa088c7b2d 100644
--- a/dev-libs/apr/apr-1.2.9.ebuild
+++ b/dev-libs/apr/apr-1.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.9.ebuild,v 1.2 2007/07/31 09:00:08 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.12.ebuild,v 1.1 2007/12/15 14:24:41 hollow Exp $
inherit autotools
@@ -11,10 +11,10 @@ SRC_URI="mirror://apache/apr/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ipv6 urandom debug"
+IUSE="doc ipv6 urandom debug"
RESTRICT="test"
-DEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
@@ -42,7 +42,10 @@ src_compile() {
myconf="${myconf} --with-devrandom=/dev/random"
fi
- use debug && myconf="${myconf} --enable-maintainer-mode"
+ if use debug; then
+ myconf="${myconf} --enable-maintainer-mode"
+ myconf="${myconf} --enable-pool-debug=all"
+ fi
# We pre-load the cache with the correct answer! This avoids
# it violating the sandbox. This may have to be changed for
@@ -53,9 +56,9 @@ src_compile() {
echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
econf --enable-layout=gentoo \
- --enable-threads \
- --enable-nonportable-atomics \
- ${myconf} || die "econf failed!"
+ --enable-threads \
+ --enable-nonportable-atomics \
+ ${myconf}
# Make sure we use the system libtool
sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
@@ -63,6 +66,10 @@ src_compile() {
rm -f "${S}"/libtool
emake || die "Make failed"
+
+ if use doc; then
+ emake dox || die "make dox failed"
+ fi
}
src_install() {
@@ -73,6 +80,10 @@ src_install() {
rm "${D}"/usr/$(get_libdir)/apr.exp
dodoc CHANGES NOTICE
+
+ if use doc; then
+ dohtml docs/dox/html/* || die
+ fi
}
pkg_postinst() {
diff --git a/dev-libs/apr/apr-1.2.8.ebuild b/dev-libs/apr/apr-1.2.8.ebuild
deleted file mode 100644
index e40b44abc3b2..000000000000
--- a/dev-libs/apr/apr-1.2.8.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.8.ebuild,v 1.14 2007/06/27 19:54:59 pylon Exp $
-
-inherit autotools
-
-DESCRIPTION="Apache Portable Runtime Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ipv6 urandom debug"
-RESTRICT="test"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # for some reason not all the .m4 files that are referenced in
- # configure.in exist, so we remove all references and include every
- # .m4 file in build using aclocal via eautoreconf
- # See bug 135463
- sed -i -e '/sinclude/d' configure.in
- AT_M4DIR="build" eautoreconf
-
- epatch "${FILESDIR}"/config.layout.patch
-
-}
-
-src_compile() {
- # For now we always enable ipv6. Testing has shown that is still works
- # correctly in ipv4 systems, and currently, the ipv4-only support
- # is broken in apr. (ipv6 is enabled by default)
- #myconf="${myconf} $(use_enable ipv6)"
-
- if use urandom; then
- myconf="${myconf} --with-devrandom=/dev/urandom"
- else
- myconf="${myconf} --with-devrandom=/dev/random"
- fi
-
- use debug && myconf="${myconf} --enable-maintainer-mode"
-
- # We pre-load the cache with the correct answer! This avoids
- # it violating the sandbox. This may have to be changed for
- # non-Linux systems or if sem_open changes on Linux. This
- # hack is built around documentation in /usr/include/semaphore.h
- # and the glibc (pthread) source
- # See bugs 24215 and 133573
- echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
-
- econf --enable-layout=gentoo \
- --enable-threads \
- --enable-nonportable-atomics \
- ${myconf} || die "econf failed!"
-
- # Make sure we use the system libtool
- sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
- sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
- rm -f "${S}"/libtool
-
- emake || die "Make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # This file is only used on AIX systems, which gentoo is not,
- # and causes collisions between the SLOTs, so kill it
- rm "${D}"/usr/$(get_libdir)/apr.exp
-
- dodoc CHANGES NOTICE
-}
-
-pkg_postinst() {
- ewarn "We are now using the system's libtool rather then bundling"
- ewarn "our own. You will need to rebuild Apache and possibly other"
- ewarn "software if you get a message similiar to the following:"
- ewarn
- ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
- ewarn
-}
diff --git a/dev-libs/apr/files/digest-apr-1.2.12 b/dev-libs/apr/files/digest-apr-1.2.12
new file mode 100644
index 000000000000..e1a49f262fd1
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-1.2.12
@@ -0,0 +1,3 @@
+MD5 020ea947446dca2d1210c099c7a4c837 apr-1.2.12.tar.gz 1127522
+RMD160 912c34e412b42e678288727b811ba35f03d07b6b apr-1.2.12.tar.gz 1127522
+SHA256 23759142c483be869a0aec0529c5b8c94745b4dfd1c2c23f38417f4e02adcead apr-1.2.12.tar.gz 1127522
diff --git a/dev-libs/apr/files/digest-apr-1.2.8 b/dev-libs/apr/files/digest-apr-1.2.8
deleted file mode 100644
index 7e31fb56fcdf..000000000000
--- a/dev-libs/apr/files/digest-apr-1.2.8
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 814f19528d9cfc79aef188dd752e04d8 apr-1.2.8.tar.gz 1107189
-RMD160 299e1ddb1f7c9b0169a410e120c30abea38557c5 apr-1.2.8.tar.gz 1107189
-SHA256 96e31f0ea2e028f372d5fdbbd4f88f31d59e14eda85cd12153183759f8e221c7 apr-1.2.8.tar.gz 1107189
diff --git a/dev-libs/apr/files/digest-apr-1.2.9 b/dev-libs/apr/files/digest-apr-1.2.9
deleted file mode 100644
index c2b00d0cf771..000000000000
--- a/dev-libs/apr/files/digest-apr-1.2.9
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6f4b063ac01a54ba0818c31280f06959 apr-1.2.9.tar.gz 1109990
-RMD160 02d5e81c4bcc389a7c28dd19b96b792fad729ba8 apr-1.2.9.tar.gz 1109990
-SHA256 a41608b5ecd76b5d555b853c9907d55d1cf20e9d1686923eccbc1437ef967d13 apr-1.2.9.tar.gz 1109990