summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-12-27 23:35:41 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-12-27 23:35:41 +0000
commit9efeb0964df0491cba3f4e10dab453d43715b106 (patch)
tree542fe67d9f3e13e4afa1b49959f0bff3b14c2593 /dev-libs/apr-util
parentHandle UUID mismatch by deleting working copy and checking out it again. Patc... (diff)
downloadgentoo-2-9efeb0964df0491cba3f4e10dab453d43715b106.tar.gz
gentoo-2-9efeb0964df0491cba3f4e10dab453d43715b106.tar.bz2
gentoo-2-9efeb0964df0491cba3f4e10dab453d43715b106.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog8
-rw-r--r--dev-libs/apr-util/apr-util-1.4.1.ebuild102
-rw-r--r--dev-libs/apr-util/metadata.xml4
3 files changed, 113 insertions, 1 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 6ee6f62804b9..4e2606f059b3 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.172 2011/11/11 20:35:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.173 2011/12/27 23:35:41 neurogeek Exp $
+
+*apr-util-1.4.1 (27 Dec 2011)
+
+ 27 Dec 2011; Jesus Rivero <neurogeek@gentoo.org> +apr-util-1.4.1.ebuild,
+ metadata.xml:
+ Version bump. Ebuild by Arfrever.
11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> -apr-util-1.3.11.ebuild:
Remove old ebuild
diff --git a/dev-libs/apr-util/apr-util-1.4.1.ebuild b/dev-libs/apr-util/apr-util-1.4.1.ebuild
new file mode 100644
index 000000000000..c1e50b9eb3ff
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.4.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.4.1.ebuild,v 1.1 2011/12/27 23:35:41 neurogeek Exp $
+
+EAPI="4"
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.4.5"
+
+inherit autotools db-use eutils libtool multilib
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1
+ berkdb? ( >=sys-libs/db-4 )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ nss? ( dev-libs/nss )
+ odbc? ( dev-db/unixODBC )
+ openssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.12-bdb-5.2.patch"
+ eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=" --with-dbm=db${db_version} --with-berkeley-db=$(db_includedir 2> /dev/null):/usr/$(get_libdir)"
+ else
+ myconf+=" --without-berkeley-db"
+ fi
+
+ econf \
+ --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ --without-sqlite2 \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with nss) \
+ $(use_with odbc) \
+ $(use_with openssl) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ ${myconf}
+}
+
+src_compile() {
+ emake CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -exec rm -f {} +
+ find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -exec rm -f {} +
+
+ if use doc; then
+ dohtml -r docs/dox/html/*
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.a" -exec rm -f {} +
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
+}
diff --git a/dev-libs/apr-util/metadata.xml b/dev-libs/apr-util/metadata.xml
index a1f5ceff2352..725d9f97a81e 100644
--- a/dev-libs/apr-util/metadata.xml
+++ b/dev-libs/apr-util/metadata.xml
@@ -5,4 +5,8 @@
<maintainer>
<email>apache-bugs@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="nss">Install apr_crypto_nss module</flag>
+ <flag name="openssl">Install apr_crypto_openssl module</flag>
+ </use>
</pkgmetadata>