summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2003-01-11 07:45:28 +0000
committerPreston A. Elder <prez@gentoo.org>2003-01-11 07:45:28 +0000
commit7e04847c370b5bf4e13fc062f83d032e60ff698a (patch)
treefbc176b2bcccc47ee6dbc1628d54c28122f24a7c /dev-libs/ace
parente install fix (diff)
downloadgentoo-2-7e04847c370b5bf4e13fc062f83d032e60ff698a.tar.gz
gentoo-2-7e04847c370b5bf4e13fc062f83d032e60ff698a.tar.bz2
gentoo-2-7e04847c370b5bf4e13fc062f83d032e60ff698a.zip
Added new version of ACE.
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog8
-rw-r--r--dev-libs/ace/ace-5.2.8.ebuild75
-rw-r--r--dev-libs/ace/files/digest-ace-5.2.81
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index 8d50a0e4e161..83bd4d23370d 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ace
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.9 2002/12/20 03:53:22 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.10 2003/01/11 07:45:28 prez Exp $
+
+*ace-5.2.8 (11 January 2003)
+
+ 11 January 2003; Preston A. Elder <prez@gentoo.org> ace-5.2.8.ebuild :
+
+ Added new version.
19 Dec 2002; Dean Bailey <alron@gentoo.org> : removed sparc64 keyword
diff --git a/dev-libs/ace/ace-5.2.8.ebuild b/dev-libs/ace/ace-5.2.8.ebuild
new file mode 100644
index 000000000000..4a70d308f845
--- /dev/null
+++ b/dev-libs/ace/ace-5.2.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.2.8.ebuild,v 1.1 2003/01/11 07:45:28 prez Exp $
+
+S=${WORKDIR}/ACE_wrappers
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}.tar.gz"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="x86 sparc ppc alpha"
+IUSE="ipv6"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/ace
+ use ipv6 && sed -e "s/#define ACE_HAS_PTHREADS$/#define ACE_HAS_PTHREADS\n#define ACE_HAS_IPV6/" config-linux.h >config.h
+ use ipv6 || cp config-linux.h config.h
+ cd ${S}/include/makeinclude
+ sed -e "s:-O3:${CFLAGS}:" platform_linux.GNU >platform_macros.GNU
+}
+
+src_compile() {
+
+ export ACE_ROOT=${S}
+ cd ${S}/ace
+ emake static_libs=1 || die
+}
+
+src_install() {
+
+ dodir /usr/include/ace /usr/lib /usr/share/man/man3
+
+ cd ${S}/ace
+ cp libACE.so ${D}/usr/lib/libACE.so.${PV}
+ cp libACE.a ${D}/usr/lib/libACE.a
+ cd ${D}/usr/lib
+ ln -s libACE.so.${PV} libACE.so.`echo ${PV} | cut -f1 -d.`
+ ln -s libACE.so.${PV} libACE.so
+
+ cd ${S}/ace
+ cp -r *.h *.cpp *.i *.inl ${D}/usr/include/ace
+ chmod 644 ${D}/usr/include/ace/*
+
+ cd ${S}/man
+ cp -r man? ${D}/usr/share/man
+ chmod 644 ${D}/usr/share/man/man?/*
+ gzip ${D}/usr/share/man/man?/*
+
+ cd ${S}
+ dodoc ACE-INSTALL* AUTHORS COPYING FAQ PROBLEM-REPORT-FORM README
+ dodoc THANKS TODO VERSION
+ cd ${S}/docs
+ dodoc *
+ cd ${S}
+ docinto ChangeLogs
+ dodoc ChangeLog
+ cd ${S}/ChangeLogs
+ dodoc *
+}
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.2.8 b/dev-libs/ace/files/digest-ace-5.2.8
new file mode 100644
index 000000000000..57377931c81d
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.2.8
@@ -0,0 +1 @@
+MD5 9070d9c090f8e8a23583f664ba5f021d ACE-5.2.8.tar.gz 7478665