summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-06-20 14:21:27 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-06-20 14:21:27 +0000
commit5547d875e5b512a459778294090414f581ae68ae (patch)
tree3826dc471a9684d5a585aaab82c243251872a071 /dev-libs/ace
parentGCC-4.3 fix added (missing headers). Bug 227919. Thanks to Jeremy Olexa (dark... (diff)
downloadgentoo-2-5547d875e5b512a459778294090414f581ae68ae.tar.gz
gentoo-2-5547d875e5b512a459778294090414f581ae68ae.tar.bz2
gentoo-2-5547d875e5b512a459778294090414f581ae68ae.zip
version bump inspired by bug #227533. removed old unstable version
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog10
-rw-r--r--dev-libs/ace/ace-5.6.5.ebuild (renamed from dev-libs/ace/ace-5.5.9.ebuild)19
2 files changed, 19 insertions, 10 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index 7a6bbd3c8533..09d18419445c 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ace
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.52 2007/10/08 09:06:40 dragonheart Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.53 2008/06/20 14:21:27 dragonheart Exp $
+
+*ace-5.6.5 (20 Jun 2008)
+
+ 20 Jun 2008; Daniel Black <dragonheart@gentoo.org> -ace-5.5.9.ebuild,
+ +ace-5.6.5.ebuild:
+ version bump inspired by bug #227533. removed old unstable version
08 Oct 2007; Daniel Black <dragonheart@gentoo.org> ace-5.5-r1.ebuild,
-ace-5.5.8.ebuild, ace-5.6.1.ebuild:
diff --git a/dev-libs/ace/ace-5.5.9.ebuild b/dev-libs/ace/ace-5.6.5.ebuild
index 6ca840e58709..900b54ea60c5 100644
--- a/dev-libs/ace/ace-5.5.9.ebuild
+++ b/dev-libs/ace/ace-5.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5.9.ebuild,v 1.2 2007/07/22 08:33:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.5.ebuild,v 1.1 2008/06/20 14:21:27 dragonheart Exp $
inherit toolchain-funcs
@@ -34,7 +34,7 @@ src_compile() {
# This disables a silly test which fills the memory
# waiting for a bad_alloc exception and happily
# leaking memory (bug #169647)
- export ace_cv_new_throws_bad_alloc_exception="yes"
+ #export ace_cv_new_throws_bad_alloc_exception="yes"
ECONF_SOURCE="${S}"
econf \
@@ -59,15 +59,18 @@ src_install() {
src_test() {
cd "${S}/build"
emake ACE_ROOT="${S}" check || die "self test failed"
+ sed -i -e "^#define PACKAGE_.*//g" /usr/include/ace/config.h
}
pkg_postinst() {
- # This is required, as anything trying to compile against ACE will have
- # problems with conflicting OS.h files if this is not done.
local CC_MACHINE=$($(tc-getCC) -dumpmachine)
- if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
- mv "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
- "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
+ if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
+ ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
+ ewarn "ace.old"
+ ewarn "This is required, as anything trying to compile against ACE will"
+ ewarn "have problems with conflicting OS.h files if this is not done."
+ mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
+ "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
fi
}