summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-06 20:37:44 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-06 20:37:44 +0000
commitcd3b7241dbf5cfbcd3395c957e561ef3fd388ba4 (patch)
tree0a1df9eac9b7c2c5d771c2edc0adc2b8fedf6607 /dev-libs/STLport
parentadd copyright to RC6 rc-scripts (diff)
downloadgentoo-2-cd3b7241dbf5cfbcd3395c957e561ef3fd388ba4.tar.gz
gentoo-2-cd3b7241dbf5cfbcd3395c957e561ef3fd388ba4.tar.bz2
gentoo-2-cd3b7241dbf5cfbcd3395c957e561ef3fd388ba4.zip
new stlport version needed for openoffice.
Diffstat (limited to 'dev-libs/STLport')
-rw-r--r--dev-libs/STLport/STLport-4.0.ebuild43
-rw-r--r--dev-libs/STLport/files/50STLport-4.06
-rw-r--r--dev-libs/STLport/files/digest-STLport-4.01
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/STLport/STLport-4.0.ebuild b/dev-libs/STLport/STLport-4.0.ebuild
new file mode 100644
index 000000000000..cf178f292825
--- /dev/null
+++ b/dev-libs/STLport/STLport-4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-4.0.ebuild,v 1.1 2001/12/06 20:37:44 danarmak Exp $
+# specially modified from the 4.5 ebuild for openoffice - danarmak
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ STL library"
+
+SRC_URI="http://www.stlport.org/archive/STLport-4.0.tar.gz"
+
+HOMEPAGE="http://www.stlport.org"
+
+DEPEND="sys-devel/gcc"
+
+src_compile() {
+
+ cd ${S}/src
+ make -f gcc.mak clean all
+}
+
+src_install () {
+
+ target=/usr/lib/${P}
+
+ dodir ${target}/include
+ cp -R ${S}/stlport ${D}/${target}/include
+ rm -rf ${D}/${target}/include/stlport/BC50
+
+ dodir ${target}/lib
+ cp -R ${S}/lib/* ${D}/${target}/lib/
+ rm -rf ${D}/${target}/lib/obj
+
+ dodir usr/share/doc/${P}/html
+ cp -R ${S}/doc/* ${D}/usr/share/doc/${P}/html
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/50${P}
+
+}
+
+
diff --git a/dev-libs/STLport/files/50STLport-4.0 b/dev-libs/STLport/files/50STLport-4.0
new file mode 100644
index 000000000000..50c1ed6bde1d
--- /dev/null
+++ b/dev-libs/STLport/files/50STLport-4.0
@@ -0,0 +1,6 @@
+LDPATH=/usr/lib/STLport-4.0/lib
+LIBRARY_PATH=/usr/lib/STLport-4.0/lib
+C_INCLUDE_PATH=/usr/lib/STLport-4.0/include
+CPLUS_INCLUDE_PATH=/usr/lib/STLport-4.0/include
+OBJC_INCLUDE_PATH=/usr/lib/STLport-4.0/include
+
diff --git a/dev-libs/STLport/files/digest-STLport-4.0 b/dev-libs/STLport/files/digest-STLport-4.0
new file mode 100644
index 000000000000..41405e361de3
--- /dev/null
+++ b/dev-libs/STLport/files/digest-STLport-4.0
@@ -0,0 +1 @@
+MD5 9f46fa470328f55c550b829abbf8611b STLport-4.0.tar.gz 696320