summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-08-21 11:14:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-08-21 11:14:48 +0000
commit67e71abb688b9288d4bb314e6e190361c0e1733a (patch)
treeb85db2f203e4d03c572b4bad020a946d23d8f787 /dev-libs/STLport
parentNon-maintainer commit: Version bump for security bug 320977. Also closes bump... (diff)
downloadgentoo-2-67e71abb688b9288d4bb314e6e190361c0e1733a.tar.gz
gentoo-2-67e71abb688b9288d4bb314e6e190361c0e1733a.tar.bz2
gentoo-2-67e71abb688b9288d4bb314e6e190361c0e1733a.zip
Dropped old (bug #240604).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/STLport')
-rw-r--r--dev-libs/STLport/ChangeLog6
-rw-r--r--dev-libs/STLport/STLport-5.1.2.ebuild108
-rw-r--r--dev-libs/STLport/STLport-5.1.3.ebuild113
3 files changed, 5 insertions, 222 deletions
diff --git a/dev-libs/STLport/ChangeLog b/dev-libs/STLport/ChangeLog
index 831240bd433a..fbc99064a4ec 100644
--- a/dev-libs/STLport/ChangeLog
+++ b/dev-libs/STLport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/STLport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.74 2010/08/21 10:27:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.75 2010/08/21 11:14:48 dev-zero Exp $
+
+ 21 Aug 2010; Tiziano Müller <dev-zero@gentoo.org> -STLport-5.1.2.ebuild,
+ -STLport-5.1.3.ebuild:
+ Dropped old (bug #240604).
*STLport-5.2.1 (21 Aug 2010)
diff --git a/dev-libs/STLport/STLport-5.1.2.ebuild b/dev-libs/STLport/STLport-5.1.2.ebuild
deleted file mode 100644
index a2bfaa24ac45..000000000000
--- a/dev-libs/STLport/STLport-5.1.2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.2.ebuild,v 1.10 2009/09/11 11:24:44 flameeyes Exp $
-
-inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
-
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-
-DESCRIPTION="C++ STL library"
-HOMEPAGE="http://stlport.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2"
-LICENSE="as-is"
-SLOT="0"
-IUSE="boost"
-
-DEPEND="boost? ( dev-libs/boost )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-wrong_russian_currency_name.patch"
- epatch "${FILESDIR}/${P}-fix_bashism.patch"
-
- sed -i \
- -e 's/\(OPT += \)-O2/\1/' \
- build/Makefiles/gmake/*cc.mak \
- || die "sed opts failed"
-
- sed -i \
- -e 's/_STLP_VENDOR_CSTD::wcsftime/::wcsftime/' \
- stlport/stl/_cwchar.h || die "sed failed"
-}
-
-src_compile() {
- cat <<- EOF >> stlport/stl/config/user_config.h
- #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
- EOF
-
- append-lfs-flags
-
- sed -i \
- -e "s|\(CC :=\) gcc|\1 $(tc-getCC)|" \
- -e "s|\(CXX :=\) c++|\1 $(tc-getCXX)|" \
- -e "s|^\(CFLAGS = \)|\1 ${CFLAGS} |" \
- -e "s|^\(CCFLAGS = \)|\1 ${CFLAGS} |" \
- -e "s|^\(CPPFLAGS = \)|\1 ${CPPFLAGS} |" \
- build/Makefiles/gmake/gcc.mak || die "sed failed"
-
- local myconf
- if use boost ; then
- myconf="${myconf} --with-boost=/usr/include"
- sed -i \
- -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
- stlport/stl/config/user_config.h
- fi
-
- cd "${S}/build/lib"
-
- # It's not an autoconf script
- ./configure \
- ${myconf} \
- --with-extra-cxxflags="${CXXFLAGS}" || die "configure failed"
-
- cd "${S}"
-
- cat <<- EOF >> build/Makefiles/config.mak
- CFLAGS := ${CFLAGS}
- EOF
-
- local targets
- targets="all-shared all-static"
-
- # The build-system is broken in respect to parallel builds, bug #161881
- emake \
- -j1 \
- -C build/lib \
- -f gcc.mak \
- depend ${targets} || die "Compile failed"
-
-}
-
-src_install() {
- emake -C build/lib -f gcc.mak install
- dolib.so lib/*
-
- emake -C build/lib -f gcc.mak install-static
- dolib.a lib/*.a
-
- insinto /usr/include
- doins -r stlport
-
- dodoc README etc/ChangeLog* etc/*.txt doc/*
-}
-
-src_test() {
- cd "${S}/build"
-
- sed -i \
- -e "1aLDFLAGS := -L${S}/build/lib/obj/gcc/so -L${S}/build/lib/obj/gcc/so_g -L${S}/build/lib/obj/gcc/so_stlg" \
- test/unit/gcc.mak || die "sed failed"
-
- emake -j1 -C test/unit -f gcc.mak || die "emake tests failed"
-
- export LD_LIBRARY_PATH="./lib/obj/gcc/so_stlg"
- ./test/unit/obj/gcc/so_stlg/stl_unit_test || die "unit tests failed"
-}
diff --git a/dev-libs/STLport/STLport-5.1.3.ebuild b/dev-libs/STLport/STLport-5.1.3.ebuild
deleted file mode 100644
index 9d8ef06fc339..000000000000
--- a/dev-libs/STLport/STLport-5.1.3.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.3.ebuild,v 1.2 2009/09/11 11:24:44 flameeyes Exp $
-
-inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="C++ STL library"
-HOMEPAGE="http://stlport.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2"
-LICENSE="as-is"
-SLOT="0"
-IUSE="boost"
-
-DEPEND="boost? ( dev-libs/boost )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-5.1.2-fix_bashism.patch"
-
- sed -i \
- -e 's/\(OPT += \)-O2/\1/' \
- build/Makefiles/gmake/*cc.mak \
- || die "sed opts failed"
-
- sed -i \
- -e 's/_STLP_VENDOR_CSTD::wcsftime/::wcsftime/' \
- stlport/stl/_cwchar.h || die "sed failed"
-}
-
-src_compile() {
- # We have to add this to host.h to make sure
- # that dependencies of STLport use the same settings
- cat <<- EOF >> stlport/stl/config/host.h
- #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
- /* use pthreads for threading */
- #define _PTHREADS
- /* enable largefile support */
- #define _FILE_OFFSET_BITS 64
- #define _LARGEFILE_SOURCE
- #define _LARGEFILE64_SOURCE
- EOF
-
- sed -i \
- -e "s|\(CC :=\) gcc|\1 $(tc-getCC)|" \
- -e "s|\(CXX :=\) c++|\1 $(tc-getCXX)|" \
- -e "s|^\(CFLAGS = \)|\1 ${CFLAGS} |" \
- -e "s|^\(CCFLAGS = \)|\1 ${CFLAGS} |" \
- -e "s|^\(CPPFLAGS = \)|\1 ${CPPFLAGS} |" \
- build/Makefiles/gmake/gcc.mak || die "sed failed"
-
- local myconf
- if use boost ; then
- myconf="${myconf} --with-boost=/usr/include"
- sed -i \
- -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
- stlport/stl/config/user_config.h
- fi
-
- cd "${S}/build/lib"
-
- # It's not an autoconf script
- ./configure \
- ${myconf} \
- --with-extra-cxxflags="${CXXFLAGS}" || die "configure failed"
-
- cd "${S}"
-
- cat <<- EOF >> build/Makefiles/config.mak
- CFLAGS := ${CFLAGS}
- EOF
-
- local targets
- targets="all-shared all-static"
-
- # The build-system is broken in respect to parallel builds, bug #161881
- emake \
- -j1 \
- -C build/lib \
- -f gcc.mak \
- depend ${targets} || die "Compile failed"
-
-}
-
-src_install() {
- emake -C build/lib -f gcc.mak install
- dolib.so lib/*
-
- emake -C build/lib -f gcc.mak install-static
- dolib.a lib/*.a
-
- insinto /usr/include
- doins -r stlport
-
- dodoc README etc/ChangeLog* etc/*.txt doc/*
-}
-
-src_test() {
- cd "${S}/build"
-
- sed -i \
- -e "1aLDFLAGS := -L${S}/build/lib/obj/gcc/so -L${S}/build/lib/obj/gcc/so_g -L${S}/build/lib/obj/gcc/so_stlg" \
- test/unit/gcc.mak || die "sed failed"
-
- emake -j1 -C test/unit -f gcc.mak || die "emake tests failed"
-
- export LD_LIBRARY_PATH="./lib/obj/gcc/so_stlg"
- ./test/unit/obj/gcc/so_stlg/stl_unit_test || die "unit tests failed"
-}