summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-08 16:53:57 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-08 16:53:57 +0000
commitfd70b64e2ea47b0ef29e23655fc783a7db826422 (patch)
treebab1b9e2a7e9414c4d534a3c8fd585d295df9229 /dev-lang
parentStable for ppc64, wrt bug #440872 (diff)
downloadgentoo-2-fd70b64e2ea47b0ef29e23655fc783a7db826422.tar.gz
gentoo-2-fd70b64e2ea47b0ef29e23655fc783a7db826422.tar.bz2
gentoo-2-fd70b64e2ea47b0ef29e23655fc783a7db826422.zip
Use python-any-r1.eclass to find a suitable python for building.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.14.5.1-r1.ebuild8
-rw-r--r--dev-lang/v8/v8-3.14.5.2.ebuild8
-rw-r--r--dev-lang/v8/v8-3.15.1.2-r1.ebuild8
-rw-r--r--dev-lang/v8/v8-3.15.7.2.ebuild8
5 files changed, 21 insertions, 17 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index a37a116f710e..9e5b77de208a 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.261 2012/12/08 04:26:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.262 2012/12/08 16:53:57 floppym Exp $
+
+ 08 Dec 2012; Mike Gilbert <floppym@gentoo.org> v8-3.14.5.1-r1.ebuild,
+ v8-3.14.5.2.ebuild, v8-3.15.1.2-r1.ebuild, v8-3.15.7.2.ebuild:
+ Use python-any-r1.eclass to find a suitable python for building.
*v8-3.15.7.2 (08 Dec 2012)
diff --git a/dev-lang/v8/v8-3.14.5.1-r1.ebuild b/dev-lang/v8/v8-3.14.5.1-r1.ebuild
index 33f44fa534bc..a4d6ce13eb3d 100644
--- a/dev-lang/v8/v8-3.14.5.1-r1.ebuild
+++ b/dev-lang/v8/v8-3.14.5.1-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1-r1.ebuild,v 1.2 2012/11/25 19:05:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1-r1.ebuild,v 1.3 2012/12/08 16:53:57 floppym Exp $
EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
-inherit eutils multilib pax-utils python-utils-r1 toolchain-funcs versionator
+inherit eutils multilib pax-utils python-any-r1 toolchain-funcs versionator
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
@@ -16,12 +17,11 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
+DEPEND="${PYTHON_DEPS}"
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
- python_export python2 EPYTHON
local hardfp=off
diff --git a/dev-lang/v8/v8-3.14.5.2.ebuild b/dev-lang/v8/v8-3.14.5.2.ebuild
index 86a4c0297d4f..0b1574b09226 100644
--- a/dev-lang/v8/v8-3.14.5.2.ebuild
+++ b/dev-lang/v8/v8-3.14.5.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.2.ebuild,v 1.1 2012/12/08 00:51:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.2.ebuild,v 1.2 2012/12/08 16:53:57 floppym Exp $
EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
-inherit eutils multilib pax-utils python-utils-r1 toolchain-funcs versionator
+inherit eutils multilib pax-utils python-any-r1 toolchain-funcs versionator
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
@@ -16,12 +17,11 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
+DEPEND="${PYTHON_DEPS}"
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
- python_export python2 EPYTHON
local hardfp=off
diff --git a/dev-lang/v8/v8-3.15.1.2-r1.ebuild b/dev-lang/v8/v8-3.15.1.2-r1.ebuild
index e26b31db6f1c..02393eae17b7 100644
--- a/dev-lang/v8/v8-3.15.1.2-r1.ebuild
+++ b/dev-lang/v8/v8-3.15.1.2-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2-r1.ebuild,v 1.2 2012/11/25 19:05:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2-r1.ebuild,v 1.3 2012/12/08 16:53:57 floppym Exp $
EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
-inherit eutils multilib pax-utils python-utils-r1 toolchain-funcs versionator
+inherit eutils multilib pax-utils python-any-r1 toolchain-funcs versionator
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
@@ -16,12 +17,11 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
+DEPEND="${PYTHON_DEPS}"
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
- python_export python2 EPYTHON
local hardfp=off
diff --git a/dev-lang/v8/v8-3.15.7.2.ebuild b/dev-lang/v8/v8-3.15.7.2.ebuild
index e155cfd5f04f..a24fc6cd6a06 100644
--- a/dev-lang/v8/v8-3.15.7.2.ebuild
+++ b/dev-lang/v8/v8-3.15.7.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.7.2.ebuild,v 1.1 2012/12/08 04:26:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.7.2.ebuild,v 1.2 2012/12/08 16:53:57 floppym Exp $
EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
-inherit eutils multilib pax-utils python-utils-r1 toolchain-funcs versionator
+inherit eutils multilib pax-utils python-any-r1 toolchain-funcs versionator
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
@@ -16,12 +17,11 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
+DEPEND="${PYTHON_DEPS}"
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
- python_export python2 EPYTHON
local hardfp=off