summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-27 10:43:45 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-27 10:43:45 +0000
commitfac2f18c97ee47c8f9a5b5b4ea1599bf194bb4a4 (patch)
tree653206b4089f153a12d166830bb30e46f6d80a06 /dev-lang
parentStable on amd64 wrt bug #350596 (diff)
downloadgentoo-2-fac2f18c97ee47c8f9a5b5b4ea1599bf194bb4a4.tar.gz
gentoo-2-fac2f18c97ee47c8f9a5b5b4ea1599bf194bb4a4.tar.bz2
gentoo-2-fac2f18c97ee47c8f9a5b5b4ea1599bf194bb4a4.zip
Version bump for dev channel release. Remove old.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-3.0.9.ebuild (renamed from dev-lang/v8/v8-2.5.9.6-r1.ebuild)15
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index b039780873ff..2116f5188f92 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.31 2011/01/26 10:54:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.32 2011/01/27 10:43:45 phajdan.jr Exp $
+
+*v8-3.0.9 (27 Jan 2011)
+
+ 27 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -v8-2.5.9.6-r1.ebuild, +v8-3.0.9.ebuild:
+ Version bump for dev channel release. Remove old.
*v8-2.5.9.11 (26 Jan 2011)
diff --git a/dev-lang/v8/v8-2.5.9.6-r1.ebuild b/dev-lang/v8/v8-3.0.9.ebuild
index b850deffafe2..5a1a15325e04 100644
--- a/dev-lang/v8/v8-2.5.9.6-r1.ebuild
+++ b/dev-lang/v8/v8-3.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.6-r1.ebuild,v 1.1 2011/01/06 10:11:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.9.ebuild,v 1.1 2011/01/27 10:43:45 phajdan.jr Exp $
EAPI="2"
@@ -18,7 +18,9 @@ IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
DEPEND="${RDEPEND}"
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
+# To make tests work, we compile with sample=shell.
+# For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
+EXTRA_ESCONS="library=shared soname=on sample=shell importenv=\"LINKFLAGS\""
pkg_setup() {
tc-export AR CC CXX RANLIB
@@ -37,10 +39,6 @@ src_prepare() {
# Fix a compile error (bug #349794), to be upstreamed.
epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
- # Backport an upstream bugfix for symbol visibility,
- # see bug #348609.
- epatch "${FILESDIR}"/${PN}-upstream-bug-1016-r0.patch
-
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
@@ -88,5 +86,8 @@ src_install() {
}
src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
+ # Make sure we use the libv8.so from our build directory,
+ # and not the /usr/lib one (it may be missing if we are
+ # installing for the first time or upgrading), see bug #352374.
+ LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
}