summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2008-12-30 04:40:22 +0000
committerKeri Harris <keri@gentoo.org>2008-12-30 04:40:22 +0000
commitf2b05104f1491249d94d4e358712b69dba8f8e46 (patch)
treefd8819f25da24ec88bfb92621080c9aa538faf34 /dev-lang
parentDepend on sys-libs/e2fsprogs-libs rather than sys-fs/e2fsprogs #249663. (diff)
downloadgentoo-2-f2b05104f1491249d94d4e358712b69dba8f8e46.tar.gz
gentoo-2-f2b05104f1491249d94d4e358712b69dba8f8e46.tar.bz2
gentoo-2-f2b05104f1491249d94d4e358712b69dba8f8e46.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tuprolog/ChangeLog10
-rw-r--r--dev-lang/tuprolog/files/tuprolog-2.1.1-java1.4.patch180
-rw-r--r--dev-lang/tuprolog/files/tuprolog-2.1.1-javadocs.patch165
-rw-r--r--dev-lang/tuprolog/tuprolog-2.1.1.ebuild55
4 files changed, 408 insertions, 2 deletions
diff --git a/dev-lang/tuprolog/ChangeLog b/dev-lang/tuprolog/ChangeLog
index 009b8bc90dcb..bfdc0b982ff1 100644
--- a/dev-lang/tuprolog/ChangeLog
+++ b/dev-lang/tuprolog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tuprolog
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.24 2007/11/09 18:25:20 keri Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.25 2008/12/30 04:40:22 keri Exp $
+
+*tuprolog-2.1.1 (30 Dec 2008)
+
+ 30 Dec 2008; <keri@gentoo.org> +files/tuprolog-2.1.1-java1.4.patch,
+ +files/tuprolog-2.1.1-javadocs.patch, +tuprolog-2.1.1.ebuild:
+ Version bump
09 Nov 2007; keri <keri@gentoo.org> +files/tuprolog-2.1-DCGLibrary.patch,
tuprolog-2.1.ebuild:
diff --git a/dev-lang/tuprolog/files/tuprolog-2.1.1-java1.4.patch b/dev-lang/tuprolog/files/tuprolog-2.1.1-java1.4.patch
new file mode 100644
index 000000000000..89324fcb7103
--- /dev/null
+++ b/dev-lang/tuprolog/files/tuprolog-2.1.1-java1.4.patch
@@ -0,0 +1,180 @@
+diff -ur src.orig/alice/tuprologx/ide/AWTFrameLauncher.java src/alice/tuprologx/ide/AWTFrameLauncher.java
+--- src.orig/alice/tuprologx/ide/AWTFrameLauncher.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprologx/ide/AWTFrameLauncher.java 2007-06-08 19:43:27.000000000 +1200
+@@ -88,7 +88,7 @@
+ height = Math.min(height, screenSize.height);
+ setBounds((screenSize.width - width) / 2, (screenSize.height - height) / 2, width, height);
+ }
+- show();
++ setVisible(true);
+ }
+
+ public void update(Graphics g) {
+@@ -117,4 +117,4 @@
+
+ } // end AWTFrame class
+
+-} // end AWTFrameLauncher class
+\ No newline at end of file
++} // end AWTFrameLauncher class
+diff -ur src.orig/alice/tuprologx/ide/Applet.java src/alice/tuprologx/ide/Applet.java
+--- src.orig/alice/tuprologx/ide/Applet.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprologx/ide/Applet.java 2007-06-08 19:47:00.000000000 +1200
+@@ -41,7 +41,7 @@
+ ide.removeWindowListener(listeners[i]);
+
+ ide.pack();
+- ide.show();
++ ide.setVisible(true);
+ }
+
+-} // end Applet class
+\ No newline at end of file
++} // end Applet class
+diff -ur src.orig/alice/tuprologx/ide/DotNetIOManager.java src/alice/tuprologx/ide/DotNetIOManager.java
+--- src.orig/alice/tuprologx/ide/DotNetIOManager.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprologx/ide/DotNetIOManager.java 2007-06-08 19:46:43.000000000 +1200
+@@ -46,7 +46,7 @@
+ FileDialog dialog = new FileDialog(parent, "Load Theory", FileDialog.LOAD);
+ dialog.setDirectory(currentLoadDirectory);
+ dialog.setFile("*.pro");
+- dialog.show();
++ dialog.setVisible(true);
+ String directory = dialog.getDirectory();
+ currentLoadDirectory = directory;
+ String fileName = dialog.getFile();
+@@ -61,7 +61,7 @@
+ public String saveTheoryAs(String theory) throws Exception {
+ FileDialog dialog = new FileDialog(parent, "Save Theory As...", FileDialog.SAVE);
+ dialog.setDirectory(currentSaveDirectory);
+- dialog.show();
++ dialog.setVisible(true);
+ String directory = dialog.getDirectory();
+ currentSaveDirectory = directory;
+ String fileName = dialog.getFile();
+@@ -72,4 +72,4 @@
+ return "";
+ }
+
+-} // end DotNetIOManager class
+\ No newline at end of file
++} // end DotNetIOManager class
+diff -ur src.orig/alice/tuprologx/ide/GUILauncher.java src/alice/tuprologx/ide/GUILauncher.java
+--- src.orig/alice/tuprologx/ide/GUILauncher.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprologx/ide/GUILauncher.java 2007-06-08 19:48:08.000000000 +1200
+@@ -74,7 +74,7 @@
+ private void launchDotNetGUI() {
+ DotNetIDE ide = new DotNetIDE();
+ ide.pack();
+- ide.show();
++ ide.setVisible(true);
+ }
+
+ /**
+@@ -99,4 +99,4 @@
+ launcher.launchJavaGUI();
+ }
+
+-} // end GUILauncher class
+\ No newline at end of file
++} // end GUILauncher class
+diff -ur src.orig/alice/util/jedit/JEditTextArea.java src/alice/util/jedit/JEditTextArea.java
+--- src.orig/alice/util/jedit/JEditTextArea.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/JEditTextArea.java 2007-06-08 19:41:59.000000000 +1200
+@@ -115,10 +115,10 @@
+ * Returns if this component can be traversed by pressing
+ * the Tab key. This returns false.
+ */
+- public final boolean isManagingFocus()
++ /*public final boolean isManagingFocus()
+ {
+ return true;
+- }
++ }*/
+
+ /**
+ * Returns the object responsible for painting this text area.
+@@ -507,7 +507,7 @@
+ if(id == Token.NULL)
+ fm = painter.getFontMetrics();
+ else
+- fm = styles[id].getFontMetrics(defaultFont);
++ fm = styles[id].getFontMetrics(painter, defaultFont);
+
+ int length = tokens.length;
+
+@@ -604,7 +604,7 @@
+ if(id == Token.NULL)
+ fm = painter.getFontMetrics();
+ else
+- fm = styles[id].getFontMetrics(defaultFont);
++ fm = styles[id].getFontMetrics(painter, defaultFont);
+
+ int length = tokens.length;
+
+diff -ur src.orig/alice/util/jedit/SyntaxStyle.java src/alice/util/jedit/SyntaxStyle.java
+--- src.orig/alice/util/jedit/SyntaxStyle.java 2007-04-23 10:10:40.000000000 +1200
++++ src/alice/util/jedit/SyntaxStyle.java 2007-06-08 19:32:46.000000000 +1200
+@@ -9,6 +9,7 @@
+ package alice.util.jedit;
+
+ import java.awt.*;
++import javax.swing.*;
+ import java.util.StringTokenizer;
+
+ /**
+@@ -86,7 +87,7 @@
+ /**
+ * Returns the font metrics for the styled font.
+ */
+- public FontMetrics getFontMetrics(Font font)
++ public FontMetrics getFontMetrics(JComponent component, Font font)
+ {
+ if(font == null)
+ throw new NullPointerException("font param must not"
+@@ -98,7 +99,7 @@
+ (bold ? Font.BOLD : 0)
+ | (italic ? Font.ITALIC : 0),
+ font.getSize());
+- fontMetrics = Toolkit.getDefaultToolkit().getFontMetrics(
++ fontMetrics = component.getFontMetrics(
+ lastStyledFont);
+ return fontMetrics;
+ }
+diff -ur src.orig/alice/util/jedit/TextAreaPainter.java src/alice/util/jedit/TextAreaPainter.java
+--- src.orig/alice/util/jedit/TextAreaPainter.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/TextAreaPainter.java 2007-06-08 19:38:19.000000000 +1200
+@@ -67,10 +67,10 @@
+ * Returns if this component can be traversed by pressing the
+ * Tab key. This returns false.
+ */
+- public final boolean isManagingFocus()
++ /*public final boolean isManagingFocus()
+ {
+ return false;
+- }
++ }*/
+
+ /**
+ * Returns the syntax styles used to paint colorized text. Entry <i>n</i>
+@@ -350,7 +350,7 @@
+ public void setFont(Font font)
+ {
+ super.setFont(font);
+- fm = Toolkit.getDefaultToolkit().getFontMetrics(font);
++ fm = getFontMetrics(font);
+ textArea.recalculateVisibleLines();
+ }
+
+diff -ur src.orig/alice/util/thinlet/Thinlet.java src/alice/util/thinlet/Thinlet.java
+--- src.orig/alice/util/thinlet/Thinlet.java 2007-04-23 10:10:40.000000000 +1200
++++ src/alice/util/thinlet/Thinlet.java 2007-06-08 19:49:17.000000000 +1200
+@@ -2157,7 +2157,7 @@
+ *
+ * @return true as focus-transverable component, overwrites the default false value
+ */
+- public boolean isFocusTraversable() {
++ public boolean isFocusable() {
+ return true;
+ }
+
diff --git a/dev-lang/tuprolog/files/tuprolog-2.1.1-javadocs.patch b/dev-lang/tuprolog/files/tuprolog-2.1.1-javadocs.patch
new file mode 100644
index 000000000000..65bd7fc48500
--- /dev/null
+++ b/dev-lang/tuprolog/files/tuprolog-2.1.1-javadocs.patch
@@ -0,0 +1,165 @@
+diff -ur src.orig/alice/tuprolog/ChoicePointStore.java src/alice/tuprolog/ChoicePointStore.java
+--- src.orig/alice/tuprolog/ChoicePointStore.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprolog/ChoicePointStore.java 2007-06-08 07:46:21.000000000 +1200
+@@ -35,7 +35,6 @@
+
+ /**
+ * Return the actual choice-point store
+- * @return
+ */
+ public ChoicePointContext getPointer() {
+ return pointer;
+@@ -44,7 +43,6 @@
+ /**
+ * Check if a choice point exists in the store.
+ * As a side effect, removes choice points which have been already used and are now empty.
+- * @return
+ */
+ protected boolean existChoicePoint() {
+ if (pointer == null) return false;
+diff -ur src.orig/alice/tuprolog/ClauseStore.java src/alice/tuprolog/ClauseStore.java
+--- src.orig/alice/tuprolog/ClauseStore.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprolog/ClauseStore.java 2007-06-08 07:45:36.000000000 +1200
+@@ -58,8 +58,6 @@
+
+ /**
+ * Verify if there is a term in compatibleGoals compatible with goal.
+- * @param goal
+- * @param compGoals
+ * @return true if compatible or false otherwise.
+ */
+ protected boolean existCompatibleClause() {
+diff -ur src.orig/alice/tuprolog/EngineManager.java src/alice/tuprolog/EngineManager.java
+--- src.orig/alice/tuprolog/EngineManager.java 2007-04-23 10:10:40.000000000 +1200
++++ src/alice/tuprolog/EngineManager.java 2007-06-08 07:44:50.000000000 +1200
+@@ -85,7 +85,7 @@
+ /**
+ * Solves a query
+ *
+- * @param g the term representing the goal to be demonstrated
++ * @param query the term representing the goal to be demonstrated
+ * @return the result of the demonstration
+ * @see SolveInfo
+ **/
+diff -ur src.orig/alice/tuprolog/PrimitiveManager.java src/alice/tuprolog/PrimitiveManager.java
+--- src.orig/alice/tuprolog/PrimitiveManager.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprolog/PrimitiveManager.java 2007-06-08 07:44:07.000000000 +1200
+@@ -87,7 +87,7 @@
+ * This involves identifying structs representing builtin
+ * predicates and functors, and setting up related structures and links
+ *
+- * @parm term the term to be identified
++ * @param term the term to be identified
+ * @return term with the identified built-in directive
+ */
+ public Term identifyDirective(Term term) {
+diff -ur src.orig/alice/tuprolog/lib/BasicLibrary.java src/alice/tuprolog/lib/BasicLibrary.java
+--- src.orig/alice/tuprolog/lib/BasicLibrary.java 2007-04-23 10:10:40.000000000 +1200
++++ src/alice/tuprolog/lib/BasicLibrary.java 2007-06-08 07:42:23.000000000 +1200
+@@ -96,7 +96,7 @@
+ /**
+ * Loads a library constructed from a theory.
+ *
+- * @param theory theory text
++ * @param th theory text
+ * @param libName name of the library
+ * @return true if the library has been succesfully loaded.
+ */
+diff -ur src.orig/alice/tuprolog/lib/JavaLibrary.java src/alice/tuprolog/lib/JavaLibrary.java
+--- src.orig/alice/tuprolog/lib/JavaLibrary.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/tuprolog/lib/JavaLibrary.java 2007-06-08 07:43:33.000000000 +1200
+@@ -1226,7 +1226,6 @@
+
+ /**
+ * Generates a fresh numeric identifier
+- * @return
+ */
+ protected Struct generateFreshId() {
+ return new Struct("$obj_" + id++);
+diff -ur src.orig/alice/util/jedit/InputHandler.java src/alice/util/jedit/InputHandler.java
+--- src.orig/alice/util/jedit/InputHandler.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/InputHandler.java 2007-06-07 21:20:15.000000000 +1200
+@@ -24,7 +24,7 @@
+ *
+ * @author Slava Pestov
+ * @version $Id: InputHandler.java,v 1.14 1999/12/13 03:40:30 sp Exp $
+- * @see org.gjt.sp.jedit.textarea.DefaultInputHandler
++ * @see alice.util.jedit.DefaultInputHandler
+ */
+ public abstract class InputHandler extends KeyAdapter
+ {
+@@ -187,7 +187,7 @@
+ /**
+ * Grabs the next key typed event and invokes the specified
+ * action with the key as a the action command.
+- * @param action The action
++ * @param listener The action
+ */
+ public void grabNextKeyStroke(ActionListener listener)
+ {
+diff -ur src.orig/alice/util/jedit/JEditTextArea.java src/alice/util/jedit/JEditTextArea.java
+--- src.orig/alice/util/jedit/JEditTextArea.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/JEditTextArea.java 2007-06-07 21:19:06.000000000 +1200
+@@ -1389,7 +1389,7 @@
+
+ /**
+ * Sets if the selection should be rectangular.
+- * @param overwrite True if the selection should be rectangular,
++ * @param rectSelect True if the selection should be rectangular,
+ * false otherwise.
+ */
+ public final void setSelectionRectangular(boolean rectSelect)
+diff -ur src.orig/alice/util/jedit/KeywordMap.java src/alice/util/jedit/KeywordMap.java
+--- src.orig/alice/util/jedit/KeywordMap.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/KeywordMap.java 2007-06-07 21:17:18.000000000 +1200
+@@ -75,7 +75,7 @@
+ /**
+ * Adds a key-value mapping.
+ * @param keyword The key
+- * @Param id The value
++ * @param id The value
+ */
+ public void add(String keyword, byte id)
+ {
+diff -ur src.orig/alice/util/jedit/TextAreaPainter.java src/alice/util/jedit/TextAreaPainter.java
+--- src.orig/alice/util/jedit/TextAreaPainter.java 2007-04-23 10:10:38.000000000 +1200
++++ src/alice/util/jedit/TextAreaPainter.java 2007-06-07 21:18:00.000000000 +1200
+@@ -75,7 +75,7 @@
+ /**
+ * Returns the syntax styles used to paint colorized text. Entry <i>n</i>
+ * will be used to paint tokens with id = <i>n</i>.
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final SyntaxStyle[] getStyles()
+ {
+@@ -86,7 +86,7 @@
+ * Sets the syntax styles used to paint colorized text. Entry <i>n</i>
+ * will be used to paint tokens with id = <i>n</i>.
+ * @param styles The syntax styles
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final void setStyles(SyntaxStyle[] styles)
+ {
+@@ -356,7 +356,7 @@
+
+ /**
+ * Repaints the text.
+- * @param g The graphics context
++ * @param gfx The graphics context
+ */
+ public void paint(Graphics gfx)
+ {
+diff -ur src.orig/alice/util/jedit/TokenMarker.java src/alice/util/jedit/TokenMarker.java
+--- src.orig/alice/util/jedit/TokenMarker.java 2007-04-23 10:10:40.000000000 +1200
++++ src/alice/util/jedit/TokenMarker.java 2007-06-07 21:15:17.000000000 +1200
+@@ -24,7 +24,7 @@
+ * @author Slava Pestov
+ * @version $Id: TokenMarker.java,v 1.32 1999/12/13 03:40:30 sp Exp $
+ *
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public abstract class TokenMarker
+ {
diff --git a/dev-lang/tuprolog/tuprolog-2.1.1.ebuild b/dev-lang/tuprolog/tuprolog-2.1.1.ebuild
new file mode 100644
index 000000000000..a0cd78121391
--- /dev/null
+++ b/dev-lang/tuprolog/tuprolog-2.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/tuprolog-2.1.1.ebuild,v 1.1 2008/12/30 04:40:22 keri Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="2p-${PV}"
+MY_SRC_P="src-J2SE-${PV}"
+
+DESCRIPTION="tuProlog is a light-weight Prolog for Internet applications and infrastructures"
+HOMEPAGE="http://www.alice.unibo.it/tuProlog/"
+SRC_URI="mirror://sourceforge/tuprolog/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jdk-1.4"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-java1.4.patch
+ epatch "${FILESDIR}"/${P}-javadocs.patch
+
+ cp "${FILESDIR}"/build.xml "${S}"
+}
+
+src_compile() {
+ eant jar $(use_doc)
+}
+
+src_test() {
+ cd "${S}"/dist
+ java-pkg_jar-from junit
+ cd "${S}"
+ ANT_TASKS="ant-junit" eant test || die "eant test failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ if use doc ; then
+ java-pkg_dohtml -r docs/*
+ dodoc doc/*.pdf
+ fi
+
+ dodoc CHANGELOG
+}