summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-02 00:27:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-02 00:27:55 +0000
commitf25b74bbb21539bfe6bc6ba8137befcd32786d21 (patch)
treee6a412f1ec73cd36650b3bb4f39ca311796cb383 /dev-lang
parentTaking over ventrilo-server-bin and bumping to 3.0.3 (diff)
downloadgentoo-2-f25b74bbb21539bfe6bc6ba8137befcd32786d21.tar.gz
gentoo-2-f25b74bbb21539bfe6bc6ba8137befcd32786d21.tar.bz2
gentoo-2-f25b74bbb21539bfe6bc6ba8137befcd32786d21.zip
Fixing fcc 4.3.3 / fortify_sources error. Patch from Ubuntu. Closes #260180
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yap/ChangeLog9
-rw-r--r--dev-lang/yap/files/yap-5.1.3-fortify_sources-ubuntu.patch26
-rw-r--r--dev-lang/yap/yap-5.1.3-r2.ebuild99
3 files changed, 133 insertions, 1 deletions
diff --git a/dev-lang/yap/ChangeLog b/dev-lang/yap/ChangeLog
index 093cee26acaf..5c689814b390 100644
--- a/dev-lang/yap/ChangeLog
+++ b/dev-lang/yap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/yap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.25 2009/01/24 21:24:09 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.26 2009/03/02 00:27:35 patrick Exp $
+
+*yap-5.1.3-r2 (02 Mar 2009)
+
+ 02 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/yap-5.1.3-fortify_sources-ubuntu.patch, +yap-5.1.3-r2.ebuild:
+ Fixing fcc 4.3.3 / fortify_sources error. Patch from Ubuntu. Closes
+ #260180
24 Jan 2009; <keri@gentoo.org> files/yap-5.1.3-configure.patch,
+files/yap-5.1.3-dynamic-lib.patch, yap-5.1.3-r1.ebuild:
diff --git a/dev-lang/yap/files/yap-5.1.3-fortify_sources-ubuntu.patch b/dev-lang/yap/files/yap-5.1.3-fortify_sources-ubuntu.patch
new file mode 100644
index 000000000000..b207f2c18ce4
--- /dev/null
+++ b/dev-lang/yap/files/yap-5.1.3-fortify_sources-ubuntu.patch
@@ -0,0 +1,26 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_gcc_4.3.dpatch by <dktrkranz@ubuntu.com>
+## DP: Fix FTBFS with Ubuntu toolchain
+
+@DPATCH@
+diff -urNad yap-5.1.1~/C/alloc.c yap-5.1.1/C/alloc.c
+--- yap-5.1.1~/C/alloc.c 2006-03-24 18:15:18.000000000 +0100
++++ yap-5.1.1/C/alloc.c 2008-07-09 22:55:34.000000000 +0200
+@@ -796,7 +796,7 @@
+ itos(getpid(), &file[12]);
+ #endif /* HAVE_TMPNAM */
+ #endif /* HAVE_MKSTEMP */
+- fd = open(file, O_CREAT|O_RDWR);
++ fd = open(file, O_CREAT|O_RDWR, 0644);
+ if (fd < 0) {
+ Yap_Error(FATAL_ERROR, TermNil, "mmap could not open %s", file);
+ return NULL;
+@@ -909,7 +909,7 @@
+ itos(getpid(), &file[12]);
+ #endif /* HAVE_TMPNAM */
+ #endif /* HAVE_MKSTEMP */
+- fd = open(file, O_CREAT|O_RDWR);
++ fd = open(file, O_CREAT|O_RDWR, 0644);
+ if (fd < 0) {
+ Yap_ErrorMessage = Yap_ErrorSay;
+ snprintf4(Yap_ErrorMessage, MAX_ERROR_MSG_SIZE,
diff --git a/dev-lang/yap/yap-5.1.3-r2.ebuild b/dev-lang/yap/yap-5.1.3-r2.ebuild
new file mode 100644
index 000000000000..71ec40160a7d
--- /dev/null
+++ b/dev-lang/yap/yap-5.1.3-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.3-r2.ebuild,v 1.1 2009/03/02 00:27:35 patrick Exp $
+
+inherit autotools eutils java-pkg-opt-2
+
+MY_P="Yap-${PV}"
+
+DESCRIPTION="YAP is a high-performance Prolog compiler."
+HOMEPAGE="http://www.ncc.up.pt/~vsc/Yap/"
+SRC_URI="http://www.ncc.up.pt/~vsc/Yap/current/Yap-5.1.3.tar.gz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples gmp java mpi mysql odbc readline static tk threads"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ java? ( >=virtual/jdk-1.4 )
+ mpi? ( virtual/mpi )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline )
+ doc? ( app-text/texi2html )"
+
+RDEPEND="${DEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-config.h.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-multilib.patch
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-dynamic-lib.patch
+ epatch "${FILESDIR}"/${P}-bootdir.patch
+ epatch "${FILESDIR}"/${P}-chr.patch
+ epatch "${FILESDIR}"/${P}-clpbn-examples.patch
+ epatch "${FILESDIR}"/${P}-tkyap.patch
+ epatch "${FILESDIR}"/${P}-fortify_sources-ubuntu.patch
+
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --enable-cut-c \
+ $(use_enable !static dynamic-loading) \
+ $(use_enable threads) \
+ $(use_enable threads pthread-locking) \
+ $(use_enable debug debug-yap) \
+ $(use_enable debug low-level-tracer) \
+ $(use_enable mysql myddas-mysql) \
+ $(use_enable mysql myddas-stats) \
+ $(use_enable mysql myddas-top-level) \
+ $(use_enable odbc myddas-odbc) \
+ $(use_with gmp) \
+ $(use_with readline) \
+ $(use_with mpi) \
+ $(use_with mpi mpe) \
+ $(use_with java jpl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed."
+
+ if use tk ; then
+ exeinto /usr/bin
+ doexe misc/tkyap
+ fi
+
+ dodoc changes*.html README
+
+ if use doc ; then
+ dodoc yap.html
+ fi
+
+ if use examples ; then
+ docinto examples/clpbn
+ dodoc CLPBN/clpbn/examples/*.yap
+ docinto examples/clpbn/school
+ dodoc CLPBN/clpbn/examples/School/*.yap
+ if use mpi ; then
+ docinto examples/mpi
+ dodoc library/mpi/examples/*.pl
+ fi
+ fi
+}