summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 22:22:23 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 22:22:23 +0000
commiteb76a880c5c4efc74278bf027abfe9ba0d39c7bc (patch)
tree87779dff1e36c35cf5bc74e0b039d2df2474c005 /dev-lang
parentPunted old versions, 15.0.1 stable on amd64, bumped. (diff)
downloadgentoo-2-eb76a880c5c4efc74278bf027abfe9ba0d39c7bc.tar.gz
gentoo-2-eb76a880c5c4efc74278bf027abfe9ba0d39c7bc.tar.bz2
gentoo-2-eb76a880c5c4efc74278bf027abfe9ba0d39c7bc.zip
Change all instances of [ to [[.
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog5
-rw-r--r--dev-lang/perl/perl-5.8.8-r2.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 73a28de1911b..98ae4d65dc85 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.240 2007/03/04 13:40:52 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.241 2007/03/07 22:22:23 wolf31o2 Exp $
+
+ 07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> perl-5.8.8-r2.ebuild:
+ Change all instances of [ to [[.
04 Mar 2007; Michael Cummings <mcummings@gentoo.org>
+files/perl-5.8.8-asm-page-h-compile-failure.patch, perl-5.8.8-r2.ebuild:
diff --git a/dev-lang/perl/perl-5.8.8-r2.ebuild b/dev-lang/perl/perl-5.8.8-r2.ebuild
index 5df6c73bbae3..02a497934676 100644
--- a/dev-lang/perl/perl-5.8.8-r2.ebuild
+++ b/dev-lang/perl/perl-5.8.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.30 2007/03/04 13:40:52 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.31 2007/03/07 22:22:23 wolf31o2 Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -53,7 +53,7 @@ pkg_setup() {
epause 5
fi
- if [ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]
+ if [[ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]]
then
# Make sure we have libperl installed ...
eerror "Cannot find ${ROOT}/usr/$(get_libdir)/${LIBPERL}! Make sure that you"
@@ -577,11 +577,11 @@ src_remove_extra_files()
pkg_postinst() {
INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${MY_PV}'|etc|local|perl$/; print "$line\n" }')
- if [ "${ROOT}" = "/" ]
+ if [[ "${ROOT}" = "/" ]]
then
ebegin "Removing old .ph files"
for DIR in $INC; do
- if [ -d ${ROOT}/$DIR ]; then
+ if [[ -d ${ROOT}/$DIR ]]; then
for file in $(find ${ROOT}/$DIR -name "*.ph" -type f); do
rm ${ROOT}/$file
einfo "<< $file"
@@ -590,7 +590,7 @@ pkg_postinst() {
done
# Silently remove the now empty dirs
for DIR in $INC; do
- if [ -d ${ROOT}/$DIR ]; then
+ if [[ -d ${ROOT}/$DIR ]]; then
find ${ROOT}/$DIR -depth -type d | xargs -r rmdir &> /dev/null
fi
done
@@ -608,7 +608,7 @@ pkg_postinst() {
# of portage will allow us to check what version was just removed - which means
# we will be able to invoke this only as needed :)
# Tried doing this via -z, but $INC is too big...
- if [ "${INC}x" != "x" ]; then
+ if [[ "${INC}x" != "x" ]]; then
cleaner_msg
epause 5
fi