summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 16:08:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 16:08:42 +0000
commite877a4642cc7d72be14be2a6ffa1f56e244978a9 (patch)
tree6cd49e70031bc0dc385f0a5a9bfe7e9389a152b0 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-e877a4642cc7d72be14be2a6ffa1f56e244978a9.tar.gz
gentoo-2-e877a4642cc7d72be14be2a6ffa1f56e244978a9.tar.bz2
gentoo-2-e877a4642cc7d72be14be2a6ffa1f56e244978a9.zip
EPYTHON is required for python_mod_optimize().
(Portage version: 15196-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild4
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild4
-rw-r--r--dev-lang/python/python-2.6.4.ebuild4
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index f5c4fca909cf..3bfceebe40f1 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.27 2010/01/12 13:58:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.28 2010/01/12 16:08:42 arfrever Exp $
EAPI="1"
@@ -270,7 +270,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
+ EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 5d8ec8bea2ef..3f95c10c2b65 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.29 2010/01/12 13:52:52 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.30 2010/01/12 16:08:42 arfrever Exp $
EAPI="1"
@@ -277,7 +277,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}
+ EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index d22d8147355a..aae54a03fd64 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.4 2010/01/12 13:58:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.5 2010/01/12 16:08:42 arfrever Exp $
EAPI="1"
@@ -284,7 +284,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.6.4.ebuild b/dev-lang/python/python-2.6.4.ebuild
index ced5eedf33a8..ca2917d373f3 100644
--- a/dev-lang/python/python-2.6.4.ebuild
+++ b/dev-lang/python/python-2.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.13 2010/01/12 13:58:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.14 2010/01/12 16:08:42 arfrever Exp $
EAPI="2"
@@ -286,7 +286,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 9c7d04b2e015..19e623947c11 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.25 2010/01/12 13:58:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.26 2010/01/12 16:08:42 arfrever Exp $
EAPI="2"
@@ -263,7 +263,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
ewarn