summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-27 12:50:14 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-27 12:50:14 +0000
commite7a5efa9089f70dfdb840f361af1477c0d6c8e7b (patch)
treebfe9baf58050ad67b0672260b4f3f8bffd5bda3d /dev-lang
parentRemove masking of ghc-6.12.1 and ghc-6.12.2. (diff)
downloadgentoo-2-e7a5efa9089f70dfdb840f361af1477c0d6c8e7b.tar.gz
gentoo-2-e7a5efa9089f70dfdb840f361af1477c0d6c8e7b.tar.bz2
gentoo-2-e7a5efa9089f70dfdb840f361af1477c0d6c8e7b.zip
dev-lang/python: Disable auto-bumping of active Python version by removing eselect_python_update() and its invocation as explained and announced on gentoo-dev
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog9
-rw-r--r--dev-lang/python/python-2.4.6.ebuild16
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild16
-rw-r--r--dev-lang/python/python-2.6.5-r3.ebuild16
-rw-r--r--dev-lang/python/python-2.6.6-r1.ebuild16
-rw-r--r--dev-lang/python/python-2.7.ebuild16
-rw-r--r--dev-lang/python/python-3.1.2-r4.ebuild16
7 files changed, 14 insertions, 91 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 207c6bce9e5e..9cc84c45106b 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.500 2010/10/27 13:07:07 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.501 2010/11/27 12:50:14 sping Exp $
+
+ 27 Nov 2010; Sebastian Pipping <sping@gentoo.org> python-2.4.6.ebuild,
+ python-2.5.4-r4.ebuild, python-2.6.5-r3.ebuild, python-2.6.6-r1.ebuild,
+ python-2.7.ebuild, python-3.1.2-r4.ebuild:
+ Disable auto-bumping of active Python version by removing
+ eselect_python_update() and its invocation as explained and announced on
+ gentoo-dev
27 Oct 2010; Dirkjan Ochtman <djc@gentoo.org> -python-2.6.4-r1.ebuild,
-python-2.6.5-r2.ebuild, -python-3.1.2-r3.ebuild:
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index e9bdff7f00e5..64753762a06c 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.41 2010/07/10 13:06:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.42 2010/11/27 12:50:14 sping Exp $
EAPI="1"
@@ -269,19 +269,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
# Python 2.4 partially doesn't respect $(get_libdir).
python_mod_optimize -f -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
@@ -299,8 +287,6 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
# Python 2.4 partially doesn't respect $(get_libdir).
python_mod_cleanup /usr/lib/python${SLOT}
}
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index adef9a92d6a1..059dac626975 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.23 2010/07/10 13:06:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.24 2010/11/27 12:50:14 sping Exp $
EAPI="1"
@@ -284,19 +284,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -313,7 +301,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}
diff --git a/dev-lang/python/python-2.6.5-r3.ebuild b/dev-lang/python/python-2.6.5-r3.ebuild
index c9d157b455e9..7fa00dfe5c79 100644
--- a/dev-lang/python/python-2.6.5-r3.ebuild
+++ b/dev-lang/python/python-2.6.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r3.ebuild,v 1.8 2010/08/11 22:32:00 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r3.ebuild,v 1.9 2010/11/27 12:50:14 sping Exp $
EAPI="2"
@@ -276,19 +276,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -305,7 +293,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}
diff --git a/dev-lang/python/python-2.6.6-r1.ebuild b/dev-lang/python/python-2.6.6-r1.ebuild
index cbde2be66fc0..4e0fb6dc3a8d 100644
--- a/dev-lang/python/python-2.6.6-r1.ebuild
+++ b/dev-lang/python/python-2.6.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r1.ebuild,v 1.3 2010/10/27 12:49:29 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r1.ebuild,v 1.4 2010/11/27 12:50:14 sping Exp $
EAPI="2"
@@ -278,19 +278,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -307,7 +295,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}
diff --git a/dev-lang/python/python-2.7.ebuild b/dev-lang/python/python-2.7.ebuild
index ee22e3c28670..afa25b5682b4 100644
--- a/dev-lang/python/python-2.7.ebuild
+++ b/dev-lang/python/python-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.ebuild,v 1.4 2010/07/31 19:14:08 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.ebuild,v 1.5 2010/11/27 12:50:14 sping Exp $
EAPI="2"
@@ -290,19 +290,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -319,7 +307,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}
diff --git a/dev-lang/python/python-3.1.2-r4.ebuild b/dev-lang/python/python-3.1.2-r4.ebuild
index cdbad1d5d37f..29a0e544764c 100644
--- a/dev-lang/python/python-3.1.2-r4.ebuild
+++ b/dev-lang/python/python-3.1.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.9 2010/08/15 23:14:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.10 2010/11/27 12:50:14 sping Exp $
EAPI="3"
@@ -274,19 +274,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python3 symlink.
- eselect python update --python3 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
@@ -319,7 +307,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}