summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-28 16:48:29 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-28 16:48:29 +0000
commite444e2bec4503201047a5fbea2408bd65d7bf278 (patch)
treeab24612b07ee91c0ac85641a0c4105ea18886c56 /dev-lang
parentKeyworded ~x86 (Manifest recommit) (diff)
downloadgentoo-2-e444e2bec4503201047a5fbea2408bd65d7bf278.tar.gz
gentoo-2-e444e2bec4503201047a5fbea2408bd65d7bf278.tar.bz2
gentoo-2-e444e2bec4503201047a5fbea2408bd65d7bf278.zip
Masked on amd64. Bad object code causes segfaults on amd64. see BUG #37826.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-3.07.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-3.07_beta2.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index ec32edc226d0..00158a0eb498 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.28 2004/05/15 00:54:04 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.29 2004/05/28 16:48:29 kugelfang Exp $
+
+ 28 May 2004; Danny van Dyk <kugelfang@gentoo.org> ocaml-3.07-r1.ebuild,
+ ocaml-3.07.ebuild, ocaml-3.07_beta2.ebuild:
+ Marked ocaml -amd64. Produces bad object code that causes segfaults under
+ certain conditions. This happens only on amd64.
15 May 2004; Bryan Østergaard <kloeri@gentoo.org> ocaml-3.07-r1.ebuild:
Stable on alpha.
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index 4b98850cbed0..7bb524359421 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.9 2004/05/15 00:54:04 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.10 2004/05/28 16:48:29 kugelfang Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa"
+KEYWORDS="~x86 ~sparc ~ppc alpha ~ia64 -amd64 hppa"
IUSE="tcltk"
DEPEND="virtual/glibc
diff --git a/dev-lang/ocaml/ocaml-3.07.ebuild b/dev-lang/ocaml/ocaml-3.07.ebuild
index 4bc86532c897..2a5438aff782 100644
--- a/dev-lang/ocaml/ocaml-3.07.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07.ebuild,v 1.4 2004/04/17 10:54:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07.ebuild,v 1.5 2004/05/28 16:48:29 kugelfang Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha -amd64"
IUSE="tcltk"
DEPEND="virtual/glibc
diff --git a/dev-lang/ocaml/ocaml-3.07_beta2.ebuild b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
index 4154cd3178a3..995bc699d822 100644
--- a/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07_beta2.ebuild,v 1.5 2004/04/17 10:54:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07_beta2.ebuild,v 1.6 2004/05/28 16:48:29 kugelfang Exp $
inherit flag-o-matic eutils
@@ -13,7 +13,7 @@ S="${WORKDIR}/${PN}-${MyPV}"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha -amd64"
IUSE="tcltk"
DEPEND="virtual/glibc