summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-28 22:49:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-28 22:49:48 +0000
commite1534f458d824baa8efda3805134b9e8a27239d3 (patch)
treebc0b18d69204f8b773a0049f1f9dc6b6e609ce3e /dev-lang
parentFix metadata. (diff)
downloadgentoo-2-e1534f458d824baa8efda3805134b9e8a27239d3.tar.gz
gentoo-2-e1534f458d824baa8efda3805134b9e8a27239d3.tar.bz2
gentoo-2-e1534f458d824baa8efda3805134b9e8a27239d3.zip
Fixed for cairo graphics (bug #453048), use generic pkg-config, make sure Rexec links to libR.so on prefix. Removed old.
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog14
-rw-r--r--dev-lang/R/R-2.14.1.ebuild157
-rw-r--r--dev-lang/R/R-2.14.2.ebuild158
-rw-r--r--dev-lang/R/R-2.15.0.ebuild181
-rw-r--r--dev-lang/R/R-2.15.2-r1.ebuild (renamed from dev-lang/R/R-2.15.1.ebuild)50
-rw-r--r--dev-lang/R/files/R-2.14.1-pcre830.patch33
-rw-r--r--dev-lang/R/files/R-2.14.2-library-writability.patch40
-rw-r--r--dev-lang/R/files/R-2.14.2-prune-package-update.patch25
-rw-r--r--dev-lang/R/files/R-2.15.2-cairo.patch36
-rw-r--r--dev-lang/R/metadata.xml12
10 files changed, 81 insertions, 625 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 64ec3c2578aa..043ba5ba476b 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lang/R
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.207 2012/10/26 21:44:05 calchan Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.208 2013/01/28 22:49:47 bicatali Exp $
+
+*R-2.15.2-r1 (28 Jan 2013)
+
+ 28 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> +R-2.15.2-r1.ebuild,
+ +files/R-2.15.2-cairo.patch, -R-2.14.1.ebuild, -R-2.14.2.ebuild,
+ -R-2.15.0.ebuild, -R-2.15.1.ebuild, -files/R-2.14.1-pcre830.patch,
+ -files/R-2.14.2-library-writability.patch,
+ -files/R-2.14.2-prune-package-update.patch, metadata.xml:
+ Fixed for cairo graphics (bug #453048), use generic pkg-config, make sure
+ Rexec links to libR.so on prefix. Removed old.
*R-2.15.2 (26 Oct 2012)
diff --git a/dev-lang/R/R-2.14.1.ebuild b/dev-lang/R/R-2.14.1.ebuild
deleted file mode 100644
index adc0b41563c8..000000000000
--- a/dev-lang/R/R-2.14.1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.14.1.ebuild,v 1.6 2012/06/06 02:50:20 zmedico Exp $
-
-EAPI=4
-
-inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png profile readline static-libs tiff tk X"
-REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
-
-CDEPEND="app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- virtual/blas
- cairo? ( x11-libs/cairo[X] x11-libs/pango )
- icu? ( dev-libs/icu )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
- app-arch/xz-utils
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
-
-pkg_setup() {
- if use openmp; then
- FORTRAN_NEED_OPENMP=1
- tc-has-openmp || die "Please enable openmp support in your compiler"
- fi
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.11.1-parallel.patch \
- "${FILESDIR}"/${PN}-2.12.1-ldflags.patch \
- "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \
- "${FILESDIR}"/${PN}-2.14.1-tiff.patch \
- "${FILESDIR}"/${PN}-2.14.1-rmath-shared.patch \
- "${FILESDIR}"/${PN}-2.14.1-pcre830.patch \
- "${FILESDIR}"/${PN}-2.14.1-warnings-buffer-overflow.patch
-
- # fix packages.html for doc (bug #205103)
- sed -i \
- -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/Rd.R || die
-
- # fix Rscript path when installed (bug #221061)
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed -i \
- -e 's:\.\./manual/:manual/:g' \
- $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
- AT_M4DIR=m4 eaclocal
- eautoconf
-}
-
-src_configure() {
- econf \
- --enable-byte-compiled-packages \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_with cairo) \
- $(use_with icu ICU) \
- $(use_with jpeg jpeglib) \
- $(use_with lapack) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with tiff libtiff) \
- $(use_with tk tcltk) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake
- emake -C src/nmath/standalone shared $(use static-libs && echo static)
- use doc && emake info pdf
-}
-
-src_install() {
- default
- emake -C src/nmath/standalone DESTDIR="${D}" install
-
- if use doc; then
- emake DESTDIR="${D}" install-info install-pdf
- dosym ../manual /usr/share/doc/${PF}/html/manual
- fi
-
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R
- use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.14.2.ebuild b/dev-lang/R/R-2.14.2.ebuild
deleted file mode 100644
index ba374f12afb4..000000000000
--- a/dev-lang/R/R-2.14.2.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.14.2.ebuild,v 1.4 2012/10/07 13:35:21 jlec Exp $
-
-EAPI=4
-
-inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png profile readline static-libs tiff tk X"
-REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
-
-CDEPEND="app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- virtual/blas
- cairo? ( x11-libs/cairo[X] x11-libs/pango )
- icu? ( dev-libs/icu )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
- app-arch/xz-utils
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
-
-pkg_setup() {
- if use openmp; then
- FORTRAN_NEED_OPENMP=1
- tc-has-openmp || die "Please enable openmp support in your compiler"
- fi
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.11.1-parallel.patch \
- "${FILESDIR}"/${PN}-2.12.1-ldflags.patch \
- "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \
- "${FILESDIR}"/${PN}-2.14.1-tiff.patch \
- "${FILESDIR}"/${PN}-2.14.1-rmath-shared.patch \
- "${FILESDIR}"/${PN}-2.14.1-warnings-buffer-overflow.patch \
- "${FILESDIR}"/${PN}-2.14.2-library-writability.patch \
- "${FILESDIR}"/${PN}-2.14.2-prune-package-update.patch
-
- # fix packages.html for doc (bug #205103)
- sed -i \
- -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/Rd.R || die
-
- # fix Rscript path when installed (bug #221061)
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed -i \
- -e 's:\.\./manual/:manual/:g' \
- $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
- AT_M4DIR=m4 eaclocal
- eautoconf
-}
-
-src_configure() {
- econf \
- --enable-byte-compiled-packages \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_with cairo) \
- $(use_with icu ICU) \
- $(use_with jpeg jpeglib) \
- $(use_with lapack) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with tiff libtiff) \
- $(use_with tk tcltk) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake
- emake -C src/nmath/standalone shared $(use static-libs && echo static)
- use doc && emake info pdf
-}
-
-src_install() {
- default
- emake -C src/nmath/standalone DESTDIR="${D}" install
-
- if use doc; then
- emake DESTDIR="${D}" install-info install-pdf
- dosym ../manual /usr/share/doc/${PF}/html/manual
- fi
-
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R
- use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.15.0.ebuild b/dev-lang/R/R-2.15.0.ebuild
deleted file mode 100644
index 30b89ec2ad4c..000000000000
--- a/dev-lang/R/R-2.15.0.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.15.0.ebuild,v 1.8 2012/10/07 13:35:21 jlec Exp $
-
-EAPI=4
-
-inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs
-
-BCP=${PN}-20120306.bash_completion
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( http://dev.gentoo.org/~bicatali/distfiles/${BCP}.bz2 )"
-
-LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png profile readline static-libs tiff tk X"
-REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
-
-CDEPEND="app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- virtual/blas
- cairo? ( x11-libs/cairo[X] x11-libs/pango )
- icu? ( dev-libs/icu )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
- app-arch/xz-utils
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
-
-pkg_setup() {
- if use openmp; then
- FORTRAN_NEED_OPENMP=1
- tc-has-openmp || die "Please enable openmp support in your compiler"
- fi
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
- # Temporary fix for bug #419761
- if [[ ($(tc-getCC) == *gcc) && ($(gcc-version) == 4.7) ]]; then
- append-flags -fno-ipa-cp-clone
- fi
-}
-
-src_prepare() {
- # gentoo bug #322965 (not applied upstream)
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
- epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
-
- # respect ldflags (not applied upstream)
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
- epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
-
- # gentoo bug #383431
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14951
- epatch "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch
-
- # tiff automagic
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14952
- epatch "${FILESDIR}"/${PN}-2.14.1-tiff.patch
-
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14953
- epatch "${FILESDIR}"/${PN}-2.14.1-rmath-shared.patch
-
- # too many warning crash, bug #405463
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14954
- epatch "${FILESDIR}"/${PN}-2.14.1-warnings-buffer-overflow.patch
-
- # applied upstream for next R
- epatch \
- "${FILESDIR}"/${PN}-2.14.2-library-writability.patch \
- "${FILESDIR}"/${PN}-2.14.2-prune-package-update.patch
-
- # fix packages.html for doc (gentoo bug #205103)
- sed -i \
- -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/Rd.R || die
-
- # fix Rscript path when installed (gentoo bug #221061)
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (gentoo bug #273957)
- sed -i \
- -e 's:\.\./manual/:manual/:g' \
- $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
- AT_M4DIR=m4 eaclocal
- eautoconf
-}
-
-src_configure() {
- econf \
- --enable-byte-compiled-packages \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_with cairo) \
- $(use_with icu ICU) \
- $(use_with jpeg jpeglib) \
- $(use_with lapack) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with tiff libtiff) \
- $(use_with tk tcltk) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake
- emake -C src/nmath/standalone shared $(use static-libs && echo static)
- use doc && emake info pdf
-}
-
-src_install() {
- default
- emake -C src/nmath/standalone DESTDIR="${D}" install
-
- if use doc; then
- emake DESTDIR="${D}" install-info install-pdf
- dosym ../manual /usr/share/doc/${PF}/html/manual
- fi
-
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R
- use bash-completion && newbashcomp "${WORKDIR}"/${BCP} ${PN}
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.15.1.ebuild b/dev-lang/R/R-2.15.2-r1.ebuild
index ab930a8a0b6f..548e37a201a8 100644
--- a/dev-lang/R/R-2.15.1.ebuild
+++ b/dev-lang/R/R-2.15.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.15.1.ebuild,v 1.3 2012/10/07 13:35:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.15.2-r1.ebuild,v 1.1 2013/01/28 22:49:47 bicatali Exp $
-EAPI=4
+EAPI=5
inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs
@@ -15,10 +15,11 @@ SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-fbsd ~x86-linux ~x64-macos"
-IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png profile readline static-libs tiff tk X"
+IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png prefix profile readline static-libs tiff tk X"
REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
-CDEPEND="app-arch/bzip2
+CDEPEND="
+ app-arch/bzip2
app-text/ghostscript-gpl
dev-libs/libpcre
virtual/blas
@@ -46,7 +47,7 @@ RDEPEND="${CDEPEND}
RESTRICT="minimal? ( test )"
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
+R_DIR="${EROOT}/usr/$(get_libdir)/${PN}"
pkg_setup() {
if use openmp; then
@@ -76,13 +77,12 @@ src_prepare() {
# https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14951
epatch "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch
- # tiff automagic
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14952
- epatch "${FILESDIR}"/${PN}-2.14.1-tiff.patch
-
# https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14953
epatch "${FILESDIR}"/${PN}-2.14.1-rmath-shared.patch
+ # fix cairo plots (gentoo bug #453048)
+ epatch "${FILESDIR}"/${PN}-2.15.2-cairo.patch
+
# fix packages.html for doc (gentoo bug #205103)
sed -i \
-e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
@@ -99,7 +99,7 @@ src_prepare() {
$(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
if use X; then
export R_BROWSER="$(type -p xdg-open)"
@@ -111,18 +111,22 @@ src_prepare() {
# don't search /usr/local
sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die
# Fix for Darwin (OS X)
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed -e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \
- -e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \
- -e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \
- -e "/SHLIB_EXT/s/\.so/.dylib/" \
- -i configure.ac || die
-
- # sort of "undo" 2.14.1-rmath-shared.patch
- sed "s:-Wl,-soname=libRmath.so:-install_name ${EPREFIX}/usr/$(get_libdir)/libRmath.dylib:" \
- -i src/nmath/standalone/Makefile.in || die
+ if use prefix; then
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \
+ -e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \
+ -e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \
+ -e "/SHLIB_EXT/s/\.so/.dylib/" \
+ configure.ac || die
+ # sort of "undo" 2.14.1-rmath-shared.patch
+ sed -i \
+ -e "s:-Wl,-soname=libRmath.so:-install_name ${EROOT}/usr/$(get_libdir)/libRmath.dylib:" \
+ src/nmath/standalone/Makefile.in || die
+ else
+ append-ldflags -Wl,-rpath="${EROOT}/usr/$(get_libdir)/R/lib"
+ fi
fi
-
AT_M4DIR=m4 eaclocal
eautoconf
}
@@ -136,7 +140,7 @@ src_configure() {
--with-system-bzlib \
--with-system-pcre \
--with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable nls) \
diff --git a/dev-lang/R/files/R-2.14.1-pcre830.patch b/dev-lang/R/files/R-2.14.1-pcre830.patch
deleted file mode 100644
index 54036d6e01c7..000000000000
--- a/dev-lang/R/files/R-2.14.1-pcre830.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix for pcre-8.30 and above
-
---- src/main/util.c.orig 2012-02-09 17:15:08.000000000 +0000
-+++ src/main/util.c 2012-02-09 17:20:31.000000000 +0000
-@@ -1257,8 +1257,18 @@
- }
-
- #include "pcre.h"
-+
-+/* This changed at 8.30 */
-+#if PCRE_MAJOR > 8 || PCRE_MINOR >= 30
-+extern int _pcre_valid_utf(const char *string, int length, int *erroroffset);
-+
-+Rboolean utf8Valid(const char *str)
-+{
-+ int errp;
-+ return (_pcre_valid_utf(str, (int) strlen(str), &errp) == 0);
-+}
- /* This changed at 8.13: we don't allow < 8.0 */
--#if PCRE_MAJOR > 8 || PCRE_MINOR >= 13
-+#elif PCRE_MAJOR > 8 || PCRE_MINOR >= 13
- extern int _pcre_valid_utf8(const char *string, int length, int *erroroffset);
-
- Rboolean utf8Valid(const char *str)
-@@ -1266,7 +1276,7 @@
- int errp;
- return (_pcre_valid_utf8(str, (int) strlen(str), &errp) == 0);
- }
--#else
-+#else
- extern int _pcre_valid_utf8(const char *string, int length);
-
- Rboolean utf8Valid(const char *str)
diff --git a/dev-lang/R/files/R-2.14.2-library-writability.patch b/dev-lang/R/files/R-2.14.2-library-writability.patch
deleted file mode 100644
index 3e6cabf654cc..000000000000
--- a/dev-lang/R/files/R-2.14.2-library-writability.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: src/library/utils/R/packages2.R
-===================================================================
---- src/library/utils/R/packages2.R (revision 58532)
-+++ src/library/utils/R/packages2.R (working copy)
-@@ -229,8 +229,8 @@
- domain = NA, immediate. = TRUE)
- userdir <- unlist(strsplit(Sys.getenv("R_LIBS_USER"),
- .Platform$path.sep))[1L]
-- if(interactive() && !file.exists(userdir)) {
-- msg <- gettext("Would you like to create a personal library\n%s\nto install packages into?")
-+ if(interactive()) {
-+ msg <- gettext("Would you like to use a personal library instead?")
- if(.Platform$OS.type == "windows") {
- ans <- winDialog("yesno", sprintf(msg, sQuote(userdir)))
- if(ans != "YES") stop("unable to install packages")
-@@ -239,10 +239,21 @@
- if(substr(ans, 1L, 1L) == "n")
- stop("unable to install packages")
- }
-- if(!dir.create(userdir, recursive = TRUE))
-- stop("unable to create ", sQuote(userdir))
- lib <- userdir
-- .libPaths(c(userdir, .libPaths()))
-+ if(!file.exists(userdir)) {
-+ msg <- gettext("Would you like to create a personal library\n%s\nto install packages into?")
-+ if(.Platform$OS.type == "windows") {
-+ ans <- winDialog("yesno", sprintf(msg, sQuote(userdir)))
-+ if(ans != "YES") stop("unable to install packages")
-+ } else {
-+ ans <- readline(paste(sprintf(msg, userdir), " (y/n) "))
-+ if(substr(ans, 1L, 1L) == "n")
-+ stop("unable to install packages")
-+ }
-+ if(!dir.create(userdir, recursive = TRUE))
-+ stop("unable to create ", sQuote(userdir))
-+ .libPaths(c(userdir, .libPaths()))
-+ }
- } else stop("unable to install packages")
- }
-
diff --git a/dev-lang/R/files/R-2.14.2-prune-package-update.patch b/dev-lang/R/files/R-2.14.2-prune-package-update.patch
deleted file mode 100644
index 8b4b76916e1d..000000000000
--- a/dev-lang/R/files/R-2.14.2-prune-package-update.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: src/library/utils/R/packages.R
-===================================================================
---- src/library/utils/R/packages.R (revision 58579)
-+++ src/library/utils/R/packages.R (working copy)
-@@ -323,6 +323,20 @@
- oldPkgs <- old.packages(lib.loc = lib.loc,
- contriburl = contriburl, method = method,
- available = available, checkBuilt = checkBuilt)
-+ ## prune package versions which are invisible to require()
-+ if(!is.null(oldPkgs)) {
-+ pkg <- 0
-+ while(pkg < nrow(oldPkgs)) {
-+ pkg <- pkg + 1
-+ if(find.package(oldPkgs[pkg], lib.loc = lib.loc) != find.package(oldPkgs[pkg], lib.loc = oldPkgs[pkg,2])) {
-+ warning(sprintf("package '%s' in library '%s' will not be updated",
-+ oldPkgs[pkg], oldPkgs[pkg, 2]),
-+ call. = FALSE, immediate. = TRUE)
-+ oldPkgs <- oldPkgs[-pkg, , drop = FALSE]
-+ pkg <- pkg - 1
-+ }
-+ }
-+ }
- if(is.null(oldPkgs))
- return(invisible())
- } else if (!(is.matrix(oldPkgs) && is.character(oldPkgs)))
diff --git a/dev-lang/R/files/R-2.15.2-cairo.patch b/dev-lang/R/files/R-2.15.2-cairo.patch
new file mode 100644
index 000000000000..3a02b28ead9d
--- /dev/null
+++ b/dev-lang/R/files/R-2.15.2-cairo.patch
@@ -0,0 +1,36 @@
+--- src/modules/X11/devX11.c (révision 61681)
++++ src/modules/X11/devX11.c (révision 61682)
+@@ -244,6 +244,7 @@
+ {
+ if(inclose || !xd || !xd->buffered || xd->holdlevel > 0) return;
+ cairo_paint(xd->xcc);
++ cairo_surface_flush(xd->xcs);
+ if (xd->type == WINDOW) XDefineCursor(display, xd->window, arrow_cursor);
+ XSync(display, 0);
+ xd->last = currentTime();
+@@ -753,8 +754,10 @@
+ #ifdef HAVE_WORKING_CAIRO
+ pX11Desc xd = (pX11Desc) dd->deviceSpecific;
+ /* We can use the buffered copy where we have it */
+- if(xd->buffered == 1) cairo_paint(xd->xcc);
+- else if (xd->buffered > 1)
++ if(xd->buffered == 1) {
++ cairo_paint(xd->xcc);
++ cairo_surface_flush(xd->xcs);
++ } else if (xd->buffered > 1)
+ /* rely on timer to repaint eventually */
+ xd->last_activity = currentTime();
+ else
+@@ -2691,7 +2694,11 @@
+ Cairo_update(xd);
+ return;
+ }
+- if(xd->buffered) cairo_paint(xd->xcc);
++ if(xd->buffered) {
++ cairo_paint(xd->xcc);
++ cairo_surface_flush(xd->xcs);
++ }
++
+ #endif
+ if(xd->type==WINDOW) XDefineCursor(display, xd->window, arrow_cursor);
+ XSync(display, 0);
diff --git a/dev-lang/R/metadata.xml b/dev-lang/R/metadata.xml
index 148f2798d1a1..5d205a8da7fb 100644
--- a/dev-lang/R/metadata.xml
+++ b/dev-lang/R/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-mathematics</herd>
- <maintainer>
- <email>calchan@gentoo.org</email>
- <name>Denis Dupeyron</name>
- </maintainer>
- <longdescription lang="en">
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+</maintainer>
+<longdescription lang="en">
R is GNU S, a system for statistical computation and graphics. It
consists of a language plus a run-time environment with graphics, a
debugger, access to certain system functions, and the ability to run