summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-02-08 15:23:39 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-02-08 15:23:39 +0000
commitdec2ee737b5ea353b26a1d8277149bafc703d28d (patch)
tree90eeb9ed591a7364f0fed9ece7f85a8f6271618e /dev-lang
parentMask app-emacs/pymacs beta release for testing. (diff)
downloadgentoo-2-dec2ee737b5ea353b26a1d8277149bafc703d28d.tar.gz
gentoo-2-dec2ee737b5ea353b26a1d8277149bafc703d28d.tar.bz2
gentoo-2-dec2ee737b5ea353b26a1d8277149bafc703d28d.zip
version bump, now grab straight from git sources
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rubinius/ChangeLog8
-rw-r--r--dev-lang/rubinius/rubinius-0.8_pre20080208.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-lang/rubinius/ChangeLog b/dev-lang/rubinius/ChangeLog
index 3e6c3c13a6d4..c0504357a63a 100644
--- a/dev-lang/rubinius/ChangeLog
+++ b/dev-lang/rubinius/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/rubinius
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/ChangeLog,v 1.1 2008/01/29 18:42:20 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/ChangeLog,v 1.2 2008/02/08 15:23:39 caleb Exp $
+
+*rubinius-0.8_pre20080208 (08 Feb 2008)
+
+ 08 Feb 2008; Caleb Tennis <caleb@gentoo.org>
+ +rubinius-0.8_pre20080208.ebuild:
+ version bump, now grab straight from git sources
*rubinius-0.8_pre20080129 (29 Jan 2008)
diff --git a/dev-lang/rubinius/rubinius-0.8_pre20080208.ebuild b/dev-lang/rubinius/rubinius-0.8_pre20080208.ebuild
new file mode 100644
index 000000000000..511e6711bf9c
--- /dev/null
+++ b/dev-lang/rubinius/rubinius-0.8_pre20080208.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/rubinius-0.8_pre20080208.ebuild,v 1.1 2008/02/08 15:23:39 caleb Exp $
+
+EAPI=1
+EGIT_REPO_URI="git://git.rubini.us/code"
+
+inherit multilib git
+
+# Must go after inherit git
+# This is the tree shaid that we want to grab
+EGIT_TREE="f60fd914037838ac01032d85336675f0afd0964c"
+
+DESCRIPTION="An alternative ruby interpreter"
+HOMEPAGE="http://rubini.us"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/ruby-1.8.6_p110:1.8
+ dev-ruby/rubygems"
+DEPEND="sys-devel/bison
+ dev-util/pkgconfig
+ dev-ruby/rake
+ ${RDEPEND}"
+
+src_compile() {
+ sed -ie "s:PREFIX=/usr/local:PREFIX=/usr:g" "${S}"/shotgun/vars.mk
+
+ if use debug; then
+ DEV=1 rake build
+ else
+ rake build
+ fi
+}
+
+src_install() {
+ LIBDIR=$(get_libdir)
+ RDIR=/usr/${LIBDIR}/rubinius
+
+ dodir ${RDIR}/shotgun
+ cp -pR "${S}"/runtime "${D}"/${RDIR}
+ cp -pR "${S}"/lib "${D}"/${RDIR}
+ install shotgun/lib/librubinius-0.8.0.so "${D}"/usr/${LIBDIR}
+
+ install shotgun/rubinius "${D}"/${RDIR}/shotgun
+ install shotgun/rubinius.bin "${D}"/${RDIR}/shotgun
+ install shotgun/gdb* "${D}"/${RDIR}/shotgun
+ dosym ${RDIR}/shotgun/rubinius /usr/bin/rbx
+}
+
+src_test() {
+ ./bin/ci
+}