summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-06-30 17:14:25 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-06-30 17:14:25 +0000
commitc8223aec24fb98290047bc4e75ea2103a57fb14a (patch)
tree337b93ccfd8a0248c5155e8be211ab28b53e1491 /dev-lang
parentia64/x86 stable wrt #183728 (diff)
downloadgentoo-2-c8223aec24fb98290047bc4e75ea2103a57fb14a.tar.gz
gentoo-2-c8223aec24fb98290047bc4e75ea2103a57fb14a.tar.bz2
gentoo-2-c8223aec24fb98290047bc4e75ea2103a57fb14a.zip
Version bump.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.5.1.ebuild123
-rw-r--r--dev-lang/R/files/digest-R-2.5.13
3 files changed, 132 insertions, 1 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 7f82de89bb88..16f5859bb989 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.86 2007/05/11 13:31:28 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.87 2007/06/30 17:14:25 markusle Exp $
+
+*R-2.5.1 (30 Jun 2007)
+
+ 30 Jun 2007; Markus Dittrich <markusle@gentoo.org> +R-2.5.1.ebuild:
+ Version bump.
11 May 2007; Markus Dittrich <markusle@gentoo.org> R-2.5.0.ebuild:
Added gd useflag to allow users to install the GDD module (this
diff --git a/dev-lang/R/R-2.5.1.ebuild b/dev-lang/R/R-2.5.1.ebuild
new file mode 100644
index 000000000000..8a4a32b7b6bb
--- /dev/null
+++ b/dev-lang/R/R-2.5.1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.5.1.ebuild,v 1.1 2007/06/30 17:14:25 markusle Exp $
+
+inherit fortran toolchain-funcs flag-o-matic
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas jpeg nls png readline tk X lapack gd"
+
+RDEPEND=">=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ gd? ( >=media-libs/gd-2 )
+ tk? ( dev-lang/tk
+ dev-lang/tcl )
+ X? ( || ( ( x11-libs/libX11 )
+ virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xproto
+ x11-libs/libXt
+ x11-libs/libX11 )
+ virtual/x11 ) )"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ cd "${T}"
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77 or gfortran."
+ FORTRAN="gfortran g77 ifc"
+ else
+ FORTRAN="gfortran g77 f2c"
+ fi
+ rm -f test.{c,o}
+ fortran_pkg_setup
+
+ filter-ldflags -Wl,-Bdirect -Bdirect
+
+ # this is needed to properly compile additional R packages
+ # (see bug #152379)
+ append-flags -std=gnu99
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -e "s:\$(rhome):/usr/$(get_libdir)/R:g" \
+ -i "${S}"/src/unix/Makefile.in ||
+ die "Failed to fix Rscript makefile"
+}
+
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
+ --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ # R-2.5.0 started to have issues with parallel make
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ libdir=${D}/usr/$(get_libdir) \
+ rhome=${D}/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ # fix the R wrapper script to have the correct R_HOME_DIR
+ # sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # The same kinds of seds are needed for these variables too, see bug 115140
+ sed \
+ -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
+ -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
+ -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ # the 2nd one is corrected by above sed, the first is replaced by a symlink
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo -n \
+ "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
+ > ${D}/etc/env.d/99R
+ cd ${S}
+
+ dodoc ChangeLog *NEWS README VERSION
+}
diff --git a/dev-lang/R/files/digest-R-2.5.1 b/dev-lang/R/files/digest-R-2.5.1
new file mode 100644
index 000000000000..5adf0a12d786
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.5.1
@@ -0,0 +1,3 @@
+MD5 162f6d5a1bd7c60fd652145e050f3f3c R-2.5.1.tar.gz 15224643
+RMD160 0f5ed986c783c0d9baa2310b08278db1b8720f88 R-2.5.1.tar.gz 15224643
+SHA256 8d915327b37f38e742c247bbe6a653417eabf3dadc5880f3a81507924a1df682 R-2.5.1.tar.gz 15224643