summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-10-04 21:02:29 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-10-04 21:02:29 +0000
commitc7d2589295ab754b137d9fda4abd645371fe47a7 (patch)
tree450a1df79395cd921d24ff3d4096f5685f54fad4 /dev-lang
parentMask g-d-u -r300 with the rest of Gnome3 stuff, letting us to drop nautilus u... (diff)
downloadgentoo-2-c7d2589295ab754b137d9fda4abd645371fe47a7.tar.gz
gentoo-2-c7d2589295ab754b137d9fda4abd645371fe47a7.tar.bz2
gentoo-2-c7d2589295ab754b137d9fda4abd645371fe47a7.zip
Version bump for stable channel release. Remove old.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-3.4.14.28.ebuild (renamed from dev-lang/v8/v8-3.4.6.2.ebuild)39
-rw-r--r--dev-lang/v8/v8-9999.ebuild26
3 files changed, 22 insertions, 51 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index d6d9e53f44b6..f11dc966ad99 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.77 2011/09/24 17:19:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.78 2011/10/04 21:02:29 phajdan.jr Exp $
+
+*v8-3.4.14.28 (04 Oct 2011)
+
+ 04 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-3.4.6.2.ebuild,
+ +v8-3.4.14.28.ebuild, v8-9999.ebuild:
+ Version bump for stable channel release. Remove old.
24 Sep 2011; Fabian Groffen <grobian@gentoo.org> v8-3.4.12.1.ebuild:
Fix libaries on Darwin, keyworded ~x64-macos and ~x86-macos, bug #354601
diff --git a/dev-lang/v8/v8-3.4.6.2.ebuild b/dev-lang/v8/v8-3.4.14.28.ebuild
index b2dcc1fe0869..e0912812aa27 100644
--- a/dev-lang/v8/v8-3.4.6.2.ebuild
+++ b/dev-lang/v8/v8-3.4.14.28.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.4.6.2.ebuild,v 1.1 2011/06/29 11:28:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.4.14.28.ebuild,v 1.1 2011/10/04 21:02:29 phajdan.jr Exp $
-EAPI="2"
+EAPI="3"
inherit eutils flag-o-matic multilib pax-utils scons-utils toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos ~x86-macos"
IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
@@ -31,14 +31,6 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
}
src_configure() {
@@ -47,10 +39,7 @@ src_configure() {
}
src_compile() {
- # To make tests work, we compile with sample=shell and visibility=default.
- # For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
- # and http://groups.google.com/group/v8-users/browse_thread/thread/165f89728ed6f97d
- local myconf="library=shared soname=on sample=shell visibility=default importenv=LINKFLAGS,PATH"
+ local myconf="library=shared soname=on importenv=LINKFLAGS,PATH"
# Use target arch detection logic from bug #354601.
case ${CHOST} in
@@ -75,25 +64,21 @@ src_compile() {
die "Failed to determine target arch, got '$myarch'."
fi
- escons $(use_scons readline console readline dumb) ${myconf} . || die
- pax-mark -m obj/test/release/cctest shell d8
+ escons $(use_scons readline console readline dumb) ${myconf} || die
}
src_install() {
insinto /usr
doins -r include || die
- dobin d8 || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libv8-${PV}$(get_libname) \
+ libv8-${PV}$(get_libname) || die
+ fi
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
+ dolib libv8-${PV}$(get_libname) || die
+ dosym libv8-${PV}$(get_libname) /usr/$(get_libdir)/libv8$(get_libname) || die
dodoc AUTHORS ChangeLog || die
}
-
-src_test() {
- # Make sure we use the libv8.so from our build directory,
- # and not the /usr/lib one (it may be missing if we are
- # installing for the first time or upgrading), see bug #352374.
- LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
-}
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 89111dc999c4..0f640f763135 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.11 2011/05/24 08:04:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.12 2011/10/04 21:02:29 phajdan.jr Exp $
EAPI="2"
@@ -31,14 +31,6 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
}
src_configure() {
@@ -47,10 +39,7 @@ src_configure() {
}
src_compile() {
- # To make tests work, we compile with sample=shell and visibility=default.
- # For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
- # and http://groups.google.com/group/v8-users/browse_thread/thread/165f89728ed6f97d
- local myconf="library=shared sample=shell visibility=default importenv=LINKFLAGS,PATH"
+ local myconf="library=shared importenv=LINKFLAGS,PATH"
# Use target arch detection logic from bug #354601.
case ${CHOST} in
@@ -75,27 +64,18 @@ src_compile() {
die "Failed to determine target arch, got '$myarch'."
fi
- escons $(use_scons readline console readline dumb) ${myconf} . || die
- pax-mark -m obj/test/release/cctest shell d8
+ escons $(use_scons readline console readline dumb) ${myconf} || die
}
src_install() {
insinto /usr
doins -r include || die
- dobin d8 || die
dolib libv8.so || die
dodoc AUTHORS ChangeLog || die
}
-src_test() {
- # Make sure we use the libv8.so from our build directory,
- # and not the /usr/lib one (it may be missing if we are
- # installing for the first time or upgrading), see bug #352374.
- LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
-}
-
pkg_postinst() {
einfo "The live ebuild does not use SONAME."
einfo "You must rebuild all packages depending on ${PN}"