summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-05 16:51:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-05 16:51:29 +0000
commitc5bcfa8eece3e60a9c46c49dea776c1db62f8553 (patch)
tree7562afbfb261ae8b1e70a96f8ddd8c0f7e68a915 /dev-lang
parentalpha/ia64/ppc64/sparc stable (bug #404641) (diff)
downloadgentoo-2-c5bcfa8eece3e60a9c46c49dea776c1db62f8553.tar.gz
gentoo-2-c5bcfa8eece3e60a9c46c49dea776c1db62f8553.tar.bz2
gentoo-2-c5bcfa8eece3e60a9c46c49dea776c1db62f8553.zip
Fix build with static-libs thanks to Peter Stuge <peter@stuge.se>. Bug #411413
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jimtcl/ChangeLog8
-rw-r--r--dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild10
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild10
3 files changed, 20 insertions, 8 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index e9f91d33d3f5..2c1b372e6839 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/jimtcl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.4 2011/12/30 09:54:46 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.5 2012/05/05 16:51:29 hwoarang Exp $
+
+ 05 May 2012; Markos Chandras <hwoarang@gentoo.org>
+ jimtcl-0.70_pre20110317.ebuild, jimtcl-9999.ebuild:
+ Fix build with static-libs thanks to Peter Stuge <peter@stuge.se>. Bug #411413
30 Dec 2011; Markos Chandras <hwoarang@gentoo.org> jimtcl-9999.ebuild:
Drop --with-jim-ext configuration option. Bug #394649. Thanks to Alexander
diff --git a/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild b/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild
index cbd34f12d824..dd016e3531ba 100644
--- a/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild,v 1.1 2011/03/17 02:21:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.70_pre20110317.ebuild,v 1.2 2012/05/05 16:51:29 hwoarang Exp $
EAPI="2"
@@ -25,7 +25,11 @@ src_compile() {
src_install() {
dobin jimsh || die "dobin failed"
- dolib.so libjim.so || die "dolib failed"
+ use static-libs && {
+ dolib.a libjim.a || die "dolib failed"
+ } || {
+ dolib.so libjim.so || die "dolib failed"
+ }
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-nvp.h jim-signal.h
doins jim-win32compat.h jim-eventloop.h jim-config.h
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index 17acb7ab1c63..38a82fba29fb 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.4 2011/12/30 09:54:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.5 2012/05/05 16:51:29 hwoarang Exp $
EAPI="2"
@@ -26,7 +26,11 @@ src_compile() {
src_install() {
dobin jimsh || die "dobin failed"
- dolib.so libjim.so || die "dolib failed"
+ use static-libs && {
+ dolib.a libjim.a || die "dolib failed"
+ } || {
+ dolib.so libjim.so || die "dolib failed"
+ }
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-nvp.h jim-signal.h
doins jim-win32compat.h jim-eventloop.h jim-config.h