summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2012-08-19 09:43:26 +0000
committerKeri Harris <keri@gentoo.org>2012-08-19 09:43:26 +0000
commitbddf45912ae72e34c189c75f512af0bb97d5e5fe (patch)
tree41b6c1548636e7066c604ca96182d60a482371c7 /dev-lang
parentFix RubyInline version to actually match versions in our tree. (diff)
downloadgentoo-2-bddf45912ae72e34c189c75f512af0bb97d5e5fe.tar.gz
gentoo-2-bddf45912ae72e34c189c75f512af0bb97d5e5fe.tar.bz2
gentoo-2-bddf45912ae72e34c189c75f512af0bb97d5e5fe.zip
Remove old development versions
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swi-prolog/ChangeLog6
-rw-r--r--dev-lang/swi-prolog/swi-prolog-6.1.10.ebuild130
-rw-r--r--dev-lang/swi-prolog/swi-prolog-6.1.8.ebuild130
-rw-r--r--dev-lang/swi-prolog/swi-prolog-6.1.9.ebuild130
4 files changed, 5 insertions, 391 deletions
diff --git a/dev-lang/swi-prolog/ChangeLog b/dev-lang/swi-prolog/ChangeLog
index e36477388048..3197dea522f6 100644
--- a/dev-lang/swi-prolog/ChangeLog
+++ b/dev-lang/swi-prolog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/swi-prolog
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.338 2012/08/18 18:06:35 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.339 2012/08/19 09:43:26 keri Exp $
+
+ 19 Aug 2012; <keri@gentoo.org> -swi-prolog-6.1.8.ebuild,
+ -swi-prolog-6.1.9.ebuild, -swi-prolog-6.1.10.ebuild:
+ Remove old development versions
*swi-prolog-6.1.12 (17 Aug 2012)
diff --git a/dev-lang/swi-prolog/swi-prolog-6.1.10.ebuild b/dev-lang/swi-prolog/swi-prolog-6.1.10.ebuild
deleted file mode 100644
index a5856da2447a..000000000000
--- a/dev-lang/swi-prolog/swi-prolog-6.1.10.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-6.1.10.ebuild,v 1.1 2012/08/04 08:21:45 keri Exp $
-
-EAPI=2
-
-inherit eutils flag-o-matic java-pkg-opt-2 multilib
-
-PATCHSET_VER="0"
-
-DESCRIPTION="free, small, and standard compliant Prolog compiler"
-HOMEPAGE="http://www.swi-prolog.org/"
-SRC_URI="http://www.swi-prolog.org/download/devel/src/pl-${PV}.tar.gz
- mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="archive debug doc gmp hardened java minimal odbc readline ssl static-libs test zlib X"
-
-RDEPEND="sys-libs/ncurses
- archive? ( app-arch/libarchive )
- zlib? ( sys-libs/zlib )
- odbc? ( dev-db/unixODBC )
- readline? ( sys-libs/readline )
- gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )
- java? ( >=virtual/jdk-1.4 )
- X? (
- virtual/jpeg
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- java? ( test? ( =dev-java/junit-3.8* ) )"
-
-S="${WORKDIR}/pl-${PV}"
-
-src_prepare() {
- EPATCH_FORCE=yes
- EPATCH_SUFFIX=patch
- epatch "${WORKDIR}"/${PV}
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- use ppc && append-flags -mno-altivec
- use hardened && append-flags -fno-unit-at-a-time
- use debug && append-flags -DO_DEBUG
-
- cd "${S}"/src
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_enable gmp) \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- --enable-shared \
- --enable-custom-flags COFLAGS="${CFLAGS}"
-}
-
-src_compile() {
- cd "${S}"/src
- emake || die "emake failed"
-
- if ! use minimal ; then
- local jpltestconf
- if use java && use test ; then
- jpltestconf="--with-junit=$(java-config --classpath junit)"
- fi
-
- cd "${S}/packages"
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_with archive) \
- --with-chr \
- --with-clib \
- --with-clpqr \
- --with-cpp \
- --with-http \
- $(use_with java jpl) \
- ${jpltestconf} \
- --with-nlp \
- $(use_with odbc) \
- --with-PDT \
- --with-pldoc \
- --with-plunit \
- --with-protobufs \
- --with-R \
- --with-RDF \
- --with-semweb \
- --with-sgml \
- $(use_with ssl) \
- --with-table \
- --with-tipc \
- --with-utf8proc \
- $(use_with X xpce) \
- $(use_with zlib) \
- COFLAGS='"${CFLAGS}"'
-
- emake || die "packages emake failed"
- fi
-}
-
-src_test() {
- cd "${S}/src"
- emake check || die "make check failed. See above for details."
-
- if ! use minimal ; then
- cd "${S}/packages"
- emake check || die "make check failed. See above for details."
- fi
-}
-
-src_install() {
- emake -C src DESTDIR="${D}" install || die "install src failed"
-
- if ! use minimal ; then
- emake -C packages DESTDIR="${D}" install || die "install packages failed"
- if use doc ; then
- emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
- fi
- fi
-
- dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION || die
-}
diff --git a/dev-lang/swi-prolog/swi-prolog-6.1.8.ebuild b/dev-lang/swi-prolog/swi-prolog-6.1.8.ebuild
deleted file mode 100644
index 3c6896e0e1d7..000000000000
--- a/dev-lang/swi-prolog/swi-prolog-6.1.8.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-6.1.8.ebuild,v 1.1 2012/07/01 07:37:58 keri Exp $
-
-EAPI=2
-
-inherit eutils flag-o-matic java-pkg-opt-2 multilib
-
-PATCHSET_VER="0"
-
-DESCRIPTION="free, small, and standard compliant Prolog compiler"
-HOMEPAGE="http://www.swi-prolog.org/"
-SRC_URI="http://www.swi-prolog.org/download/devel/src/pl-${PV}.tar.gz
- mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="archive debug doc gmp hardened java minimal odbc readline ssl static-libs test zlib X"
-
-RDEPEND="sys-libs/ncurses
- archive? ( app-arch/libarchive )
- zlib? ( sys-libs/zlib )
- odbc? ( dev-db/unixODBC )
- readline? ( sys-libs/readline )
- gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )
- java? ( >=virtual/jdk-1.4 )
- X? (
- virtual/jpeg
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- java? ( test? ( =dev-java/junit-3.8* ) )"
-
-S="${WORKDIR}/pl-${PV}"
-
-src_prepare() {
- EPATCH_FORCE=yes
- EPATCH_SUFFIX=patch
- epatch "${WORKDIR}"/${PV}
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- use ppc && append-flags -mno-altivec
- use hardened && append-flags -fno-unit-at-a-time
- use debug && append-flags -DO_DEBUG
-
- cd "${S}"/src
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_enable gmp) \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- --enable-shared \
- --enable-custom-flags COFLAGS="${CFLAGS}"
-}
-
-src_compile() {
- cd "${S}"/src
- emake || die "emake failed"
-
- if ! use minimal ; then
- local jpltestconf
- if use java && use test ; then
- jpltestconf="--with-junit=$(java-config --classpath junit)"
- fi
-
- cd "${S}/packages"
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_with archive) \
- --with-chr \
- --with-clib \
- --with-clpqr \
- --with-cpp \
- --with-http \
- $(use_with java jpl) \
- ${jpltestconf} \
- --with-nlp \
- $(use_with odbc) \
- --with-PDT \
- --with-pldoc \
- --with-plunit \
- --with-protobufs \
- --with-R \
- --with-RDF \
- --with-semweb \
- --with-sgml \
- $(use_with ssl) \
- --with-table \
- --with-tipc \
- --with-utf8proc \
- $(use_with X xpce) \
- $(use_with zlib) \
- COFLAGS='"${CFLAGS}"'
-
- emake || die "packages emake failed"
- fi
-}
-
-src_test() {
- cd "${S}/src"
- emake check || die "make check failed. See above for details."
-
- if ! use minimal ; then
- cd "${S}/packages"
- emake check || die "make check failed. See above for details."
- fi
-}
-
-src_install() {
- emake -C src DESTDIR="${D}" install || die "install src failed"
-
- if ! use minimal ; then
- emake -C packages DESTDIR="${D}" install || die "install packages failed"
- if use doc ; then
- emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
- fi
- fi
-
- dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION || die
-}
diff --git a/dev-lang/swi-prolog/swi-prolog-6.1.9.ebuild b/dev-lang/swi-prolog/swi-prolog-6.1.9.ebuild
deleted file mode 100644
index 1b361d800d68..000000000000
--- a/dev-lang/swi-prolog/swi-prolog-6.1.9.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-6.1.9.ebuild,v 1.1 2012/08/02 12:47:50 keri Exp $
-
-EAPI=2
-
-inherit eutils flag-o-matic java-pkg-opt-2 multilib
-
-PATCHSET_VER="0"
-
-DESCRIPTION="free, small, and standard compliant Prolog compiler"
-HOMEPAGE="http://www.swi-prolog.org/"
-SRC_URI="http://www.swi-prolog.org/download/devel/src/pl-${PV}.tar.gz
- mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="archive debug doc gmp hardened java minimal odbc readline ssl static-libs test zlib X"
-
-RDEPEND="sys-libs/ncurses
- archive? ( app-arch/libarchive )
- zlib? ( sys-libs/zlib )
- odbc? ( dev-db/unixODBC )
- readline? ( sys-libs/readline )
- gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )
- java? ( >=virtual/jdk-1.4 )
- X? (
- virtual/jpeg
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- java? ( test? ( =dev-java/junit-3.8* ) )"
-
-S="${WORKDIR}/pl-${PV}"
-
-src_prepare() {
- EPATCH_FORCE=yes
- EPATCH_SUFFIX=patch
- epatch "${WORKDIR}"/${PV}
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- use ppc && append-flags -mno-altivec
- use hardened && append-flags -fno-unit-at-a-time
- use debug && append-flags -DO_DEBUG
-
- cd "${S}"/src
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_enable gmp) \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- --enable-shared \
- --enable-custom-flags COFLAGS="${CFLAGS}"
-}
-
-src_compile() {
- cd "${S}"/src
- emake || die "emake failed"
-
- if ! use minimal ; then
- local jpltestconf
- if use java && use test ; then
- jpltestconf="--with-junit=$(java-config --classpath junit)"
- fi
-
- cd "${S}/packages"
- econf \
- --libdir=/usr/$(get_libdir) \
- $(use_with archive) \
- --with-chr \
- --with-clib \
- --with-clpqr \
- --with-cpp \
- --with-http \
- $(use_with java jpl) \
- ${jpltestconf} \
- --with-nlp \
- $(use_with odbc) \
- --with-PDT \
- --with-pldoc \
- --with-plunit \
- --with-protobufs \
- --with-R \
- --with-RDF \
- --with-semweb \
- --with-sgml \
- $(use_with ssl) \
- --with-table \
- --with-tipc \
- --with-utf8proc \
- $(use_with X xpce) \
- $(use_with zlib) \
- COFLAGS='"${CFLAGS}"'
-
- emake || die "packages emake failed"
- fi
-}
-
-src_test() {
- cd "${S}/src"
- emake check || die "make check failed. See above for details."
-
- if ! use minimal ; then
- cd "${S}/packages"
- emake check || die "make check failed. See above for details."
- fi
-}
-
-src_install() {
- emake -C src DESTDIR="${D}" install || die "install src failed"
-
- if ! use minimal ; then
- emake -C packages DESTDIR="${D}" install || die "install packages failed"
- if use doc ; then
- emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
- fi
- fi
-
- dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION || die
-}