summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-08-08 15:57:56 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-08-08 15:57:56 +0000
commitb6f43918a668caf18b02a970fc4f97601fa8508b (patch)
treeb9fa4bc8976108921366da3c288c9f7facaf90fb /dev-lang
parentalpha/ia64 stable wrt #176297 (diff)
downloadgentoo-2-b6f43918a668caf18b02a970fc4f97601fa8508b.tar.gz
gentoo-2-b6f43918a668caf18b02a970fc4f97601fa8508b.tar.bz2
gentoo-2-b6f43918a668caf18b02a970fc4f97601fa8508b.zip
SplitObjs=NO while using >=gcc-4.2 in GHC 6.6.
(Portage version: 2.1.3.1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-6.6.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 5bb2612f2632..4b4d101c69db 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.131 2007/07/28 13:36:16 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.132 2007/08/08 15:57:56 kolmodin Exp $
+
+ 08 Aug 2007; Lennart Kolmodin <kolmodin@gentoo.org> ghc-6.6.ebuild:
+ Set SplitObjs=NO if >=gcc-4.2 is used.
28 Jul 2007; Lennart Kolmodin <kolmodin@gentoo.org> ghc-6.6.1.ebuild:
Disable the split objects feature when using >=gcc-4.2.
diff --git a/dev-lang/ghc/ghc-6.6.ebuild b/dev-lang/ghc/ghc-6.6.ebuild
index e875c0308654..8d73bbfa2d7c 100644
--- a/dev-lang/ghc/ghc-6.6.ebuild
+++ b/dev-lang/ghc/ghc-6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.ebuild,v 1.11 2007/07/25 18:30:23 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.ebuild,v 1.12 2007/08/08 15:57:56 kolmodin Exp $
# Brief explanation of the bootstrap logic:
#
@@ -28,7 +28,7 @@
# re-emerge ghc (or ghc-bin). People using vanilla gcc can switch between
# gcc-3.x and 4.x with no problems.
-inherit base eutils flag-o-matic toolchain-funcs ghc-package
+inherit base eutils flag-o-matic toolchain-funcs ghc-package versionator
DESCRIPTION="The Glasgow Haskell Compiler"
HOMEPAGE="http://www.haskell.org/ghc/"
@@ -241,6 +241,11 @@ src_compile() {
echo "GhcNotThreaded=YES" >> mk/build.mk
fi
+ # GHC <6.8 doesn't support GCC >=4.2, split objects fails.
+ if version_is_at_least "4.2" "$(gcc-version)"; then
+ echo "SplitObjs=NO" >> mk/build.mk
+ fi
+
# Get ghc from the unpacked binary .tbz2
# except when bootstrapping we just pick ghc up off the path
use ghcbootstrap || \
@@ -262,7 +267,6 @@ src_install() {
doenvd "${FILESDIR}/10ghc"
else
-
# the libdir0 setting is needed for amd64, and does not
# harm for other arches
#TODO: are any of these overrides still required? isn't econf enough?