summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-05 21:22:03 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-05 21:22:03 +0000
commitb344a8f443caf314a3f8403beb2939660c3117c3 (patch)
treed9af1399332cb9834fe8e05ab8a683c97cb0d272 /dev-lang
parentx86 stable, bug #337513 (diff)
downloadgentoo-2-b344a8f443caf314a3f8403beb2939660c3117c3.tar.gz
gentoo-2-b344a8f443caf314a3f8403beb2939660c3117c3.tar.bz2
gentoo-2-b344a8f443caf314a3f8403beb2939660c3117c3.zip
Update 9999 ebuild for using git (bug #339230), thanks a lot to Alistair Bush for his help.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/files/mono-9999-libdir.patch69
-rw-r--r--dev-lang/mono/mono-9999.ebuild59
3 files changed, 106 insertions, 29 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 2140fb612274..bc5efa2214b2 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.198 2010/09/23 22:14:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.199 2010/10/05 21:22:03 pacho Exp $
+
+ 05 Oct 2010; Pacho Ramos <pacho@gentoo.org> mono-9999.ebuild,
+ +files/mono-9999-libdir.patch:
+ Update 9999 ebuild for using git (bug #339230), thanks a lot to Alistair
+ Bush for his help.
23 Sep 2010; Markos Chandras <hwoarang@gentoo.org> mono-2.6.7.ebuild:
Stable on amd64 wrt bug #336851
diff --git a/dev-lang/mono/files/mono-9999-libdir.patch b/dev-lang/mono/files/mono-9999-libdir.patch
new file mode 100644
index 000000000000..6dd6bb51437b
--- /dev/null
+++ b/dev-lang/mono/files/mono-9999-libdir.patch
@@ -0,0 +1,69 @@
+diff -Naur mono-9999.bak/mono/mcs/tools/gacutil/driver.cs mono-9999/mono/mcs/tools/gacutil/driver.cs
+--- mono-9999.bak/mono/mcs/tools/gacutil/driver.cs 2010-07-03 04:58:15.000000000 +1200
++++ mono-9999/mono/mcs/tools/gacutil/driver.cs 2010-07-03 05:13:01.000000000 +1200
+@@ -808,7 +808,7 @@
+ private static string EnsureLib (string dir)
+ {
+ DirectoryInfo d = new DirectoryInfo (dir);
+- if (d.Name == "lib")
++ if (d.Name == "lib" || d.Name == "@MONOLIBDIR@")
+ return dir;
+ return Path.Combine (dir, "lib");
+ }
+diff -Naur mono-9999.bak/mono/mono/metadata/assembly.c mono-9999/mono/mono/metadata/assembly.c
+--- mono-9999.bak/mono/mono/metadata/assembly.c 2010-07-03 04:58:14.000000000 +1200
++++ mono-9999/mono/mono/metadata/assembly.c 2010-07-03 05:11:47.000000000 +1200
+@@ -542,7 +542,7 @@
+ }
+
+ config = g_build_filename (base, "etc", NULL);
+- lib = g_build_filename (base, "lib", NULL);
++ lib = g_build_filename (base, "@MONOLIBDIR@", NULL);
+ mono = g_build_filename (lib, "mono/1.0", NULL);
+ if (stat (mono, &buf) == -1)
+ fallback ();
+@@ -595,7 +595,7 @@
+
+ bindir = g_path_get_dirname (name);
+ installdir = g_path_get_dirname (bindir);
+- root = g_build_path (G_DIR_SEPARATOR_S, installdir, "lib", NULL);
++ root = g_build_path (G_DIR_SEPARATOR_S, installdir, "@MONOLIBDIR@", NULL);
+
+ config = g_build_filename (root, "..", "etc", NULL);
+ #ifdef HOST_WIN32
+@@ -2066,7 +2066,7 @@
+ if (extra_gac_paths) {
+ paths = extra_gac_paths;
+ while (!res && *paths) {
+- gacpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "lib", "mono", "gac", aname->name, NULL);
++ gacpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "@MONOLIBDIR@", "mono", "gac", aname->name, NULL);
+ res = probe_for_partial_name (gacpath, fullname, aname, status);
+ g_free (gacpath);
+ paths++;
+@@ -2117,7 +2117,7 @@
+ if (*gp != G_DIR_SEPARATOR)
+ continue;
+ gp++;
+- if (strncmp (gp, "lib", 3))
++ if (strncmp (gp, "@MONOLIBDIR@", 3))
+ continue;
+ gp += 3;
+ if (*gp != G_DIR_SEPARATOR)
+@@ -2196,7 +2196,7 @@
+ paths = extra_gac_paths;
+ while (!image && *paths) {
+ fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths,
+- "lib", "mono", "gac", subpath, NULL);
++ "@MONOLIBDIR@", "mono", "gac", subpath, NULL);
+ image = mono_image_open (fullpath, NULL);
+ g_free (fullpath);
+ paths++;
+@@ -2488,7 +2488,7 @@
+ if (extra_gac_paths) {
+ paths = extra_gac_paths;
+ while (!result && *paths) {
+- fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "lib", "mono", "gac", subpath, NULL);
++ fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "@MONOLIBDIR@", "mono", "gac", subpath, NULL);
+ result = mono_assembly_open_full (fullpath, status, refonly);
+ g_free (fullpath);
+ paths++;
diff --git a/dev-lang/mono/mono-9999.ebuild b/dev-lang/mono/mono-9999.ebuild
index 7f0c3b42d500..f26845939f1f 100644
--- a/dev-lang/mono/mono-9999.ebuild
+++ b/dev-lang/mono/mono-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.3 2010/01/31 19:54:46 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.4 2010/10/05 21:22:03 pacho Exp $
EAPI=2
-inherit linux-info mono eutils flag-o-matic multilib go-mono
+inherit linux-info mono eutils flag-o-matic multilib go-mono pax-utils
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.go-mono.com"
@@ -12,30 +12,28 @@ HOMEPAGE="http://www.go-mono.com"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
KEYWORDS=""
-IUSE="xen moonlight minimal"
+IUSE="hardened xen moonlight minimal"
#Bash requirement is for += operator
COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
!dev-util/monodoc
- dev-libs/glib:2
+ >=dev-libs/glib-2.4:2
!minimal? ( =dev-dotnet/libgdiplus-${GO_MONO_REL_PV}* )
- ia64? (
- sys-libs/libunwind
- )"
+ ia64? ( sys-libs/libunwind )"
RDEPEND="${COMMONDEPEND}
|| ( www-client/links www-client/lynx )"
DEPEND="${COMMONDEPEND}
sys-devel/bc
- >=app-shells/bash-3.2"
-PDEPEND="dev-dotnet/pe-format"
+ >=app-shells/bash-3.2
+ hardened? ( sys-apps/paxctl )"
MAKEOPTS="${MAKEOPTS} -j1"
RESTRICT="test"
PATCHES=(
- "${WORKDIR}/mono-2.2-libdir126.patch"
+ "${WORKDIR}/${P}-libdir.patch"
"${FILESDIR}/mono-2.2-ppc-threading.patch"
"${FILESDIR}/mono-2.2-uselibdir.patch"
)
@@ -43,10 +41,10 @@ PATCHES=(
pkg_setup() {
if ! has_version dev-lang/mono
then
- eerror "To compile the SVN version of mono, you must first have a working install of"
+ eerror "To compile the GIT version of mono, you must first have a working install of"
eerror "dev-lang/mono. Preferably one that is not too old relative to the branch you're"
eerror "trying to build."
- die "A working install of dev-lang/mono is required for building the SVN version."
+ die "A working install of dev-lang/mono is required for building the GIT version."
fi
if use kernel_linux
then
@@ -69,18 +67,19 @@ pkg_setup() {
fi
}
-src_unpack() {
- subversion_fetch "${ESVN_REPO_URI}" mono || die "subversion_fetch mono failed"
- subversion_fetch "${ESVN_REPO_URI%/mono}/mcs" mono/mcs || die "subversion_fetch mcs failed"
- S="${WORKDIR}/${P}/mono"
-}
-
src_prepare() {
sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
- < "${FILESDIR}"/mono-2.2-libdir126.patch \
- > "${WORKDIR}"/mono-2.2-libdir126.patch ||
+ < "${FILESDIR}"/${P}-libdir.patch \
+ > "${WORKDIR}"/${P}-libdir.patch ||
die "Sedding patch file failed"
go-mono_src_prepare
+
+ # we need to sed in the paxctl -m in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTEC is enable. #286280
+ if use hardened ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+ sed '/exec/ i\paxctl -m "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
+ fi
}
src_configure() {
@@ -92,18 +91,18 @@ src_configure() {
#NOTE: We need the static libs for now so mono-debugger works.
#See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
+
+ #--with-glib=system configure: error: --with-glib=system is no longer supported as of Mono 2.8
+ #--static_mono=yes (default anyway)
+
go-mono_src_configure \
- --enable-static \
--disable-quiet-build \
- --with-preview \
- --with-glib=system \
$(use_with moonlight) \
--with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
$(use_with xen xen_opt) \
--without-ikvm-native \
--with-jit \
--disable-dtrace
-
}
src_test() {
@@ -126,6 +125,10 @@ src_install() {
"${D}"/usr/bin/mod || die "Failed to fix mod."
find "${D}"/usr/ -name '*nunit-docs*' -exec rm -rf '{}' '+' || die "Removing nunit .docs failed"
+
+ # Remove Jay to avoid colliding with dev-util/jay, the internal
+ # version is only used to build mcs.
+ rm -r "${D}"/usr/share/jay "${D}"/usr/bin/jay "${D}"/usr/share/man/man1/jay.1*
}
#THINK!!!! Before touching postrm and postinst
@@ -149,10 +152,10 @@ pkg_preinst() {
einfo "be advised that this is a known problem, which will now be fixed:"
ebegin "Found broken symlinks created by $(best_version dev-lang/mono), fixing"
for symlink in \
- "${ROOT}/${NUNIT_DIR}" \
- "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
- "${ROOT}/usr/bin/nunit-console" \
- "${ROOT}/usr/bin/nunit-console2"
+ "${ROOT}/${NUNIT_DIR}" \
+ "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
+ "${ROOT}/usr/bin/nunit-console" \
+ "${ROOT}/usr/bin/nunit-console2"
do
if [[ -L "${symlink}" ]]
then