summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-12-29 14:18:56 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-12-29 14:18:56 +0000
commitafdbb696726e1262e1e0c61f407c60bbd3c67eb0 (patch)
tree535a767bb827a2ff22299cbe79e285a7e0d909c4 /dev-lang
parentCall 'git submodule sync' as well to support the case when submodule URL chan... (diff)
downloadgentoo-2-afdbb696726e1262e1e0c61f407c60bbd3c67eb0.tar.gz
gentoo-2-afdbb696726e1262e1e0c61f407c60bbd3c67eb0.tar.bz2
gentoo-2-afdbb696726e1262e1e0c61f407c60bbd3c67eb0.zip
Version bump spidermonkey to 1.9.2.13 (bug 347914).
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/spidermonkey/ChangeLog9
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-1.9.2.13-as-needed.patch22
-rw-r--r--dev-lang/spidermonkey/metadata.xml10
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.9.2.13.ebuild73
4 files changed, 110 insertions, 4 deletions
diff --git a/dev-lang/spidermonkey/ChangeLog b/dev-lang/spidermonkey/ChangeLog
index e9343494738d..886aa30f2c37 100644
--- a/dev-lang/spidermonkey/ChangeLog
+++ b/dev-lang/spidermonkey/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/spidermonkey
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.47 2010/08/06 23:15:48 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.48 2010/12/29 14:18:56 djc Exp $
+
+*spidermonkey-1.9.2.13 (29 Dec 2010)
+
+ 29 Dec 2010; Dirkjan Ochtman <djc@gentoo.org>
+ +spidermonkey-1.9.2.13.ebuild,
+ +files/spidermonkey-1.9.2.13-as-needed.patch, metadata.xml:
+ Version bump to 1.9.2.13 (bug 347914).
*spidermonkey-1.7.0-r2 (06 Aug 2010)
diff --git a/dev-lang/spidermonkey/files/spidermonkey-1.9.2.13-as-needed.patch b/dev-lang/spidermonkey/files/spidermonkey-1.9.2.13-as-needed.patch
new file mode 100644
index 000000000000..847bf792c5b2
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-1.9.2.13-as-needed.patch
@@ -0,0 +1,22 @@
+diff --git a/js/src/jsapi-tests/Makefile.in b/js/src/jsapi-tests/Makefile.in
+--- a/js/src/jsapi-tests/Makefile.in
++++ b/js/src/jsapi-tests/Makefile.in
+@@ -55,17 +55,17 @@ CPPSRCS = \
+ testSameValue.cpp \
+ testDebugger.cpp \
+ testDefineGetterSetterNonEnumerable.cpp \
+ testExtendedEq.cpp \
+ $(NULL)
+
+ DEFINES += -DEXPORT_JS_API
+
+-LIBS = $(NSPR_LIBS) $(DEPTH)/$(LIB_PREFIX)js_static.$(LIB_SUFFIX)
++LIBS = $(DEPTH)/$(LIB_PREFIX)js_static.$(LIB_SUFFIX) $(NSPR_LIBS)
+
+ LOCAL_INCLUDES += -I$(topsrcdir) -I..
+
+ ifdef _MSC_VER
+ ifdef WINCE
+ WIN32_EXE_LDFLAGS += -ENTRY:mainACRTStartup
+ endif
+ endif
diff --git a/dev-lang/spidermonkey/metadata.xml b/dev-lang/spidermonkey/metadata.xml
index 64708559be1d..96a93a5c8bc5 100644
--- a/dev-lang/spidermonkey/metadata.xml
+++ b/dev-lang/spidermonkey/metadata.xml
@@ -1,11 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
<maintainer>
- <email>aballier@gentoo.org</email>
- <name>Alexis Ballier</name>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
</maintainer>
+ <maintainer>
+ <email>anarchy@gentoo.org</email>
+ <name>Jory A. Pratt</name>
+ </maintainer>
+ <herd>mozilla</herd>
<longdescription lang="en">
Stand-alone JavaScript C library
</longdescription>
diff --git a/dev-lang/spidermonkey/spidermonkey-1.9.2.13.ebuild b/dev-lang/spidermonkey/spidermonkey-1.9.2.13.ebuild
new file mode 100644
index 000000000000..7d6c123cd50c
--- /dev/null
+++ b/dev-lang/spidermonkey/spidermonkey-1.9.2.13.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.9.2.13.ebuild,v 1.1 2010/12/29 14:18:56 djc Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs multilib python
+
+MY_PV="${PV}"
+MY_PV="${MY_PV/1.9.2/3.6}"
+DESCRIPTION="Stand-alone JavaScript C library"
+HOMEPAGE="http://www.mozilla.org/js/spidermonkey/"
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases"
+SRC_URI="${REL_URI}/${MY_PV}/source/firefox-${MY_PV}.source.tar.bz2"
+
+LICENSE="NPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="threadsafe"
+
+S="${WORKDIR}/mozilla-1.9.2"
+BUILDDIR="${S}/js/src"
+
+RDEPEND="threadsafe? ( >=dev-libs/nspr-4.8.6 )"
+
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*[threads]
+ dev-util/pkgconfig"
+
+pkg_setup(){
+ python_set_active_version 2
+}
+
+src_prepare() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${PN}-1.9.2.13-as-needed.patch"
+
+ epatch_user
+
+ cd "${S}"
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ # Don't try to be smart, this does not work in cross-compile anyway
+ ln -s "${BUILDDIR}/config/Linux_All.mk" "${S}/config/$(uname -s)$(uname -r).mk"
+ fi
+}
+
+src_configure() {
+ cd ${BUILDDIR}
+
+ local myconf
+
+ if use threadsafe ; then
+ myconf="${myconf} --with-system-nspr \
+ --enable-threadsafe"
+ fi
+ # Disable no-print-directory
+ MAKEOPTS=${MAKEOPTS/--no-print-directory/}
+
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf \
+ ${myconf}
+}
+
+src_compile() {
+ cd ${BUILDDIR}
+ emake -j1 || die "emake failed";
+}
+
+src_install() {
+ cd ${BUILDDIR}
+ emake install DESTDIR="${D}" || die
+ dodoc ../jsd/README
+ dohtml README.html
+}