summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-19 21:23:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-19 21:23:15 +0000
commita2c36ccd48f06c02352d26eb294c109d4858bca6 (patch)
tree1458b2e30f144fd57fe6c82e0212b492f437b6d9 /dev-lang
parentPatch using C locale. Don't know if this is important. (diff)
downloadgentoo-2-a2c36ccd48f06c02352d26eb294c109d4858bca6.tar.gz
gentoo-2-a2c36ccd48f06c02352d26eb294c109d4858bca6.tar.bz2
gentoo-2-a2c36ccd48f06c02352d26eb294c109d4858bca6.zip
Call python_set_active_version() instead of manually setting PYTHON_ABI variable.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild6
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild6
-rw-r--r--dev-lang/python/python-2.6.4-r1.ebuild6
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild6
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild8
5 files changed, 22 insertions, 10 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index ef9482797902..093133bfe63d 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.35 2010/05/10 18:44:05 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.36 2010/05/19 21:23:15 arfrever Exp $
EAPI="1"
@@ -18,7 +18,6 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
-PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline +ssl +threads tk +wide-unicode wininst +xml"
@@ -48,6 +47,9 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
+ python_set_active_version ${SLOT}
+ python_pkg_setup
+
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index 9539e96fdc46..101ac3b63749 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.17 2010/05/10 18:44:05 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.18 2010/05/19 21:23:15 arfrever Exp $
EAPI="1"
@@ -18,7 +18,6 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
-PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -55,6 +54,9 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
+ python_set_active_version ${SLOT}
+ python_pkg_setup
+
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
diff --git a/dev-lang/python/python-2.6.4-r1.ebuild b/dev-lang/python/python-2.6.4-r1.ebuild
index d35cabea53b1..ceda683555ba 100644
--- a/dev-lang/python/python-2.6.4-r1.ebuild
+++ b/dev-lang/python/python-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.9 2010/03/20 20:33:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.10 2010/05/19 21:23:15 arfrever Exp $
EAPI="2"
@@ -18,7 +18,6 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
-PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -58,6 +57,9 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
+ python_set_active_version ${SLOT}
+ python_pkg_setup
+
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index 81f7552a8a2d..33d46d534d8c 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.5 2010/05/14 16:18:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.6 2010/05/19 21:23:15 arfrever Exp $
EAPI="2"
@@ -18,7 +18,6 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
-PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -58,6 +57,9 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
+ python_set_active_version ${SLOT}
+ python_pkg_setup
+
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index cdf0e4f9ed2f..9a527088369d 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.4 2010/05/10 18:44:05 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.5 2010/05/19 21:23:15 arfrever Exp $
EAPI="3"
@@ -18,7 +18,6 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="3.1"
-PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -47,6 +46,11 @@ PDEPEND=">=app-admin/python-updater-0.8
PROVIDE="virtual/python"
+pkg_setup() {
+ python_set_active_version ${SLOT}
+ python_pkg_setup
+}
+
src_prepare() {
# Ensure that internal copies of expat, libffi and zlib are not used.
rm -fr Modules/expat