summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2012-12-14 15:40:55 +0000
committerKeri Harris <keri@gentoo.org>2012-12-14 15:40:55 +0000
commit9fe62955311da667e5d7d1348376a830b73bc636 (patch)
tree2221c4cd80cd62574841eac7b635bb1f04f15390 /dev-lang
parentRemove redundant USE=upnp description; it matches the global flag meaning. (diff)
downloadgentoo-2-9fe62955311da667e5d7d1348376a830b73bc636.tar.gz
gentoo-2-9fe62955311da667e5d7d1348376a830b73bc636.tar.bz2
gentoo-2-9fe62955311da667e5d7d1348376a830b73bc636.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key A138F5ED)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swi-prolog/ChangeLog7
-rw-r--r--dev-lang/swi-prolog/swi-prolog-6.2.4.ebuild140
2 files changed, 146 insertions, 1 deletions
diff --git a/dev-lang/swi-prolog/ChangeLog b/dev-lang/swi-prolog/ChangeLog
index 401e9c88fb35..28f6a819cd70 100644
--- a/dev-lang/swi-prolog/ChangeLog
+++ b/dev-lang/swi-prolog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swi-prolog
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.361 2012/12/12 14:38:01 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.362 2012/12/14 15:40:55 keri Exp $
+
+*swi-prolog-6.2.4 (14 Dec 2012)
+
+ 14 Dec 2012; <keri@gentoo.org> +swi-prolog-6.2.4.ebuild:
+ Version bump
*swi-prolog-6.2.3 (12 Dec 2012)
diff --git a/dev-lang/swi-prolog/swi-prolog-6.2.4.ebuild b/dev-lang/swi-prolog/swi-prolog-6.2.4.ebuild
new file mode 100644
index 000000000000..c66601444132
--- /dev/null
+++ b/dev-lang/swi-prolog/swi-prolog-6.2.4.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-6.2.4.ebuild,v 1.1 2012/12/14 15:40:55 keri Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic java-pkg-opt-2 multilib
+
+PATCHSET_VER="0"
+
+DESCRIPTION="free, small, and standard compliant Prolog compiler"
+HOMEPAGE="http://www.swi-prolog.org/"
+SRC_URI="http://www.swi-prolog.org/download/stable/src/pl-${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="archive debug doc gmp hardened java minimal odbc readline ssl static-libs test zlib X"
+
+RDEPEND="sys-libs/ncurses
+ archive? ( app-arch/libarchive )
+ zlib? ( sys-libs/zlib )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline )
+ gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4 )
+ X? (
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ java? ( test? ( =dev-java/junit-3.8* ) )"
+
+S="${WORKDIR}/pl-${PV}"
+
+src_prepare() {
+ EPATCH_FORCE=yes
+ EPATCH_SUFFIX=patch
+ epatch "${WORKDIR}"/${PV}
+
+ # OSX/Intel ld doesn't like an archive without table of contents
+ sed -i -e 's/-cru/-scru/' packages/nlp/libstemmer_c/Makefile.pl || die
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ use ppc && append-flags -mno-altivec
+ use hardened && append-flags -fno-unit-at-a-time
+ use debug && append-flags -DO_DEBUG
+
+ # ARCH is used in the configure script to figure out host and target
+ # specific stuff
+ export ARCH=${CHOST}
+
+ cd "${S}"/src
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable gmp) \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ --enable-shared \
+ --enable-custom-flags COFLAGS="${CFLAGS}"
+
+ if ! use minimal ; then
+ local jpltestconf
+ if use java && use test ; then
+ jpltestconf="--with-junit=$(java-config --classpath junit)"
+ fi
+
+ cd "${S}/packages"
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_with archive) \
+ --with-chr \
+ --with-clib \
+ --with-clpqr \
+ --with-cpp \
+ --with-http \
+ $(use_with java jpl) \
+ ${jpltestconf} \
+ --with-nlp \
+ $(use_with odbc) \
+ --with-PDT \
+ --with-pldoc \
+ --with-plunit \
+ --with-protobufs \
+ --with-R \
+ --with-RDF \
+ --with-semweb \
+ --with-sgml \
+ $(use_with ssl) \
+ --with-table \
+ --with-tipc \
+ --with-utf8proc \
+ $(use_with X xpce) \
+ $(use_with zlib) \
+ COFLAGS='"${CFLAGS}"'
+ fi
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake
+
+ if ! use minimal ; then
+ cd "${S}/packages"
+ emake
+ fi
+}
+
+src_test() {
+ cd "${S}/src"
+ emake check
+
+ if ! use minimal ; then
+ cd "${S}/packages"
+ emake check
+ fi
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+
+ if ! use minimal ; then
+ emake -C packages DESTDIR="${D}" install
+ if use doc ; then
+ emake -C packages DESTDIR="${D}" html-install
+ fi
+ fi
+
+ dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION
+}