summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-19 19:15:14 +0000
committerTod Neidt <tod@gentoo.org>2002-02-19 19:15:14 +0000
commit9e93a810ea5342d1e638958ea57d3f76ceeeef60 (patch)
tree164599da661fc82ce8e95ae88eb7e0cbbbe416a5 /dev-lang
parentFixed Header strings. (diff)
downloadgentoo-2-9e93a810ea5342d1e638958ea57d3f76ceeeef60.tar.gz
gentoo-2-9e93a810ea5342d1e638958ea57d3f76ceeeef60.tar.bz2
gentoo-2-9e93a810ea5342d1e638958ea57d3f76ceeeef60.zip
Initial commit. Gnu octave is a high-level language, primarily intended for numerical computations. It is mostly MatLab compatible.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/octave/ChangeLog11
-rw-r--r--dev-lang/octave/files/digest-octave-2.0.161
-rw-r--r--dev-lang/octave/octave-2.0.16.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-lang/octave/ChangeLog b/dev-lang/octave/ChangeLog
new file mode 100644
index 000000000000..bfb3a81913a6
--- /dev/null
+++ b/dev-lang/octave/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/octave/ChangeLog,v 1.1 2002/02/19 19:15:14 tod Exp $
+
+*octave-2.0.16 (19 Feb 2002)
+
+ 19 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, octave-2.0.16.ebuild :
+
+ Initial commit. GNU Octave is a high-level language, primarily intended
+ for numerical computations. It is mostly compatible with Matlab.
+
diff --git a/dev-lang/octave/files/digest-octave-2.0.16 b/dev-lang/octave/files/digest-octave-2.0.16
new file mode 100644
index 000000000000..e4495104242d
--- /dev/null
+++ b/dev-lang/octave/files/digest-octave-2.0.16
@@ -0,0 +1 @@
+MD5 439e8e70706c875149836146d1ccebe0 octave-2.0.16.tar.bz2 3009214
diff --git a/dev-lang/octave/octave-2.0.16.ebuild b/dev-lang/octave/octave-2.0.16.ebuild
new file mode 100644
index 000000000000..9ad1255c2a8b
--- /dev/null
+++ b/dev-lang/octave/octave-2.0.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/octave/octave-2.0.16.ebuild,v 1.1 2002/02/19 19:15:14 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+
+SRC_URI="ftp://ftp.octave.org/pub/octave/${P}.tar.bz2"
+
+HOMEPAGE="http://www.octave.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1"
+
+src_compile() {
+
+ local myconf="--enable-shared --enable-dl --enable-lite-kernel"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc BUGS COPYING ChangeLog* INSTALL* NEWS* PROJECTS README* ROADMAP \
+ SENDING-PATCHES THANKS
+
+}