summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-07-20 07:28:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-07-20 07:28:17 +0000
commit9cf829c2a9127c1a1559f1c5e8816d1f0f5c8d73 (patch)
treee877f39558a0deda84cebd67afd3a510d974d537 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-9cf829c2a9127c1a1559f1c5e8816d1f0f5c8d73.tar.gz
gentoo-2-9cf829c2a9127c1a1559f1c5e8816d1f0f5c8d73.tar.bz2
gentoo-2-9cf829c2a9127c1a1559f1c5e8816d1f0f5c8d73.zip
Version bump
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ekopath-bin/ChangeLog8
-rw-r--r--dev-lang/ekopath-bin/ekopath-bin-4.0.10_pre20110717.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-lang/ekopath-bin/ChangeLog b/dev-lang/ekopath-bin/ChangeLog
index 16ffa41cdea5..ba72002cb999 100644
--- a/dev-lang/ekopath-bin/ChangeLog
+++ b/dev-lang/ekopath-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ekopath-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath-bin/ChangeLog,v 1.1 2011/06/15 08:27:06 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath-bin/ChangeLog,v 1.2 2011/07/20 07:28:17 xarthisius Exp $
+
+*ekopath-bin-4.0.10_pre20110717 (20 Jul 2011)
+
+ 20 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ +ekopath-bin-4.0.10_pre20110717.ebuild:
+ Version bump
*ekopath-bin-4.0.10_pre20110612 (15 Jun 2011)
diff --git a/dev-lang/ekopath-bin/ekopath-bin-4.0.10_pre20110717.ebuild b/dev-lang/ekopath-bin/ekopath-bin-4.0.10_pre20110717.ebuild
new file mode 100644
index 000000000000..2f4b85b5dbec
--- /dev/null
+++ b/dev-lang/ekopath-bin/ekopath-bin-4.0.10_pre20110717.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath-bin/ekopath-bin-4.0.10_pre20110717.ebuild,v 1.1 2011/07/20 07:28:17 xarthisius Exp $
+
+EAPI=4
+
+inherit versionator
+
+MY_PN=${PN/-bin}
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE/pre}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${MY_PN}/nightly/Linux/${MY_PN}-${DATE}-installer.run
+ -> ${P}.run"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S=${WORKDIR}
+
+PATHSCALE_SDP_DIR=/opt/${P}
+
+QA_PREBUILT="
+ ${PATHSCALE_SDP_DIR}/lib/${MY_PV}/x8664/*
+ ${PATHSCALE_SDP_DIR}/bin/pathcc*
+ ${PATHSCALE_SDP_DIR}/bin/pathas
+ ${PATHSCALE_SDP_DIR}/bin/assign"
+
+pkg_pretend() {
+ if has_version app-arch/rpm ; then
+ ewarn "You have app-arch/rpm installed on your system. Therefore"
+ ewarn "${PN} will fail to install due to sandbox violation."
+ ewarn "As this cannot be fixed on distribution level, please use"
+ ewarn "following workaround:"
+ ewarn " emerge -C rpm && emerge -1 ${PN} && emerge -1 rpm"
+ die
+ fi
+}
+
+src_prepare() {
+ cat > "99${PN}" <<-EOF
+ PATH=/opt/${P}/bin
+ ROOTPATH=/opt/${P}/bin
+ LDPATH=/opt/${P}/lib
+ EOF
+}
+
+src_install() {
+ "${DISTDIR}"/${P}.run \
+ --prefix "${D}/opt/${P}" \
+ --mode unattended || die
+ rm -rf "${D}"/opt/${P}/uninstall || die
+ doenvd "99${PN}"
+}