summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-09 17:48:03 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-09 17:48:03 +0000
commit976b1a44141ef649d264d51cf7f3bbbfcc42dbb7 (patch)
treee1e99b70e0ec3a1e69f83063e32eda69c51f5be8 /dev-lang
parentVersion bump #469138 by Antonio Quartulli. (diff)
downloadgentoo-2-976b1a44141ef649d264d51cf7f3bbbfcc42dbb7.tar.gz
gentoo-2-976b1a44141ef649d264d51cf7f3bbbfcc42dbb7.tar.bz2
gentoo-2-976b1a44141ef649d264d51cf7f3bbbfcc42dbb7.zip
Add epatch_user wrt bug #447714.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.5.4-r5.ebuild4
-rw-r--r--dev-lang/python/python-2.6.8-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.7.4.ebuild4
-rw-r--r--dev-lang/python/python-3.1.5-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.2.4.ebuild4
-rw-r--r--dev-lang/python/python-3.3.1.ebuild4
7 files changed, 24 insertions, 7 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 29e3730a980a..046cb2b5dfee 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.654 2013/05/01 02:57:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.655 2013/05/09 17:48:03 mgorny Exp $
+
+ 09 May 2013; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
+ python-2.6.8-r1.ebuild, python-2.7.4.ebuild, python-3.1.5-r1.ebuild,
+ python-3.2.4.ebuild, python-3.3.1.ebuild:
+ Add epatch_user wrt bug #447714.
01 May 2013; Mike Gilbert <floppym@gentoo.org> python-3.2.4.ebuild:
Enable byte-compilation during tests.
diff --git a/dev-lang/python/python-2.5.4-r5.ebuild b/dev-lang/python/python-2.5.4-r5.ebuild
index ef8cc288c256..cd71824191f5 100644
--- a/dev-lang/python/python-2.5.4-r5.ebuild
+++ b/dev-lang/python/python-2.5.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.19 2013/04/13 20:54:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.20 2013/05/09 17:48:03 mgorny Exp $
EAPI="1"
@@ -104,6 +104,8 @@ src_unpack() {
# Linux-3 compat. Bug #374579 (upstream issue12571)
cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
+ epatch_user
+
eautoreconf
}
diff --git a/dev-lang/python/python-2.6.8-r1.ebuild b/dev-lang/python/python-2.6.8-r1.ebuild
index 0c37ac4809d9..b711dee59e94 100644
--- a/dev-lang/python/python-2.6.8-r1.ebuild
+++ b/dev-lang/python/python-2.6.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.19 2013/04/13 20:54:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.20 2013/05/09 17:48:03 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -102,6 +102,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+ epatch_user
+
eautoconf
eautoheader
}
diff --git a/dev-lang/python/python-2.7.4.ebuild b/dev-lang/python/python-2.7.4.ebuild
index 05f0c64baa2d..df1f86bcb4ae 100644
--- a/dev-lang/python/python-2.7.4.ebuild
+++ b/dev-lang/python/python-2.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.4.ebuild,v 1.6 2013/05/01 02:16:37 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.4.ebuild,v 1.7 2013/05/09 17:48:03 mgorny Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -109,6 +109,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+ epatch_user
+
eautoconf
eautoheader
}
diff --git a/dev-lang/python/python-3.1.5-r1.ebuild b/dev-lang/python/python-3.1.5-r1.ebuild
index 679a32db7bc9..18b80ab8a67f 100644
--- a/dev-lang/python/python-3.1.5-r1.ebuild
+++ b/dev-lang/python/python-3.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.18 2013/04/13 20:54:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.19 2013/05/09 17:48:03 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -78,6 +78,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+ epatch_user
+
eautoconf
eautoheader
}
diff --git a/dev-lang/python/python-3.2.4.ebuild b/dev-lang/python/python-3.2.4.ebuild
index c369c263d39b..93afcbc98e30 100644
--- a/dev-lang/python/python-3.2.4.ebuild
+++ b/dev-lang/python/python-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.4.ebuild,v 1.3 2013/05/01 02:57:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.4.ebuild,v 1.4 2013/05/09 17:48:03 mgorny Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -91,6 +91,8 @@ src_prepare() {
# Disable ABI flags.
sed -e "s/ABIFLAGS=\"\${ABIFLAGS}.*\"/:/" -i configure.ac || die "sed failed"
+ epatch_user
+
eautoconf
eautoheader
}
diff --git a/dev-lang/python/python-3.3.1.ebuild b/dev-lang/python/python-3.3.1.ebuild
index 1ab4dd968568..925cba998c1d 100644
--- a/dev-lang/python/python-3.3.1.ebuild
+++ b/dev-lang/python/python-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.1.ebuild,v 1.2 2013/04/29 04:40:26 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.1.ebuild,v 1.3 2013/05/09 17:48:03 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -78,6 +78,8 @@ src_prepare() {
# Disable ABI flags.
sed -e "s/ABIFLAGS=\"\${ABIFLAGS}.*\"/:/" -i configure.ac || die "sed failed"
+ epatch_user
+
eautoconf
eautoheader
}