summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2011-08-26 20:08:40 +0000
committerKeri Harris <keri@gentoo.org>2011-08-26 20:08:40 +0000
commit931344e49381dbdebe849e42d9fc9e0e14ca091b (patch)
treed02099b399c26e91154f69df1a9ec49534d56c85 /dev-lang
parentFix compilation on platforms without iconv in their libc, keyworded ~{x86,spa... (diff)
downloadgentoo-2-931344e49381dbdebe849e42d9fc9e0e14ca091b.tar.gz
gentoo-2-931344e49381dbdebe849e42d9fc9e0e14ca091b.tar.bz2
gentoo-2-931344e49381dbdebe849e42d9fc9e0e14ca091b.zip
Specify correct include-path in swipl.pc. Closes #380661
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swi-prolog/ChangeLog9
-rw-r--r--dev-lang/swi-prolog/swi-prolog-5.10.5-r1.ebuild125
-rw-r--r--dev-lang/swi-prolog/swi-prolog-5.11.26-r1.ebuild125
3 files changed, 258 insertions, 1 deletions
diff --git a/dev-lang/swi-prolog/ChangeLog b/dev-lang/swi-prolog/ChangeLog
index b9077c21bb36..54c92b2f7b86 100644
--- a/dev-lang/swi-prolog/ChangeLog
+++ b/dev-lang/swi-prolog/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/swi-prolog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.292 2011/08/21 00:58:39 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.293 2011/08/26 20:08:40 keri Exp $
+
+*swi-prolog-5.11.26-r1 (26 Aug 2011)
+*swi-prolog-5.10.5-r1 (26 Aug 2011)
+
+ 26 Aug 2011; <keri@gentoo.org> +swi-prolog-5.10.5-r1.ebuild,
+ +swi-prolog-5.11.26-r1.ebuild:
+ Specify correct include-path in swipl.pc. Closes #380661
*swi-prolog-5.10.5 (21 Aug 2011)
diff --git a/dev-lang/swi-prolog/swi-prolog-5.10.5-r1.ebuild b/dev-lang/swi-prolog/swi-prolog-5.10.5-r1.ebuild
new file mode 100644
index 000000000000..7de6c1fe6304
--- /dev/null
+++ b/dev-lang/swi-prolog/swi-prolog-5.10.5-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-5.10.5-r1.ebuild,v 1.1 2011/08/26 20:08:40 keri Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic java-pkg-opt-2
+
+PATCHSET_VER="1"
+
+DESCRIPTION="free, small, and standard compliant Prolog compiler"
+HOMEPAGE="http://www.swi-prolog.org/"
+SRC_URI="http://www.swi-prolog.org/download/stable/src/pl-${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc gmp hardened java minimal odbc readline ssl static test zlib X"
+
+RDEPEND="sys-libs/ncurses
+ zlib? ( sys-libs/zlib )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline )
+ gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4 )
+ X? (
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ java? ( test? ( =dev-java/junit-3.8* ) )"
+
+S="${WORKDIR}/pl-${PV}"
+
+src_prepare() {
+ EPATCH_FORCE=yes
+ EPATCH_SUFFIX=patch
+ epatch "${WORKDIR}"/${PV}
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ use ppc && append-flags -mno-altivec
+ use hardened && append-flags -fno-unit-at-a-time
+ use debug && append-flags -DO_DEBUG
+
+ cd "${S}"/src
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable gmp) \
+ $(use_enable readline) \
+ $(use_enable !static shared) \
+ --enable-custom-flags COFLAGS="${CFLAGS}"
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake || die "emake failed"
+
+ if ! use minimal ; then
+ local jpltestconf
+ if use java && use test ; then
+ jpltestconf="--with-junit=$(java-config --classpath junit)"
+ fi
+
+ cd "${S}/packages"
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --with-chr \
+ --with-clib \
+ --with-clpqr \
+ --with-cpp \
+ --with-http \
+ $(use_with java jpl) \
+ ${jpltestconf} \
+ --with-nlp \
+ $(use_with odbc) \
+ --with-pldoc \
+ --with-plunit \
+ --with-protobufs \
+ --with-R \
+ --with-RDF \
+ --with-semweb \
+ --with-sgml \
+ $(use_with ssl) \
+ --with-table \
+ --with-tipc \
+ $(use_with X xpce) \
+ $(use_with zlib) \
+ COFLAGS='"${CFLAGS}"'
+
+ emake || die "packages emake failed"
+ fi
+}
+
+src_test() {
+ cd "${S}/src"
+ emake check || die "make check failed. See above for details."
+
+ if ! use minimal ; then
+ cd "${S}/packages"
+ emake check || die "make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install || die "install src failed"
+
+ if ! use minimal ; then
+ emake -C packages DESTDIR="${D}" install || die "install packages failed"
+ if use doc ; then
+ emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
+ fi
+ fi
+
+ dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION || die
+}
diff --git a/dev-lang/swi-prolog/swi-prolog-5.11.26-r1.ebuild b/dev-lang/swi-prolog/swi-prolog-5.11.26-r1.ebuild
new file mode 100644
index 000000000000..b0873ff19748
--- /dev/null
+++ b/dev-lang/swi-prolog/swi-prolog-5.11.26-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-5.11.26-r1.ebuild,v 1.1 2011/08/26 20:08:40 keri Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic java-pkg-opt-2
+
+PATCHSET_VER="1"
+
+DESCRIPTION="free, small, and standard compliant Prolog compiler"
+HOMEPAGE="http://www.swi-prolog.org/"
+SRC_URI="http://www.swi-prolog.org/download/devel/src/pl-${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc gmp hardened java minimal odbc readline ssl static test zlib X"
+
+RDEPEND="sys-libs/ncurses
+ zlib? ( sys-libs/zlib )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline )
+ gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4 )
+ X? (
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ java? ( test? ( =dev-java/junit-3.8* ) )"
+
+S="${WORKDIR}/pl-${PV}"
+
+src_prepare() {
+ EPATCH_FORCE=yes
+ EPATCH_SUFFIX=patch
+ epatch "${WORKDIR}"/${PV}
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ use ppc && append-flags -mno-altivec
+ use hardened && append-flags -fno-unit-at-a-time
+ use debug && append-flags -DO_DEBUG
+
+ cd "${S}"/src
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable gmp) \
+ $(use_enable readline) \
+ $(use_enable !static shared) \
+ --enable-custom-flags COFLAGS="${CFLAGS}"
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake || die "emake failed"
+
+ if ! use minimal ; then
+ local jpltestconf
+ if use java && use test ; then
+ jpltestconf="--with-junit=$(java-config --classpath junit)"
+ fi
+
+ cd "${S}/packages"
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --with-chr \
+ --with-clib \
+ --with-clpqr \
+ --with-cpp \
+ --with-http \
+ $(use_with java jpl) \
+ ${jpltestconf} \
+ --with-nlp \
+ $(use_with odbc) \
+ --with-pldoc \
+ --with-plunit \
+ --with-protobufs \
+ --with-R \
+ --with-RDF \
+ --with-semweb \
+ --with-sgml \
+ $(use_with ssl) \
+ --with-table \
+ --with-tipc \
+ $(use_with X xpce) \
+ $(use_with zlib) \
+ COFLAGS='"${CFLAGS}"'
+
+ emake || die "packages emake failed"
+ fi
+}
+
+src_test() {
+ cd "${S}/src"
+ emake check || die "make check failed. See above for details."
+
+ if ! use minimal ; then
+ cd "${S}/packages"
+ emake check || die "make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install || die "install src failed"
+
+ if ! use minimal ; then
+ emake -C packages DESTDIR="${D}" install || die "install packages failed"
+ if use doc ; then
+ emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
+ fi
+ fi
+
+ dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION || die
+}