summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2004-06-20 17:50:22 +0000
committerRainer Groesslinger <scandium@gentoo.org>2004-06-20 17:50:22 +0000
commit8ee35935ca28177ea427fa8ad314f3579bf1c3a0 (patch)
treecc8d1eda19d99130c2e67e57a8896f1e51054e6e /dev-lang
parentremoving vulnerable versions (Manifest recommit) (diff)
downloadgentoo-2-8ee35935ca28177ea427fa8ad314f3579bf1c3a0.tar.gz
gentoo-2-8ee35935ca28177ea427fa8ad314f3579bf1c3a0.tar.bz2
gentoo-2-8ee35935ca28177ea427fa8ad314f3579bf1c3a0.zip
new version, some minor fixes/changes
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pike/ChangeLog7
-rw-r--r--dev-lang/pike/files/digest-pike-7.6.61
-rw-r--r--dev-lang/pike/pike-7.6.6.ebuild94
3 files changed, 101 insertions, 1 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index 5bb2b2b40fd2..f3cc14c59c61 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/pike
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.8 2004/03/27 14:37:38 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.9 2004/06/20 17:50:22 scandium Exp $
+
+*pike-7.6.6 (20 Jun 2004)
+
+ 20 Jun 2004; Rainer Groesslinger <scandium@gentoo.org> pike-7.6.6.ebuild:
+ new version, some minor fixes/changes
27 Mar 2004; Rainer Groesslinger <scandium@gentoo.org> pike-7.4.44.ebuild:
marked stable on x86 and ppc
diff --git a/dev-lang/pike/files/digest-pike-7.6.6 b/dev-lang/pike/files/digest-pike-7.6.6
new file mode 100644
index 000000000000..15056e35138a
--- /dev/null
+++ b/dev-lang/pike/files/digest-pike-7.6.6
@@ -0,0 +1 @@
+MD5 2a37d87be74fd488bd88bfe9b1554783 Pike-v7.6.6.tar.gz 7465431
diff --git a/dev-lang/pike/pike-7.6.6.ebuild b/dev-lang/pike/pike-7.6.6.ebuild
new file mode 100644
index 000000000000..7e2054183177
--- /dev/null
+++ b/dev-lang/pike/pike-7.6.6.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.6.ebuild,v 1.1 2004/06/20 17:50:22 scandium Exp $
+# Contributions by Emil Skoldberg, Fredrik Mellstrom (see ChangeLog)
+
+inherit fixheadtails
+
+IUSE="debug doc fftw gdbm gif gtk java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
+
+S="${WORKDIR}/Pike-v${PV}"
+HOMEPAGE="http://pike.ida.liu.se/"
+DESCRIPTION="Pike programming language and runtime"
+SRC_URI="ftp://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ pdflib? ( media-libs/pdflib )
+ gdbm? ( sys-libs/gdbm )
+ java? ( virtual/jdk )
+ scanner? ( media-gfx/sane-backends )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ gif? ( media-libs/giflib )
+ truetype? ( media-libs/freetype )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ opengl? ( virtual/opengl
+ virtual/glut )
+ sdl? ( media-libs/libsdl )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ fftw? ( dev-libs/fftw )
+ dev-libs/gmp
+ sys-devel/gcc
+ sys-devel/make
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # ht_fix_all kills autoheader stuff, so we use ht_fix_file
+ find . -iname "*.sh" -or -iname "*.sh.in" -or -iname "Makefile*" | \
+ while read i; do
+ ht_fix_file $i
+ done
+}
+
+src_compile() {
+
+ local myconf
+ use zlib || myconf="${myconf} --without-zlib"
+ use mysql || myconf="${myconf} --without-mysql"
+ use debug || myconf="${myconf} --without-debug"
+ use gdbm || myconf="${myconf} --without-gdbm"
+ use pdflib || myconf="${myconf} --without-libpdf"
+ use java || myconf="${myconf} --without-java"
+ use odbc || myconf="${myconf} --without-odbc"
+ use scanner || myconf="${myconf} --without-sane"
+ use postgres || myconf="${myconf} --without-postgres"
+ use oci8 || myconf="${myconf} --without-oracle"
+ use gif || myconf="${myconf} --without-gif"
+ use truetype || myconf="${myconf} --without-ttflib --without-freetype"
+ use jpeg || myconf="${myconf} --without-jpeglib"
+ use tiff || myconf="${myconf} --without-tifflib"
+ use opengl || myconf="${myconf} --without-GL --without-GLUT"
+ use gtk || myconf="${myconf} --without-GTK"
+ use fftw || myconf="${myconf} --without-fftw"
+
+ # Using --without-nettle until the Nettle library is available in portage
+ emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-nettle" || die
+
+ if use doc; then
+ PATH="${S}/bin:${PATH}" make doc || die
+ fi
+}
+
+src_install() {
+ # the installer should be stopped from removing files, to prevent sandbox issues
+ sed -i s/rm\(mod\+\"\.o\"\)\;/\{\}/ ${S}/bin/install.pike || die "Failed to modify install.pike"
+
+ if use doc; then
+ make INSTALLARGS="--traditional" buildroot="${D}" install || die
+ else
+ make INSTALLARGS="--traditional" buildroot="${D}" install_nodoc || die
+ fi
+
+ if use doc; then
+ einfo "Installing 60MB of docs, this could take some time ..."
+ dohtml -r ${S}/refdoc/traditional_manual ${S}/refdoc/modref
+ fi
+}