summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2011-02-26 14:16:59 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2011-02-26 14:16:59 +0000
commit89eb17562ea42c4a17847bf3e9cdd5b2c7f13cf8 (patch)
tree5b21164b23b3c74d5c9e73f39f606e20abbb8506 /dev-lang
parentsparc stable (bug 354080) (diff)
downloadgentoo-2-89eb17562ea42c4a17847bf3e9cdd5b2c7f13cf8.tar.gz
gentoo-2-89eb17562ea42c4a17847bf3e9cdd5b2c7f13cf8.tar.bz2
gentoo-2-89eb17562ea42c4a17847bf3e9cdd5b2c7f13cf8.zip
Bump to 2.0.2, wrt bug #356131
(Portage version: 2.1.9.40/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swig/ChangeLog10
-rw-r--r--dev-lang/swig/swig-2.0.2.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 294b47081821..908a04b55662 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/swig
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.146 2010/10/26 07:26:56 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.147 2011/02/26 14:16:59 pchrist Exp $
+
+*swig-2.0.2 (26 Feb 2011)
+
+ 26 Feb 2011; Panagiotis Christopoulos <pchrist@gentoo.org>
+ +swig-2.0.2.ebuild:
+ Bump to 2.0.2, wrt bug #356131
*swig-2.0.1 (26 Oct 2010)
diff --git a/dev-lang/swig/swig-2.0.2.ebuild b/dev-lang/swig/swig-2.0.2.ebuild
new file mode 100644
index 000000000000..4872dea74bd2
--- /dev/null
+++ b/dev-lang/swig/swig-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-2.0.2.ebuild,v 1.1 2011/02/26 14:16:59 pchrist Exp $
+
+EAPI="3"
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ccache doc pcre"
+RESTRICT="test"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable ccache) \
+ $(use_with pcre)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ANNOUNCE CHANGES CHANGES.current README TODO || die "dodoc failed"
+ if use doc; then
+ dohtml -r Doc/{Devel,Manual} || die "dohtml failed"
+ fi
+}