summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-29 11:40:45 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-29 11:40:45 +0000
commit8756cb0c4860d91b43b4d08b1ae6b7b392fde7f0 (patch)
tree4cd9b4e0eafdd3d5fd5ca9cb3e70c0a7197d6091 /dev-lang
parentUse dev-util/chromium-tools instead of a script from FILESDIR to extract bund... (diff)
downloadgentoo-2-8756cb0c4860d91b43b4d08b1ae6b7b392fde7f0.tar.gz
gentoo-2-8756cb0c4860d91b43b4d08b1ae6b7b392fde7f0.tar.bz2
gentoo-2-8756cb0c4860d91b43b4d08b1ae6b7b392fde7f0.zip
dev-lang/python: Remove eselect_python_update() from 2.7.1 and 3.1.3
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/python-2.7.1.ebuild12
-rw-r--r--dev-lang/python/python-3.1.3.ebuild12
3 files changed, 6 insertions, 23 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 49dbbb10e39c..d0ed52c868ef 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.502 2010/11/28 19:05:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.503 2010/11/29 11:40:45 sping Exp $
+
+ 29 Nov 2010; <sping@gentoo.org> python-2.7.1.ebuild, python-3.1.3.ebuild:
+ Remove eselect_python_update() from 2.7.1 and 3.1.3
*python-3.1.3 (28 Nov 2010)
*python-2.7.1 (28 Nov 2010)
diff --git a/dev-lang/python/python-2.7.1.ebuild b/dev-lang/python/python-2.7.1.ebuild
index 598b7e0ba50d..4b8c34c59684 100644
--- a/dev-lang/python/python-2.7.1.ebuild
+++ b/dev-lang/python/python-2.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.1.ebuild,v 1.1 2010/11/28 19:05:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.1.ebuild,v 1.2 2010/11/29 11:40:45 sping Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -337,15 +337,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- if [[ -z "$(eselect python show --python${PV%%.*})" ]]; then
- eselect python update --python${PV%%.*}
- fi
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -362,7 +354,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}
diff --git a/dev-lang/python/python-3.1.3.ebuild b/dev-lang/python/python-3.1.3.ebuild
index 668d6ee5b856..d6aa339fa954 100644
--- a/dev-lang/python/python-3.1.3.ebuild
+++ b/dev-lang/python/python-3.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.3.ebuild,v 1.1 2010/11/28 19:05:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.3.ebuild,v 1.2 2010/11/29 11:40:45 sping Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -308,15 +308,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- if [[ -z "$(eselect python show --python${PV%%.*})" ]]; then
- eselect python update --python${PV%%.*}
- fi
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
@@ -349,7 +341,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}