summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 06:53:41 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 06:53:41 +0000
commit84cbd547e959a03a9867d735ba646065f07697dd (patch)
treecd975340b473d24189707a8c675bb566dfa950a1 /dev-lang
parentAdd ~amd64 keyword, define RDEPEND explicitly (diff)
downloadgentoo-2-84cbd547e959a03a9867d735ba646065f07697dd.tar.gz
gentoo-2-84cbd547e959a03a9867d735ba646065f07697dd.tar.bz2
gentoo-2-84cbd547e959a03a9867d735ba646065f07697dd.zip
Patch epic 0.9.3 to build with ghc 7.6.1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/epic/ChangeLog6
-rw-r--r--dev-lang/epic/epic-0.9.3.ebuild18
-rw-r--r--dev-lang/epic/files/epic-0.9.3-ghc-7.6.patch53
3 files changed, 68 insertions, 9 deletions
diff --git a/dev-lang/epic/ChangeLog b/dev-lang/epic/ChangeLog
index 12cf2eb6b62e..35bb043399a9 100644
--- a/dev-lang/epic/ChangeLog
+++ b/dev-lang/epic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/epic
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/epic/ChangeLog,v 1.4 2012/09/12 16:07:50 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/epic/ChangeLog,v 1.5 2012/11/18 06:53:41 gienah Exp $
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +files/epic-0.9.3-ghc-7.6.patch,
+ epic-0.9.3.ebuild:
+ Patch epic 0.9.3 to build with ghc 7.6.1
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> epic-0.9.2.ebuild,
epic-0.9.3.ebuild:
diff --git a/dev-lang/epic/epic-0.9.3.ebuild b/dev-lang/epic/epic-0.9.3.ebuild
index c68846f1742e..9fac4f12a7b4 100644
--- a/dev-lang/epic/epic-0.9.3.ebuild
+++ b/dev-lang/epic/epic-0.9.3.ebuild
@@ -1,27 +1,29 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/epic/epic-0.9.3.ebuild,v 1.3 2012/09/12 16:07:50 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/epic/epic-0.9.3.ebuild,v 1.4 2012/11/18 06:53:41 gienah Exp $
-# ebuild generated by hackport 0.2.16.9999
+EAPI=5
-EAPI=4
+# ebuild generated by hackport 0.3.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Compiler for a simple functional language"
HOMEPAGE="http://www.dcs.st-and.ac.uk/~eb/epic.php"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-haskell/cabal
- dev-haskell/mtl[profile?]
+RDEPEND="dev-haskell/cabal:=[profile?]
+ dev-haskell/mtl:=[profile?]
>=dev-libs/boehm-gc-7.0[threads]
- >=dev-lang/ghc-6.10.1"
+ >=dev-lang/ghc-6.10.4:="
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8.0.4
dev-haskell/happy"
+
+PATCHES=("${FILESDIR}/${PN}-0.9.3-ghc-7.6.patch")
diff --git a/dev-lang/epic/files/epic-0.9.3-ghc-7.6.patch b/dev-lang/epic/files/epic-0.9.3-ghc-7.6.patch
new file mode 100644
index 000000000000..d168f032b92f
--- /dev/null
+++ b/dev-lang/epic/files/epic-0.9.3-ghc-7.6.patch
@@ -0,0 +1,53 @@
+--- epic-0.9.3-orig/Epic/Language.lhs 2012-02-28 10:44:29.000000000 +1100
++++ epic-0.9.3/Epic/Language.lhs 2012-09-14 16:20:29.841939337 +1000
+@@ -1,9 +1,14 @@
+-> {-# LANGUAGE FlexibleInstances, MultiParamTypeClasses,
++> {-# LANGUAGE FlexibleInstances, MultiParamTypeClasses, CPP,
+ > FunctionalDependencies #-}
+
+ > module Epic.Language where
+
+ > import Control.Monad
++#if MIN_VERSION_base(4,6,0)
++> import Control.Exception.Base
++#endif
++
++
+ > import System.IO
+ > import System.Directory
+ > import System.Environment
+@@ -379,7 +384,13 @@
+ > environment :: String -> IO (Maybe String)
+ > environment x = catch (do e <- getEnv x
+ > return (Just e))
+-> (\_ -> return Nothing)
++#if MIN_VERSION_base(4,6,0)
++> (\y-> do return (y::SomeException); return Nothing)
++#endif
++>
++#if !MIN_VERSION_base(4,6,0)
++> (\_-> return Nothing)
++#endif
+
+ Some tests
+
+--- epic-0.9.3-orig/Epic/CodegenC.lhs 2012-02-28 10:44:29.000000000 +1100
++++ epic-0.9.3/Epic/CodegenC.lhs 2012-09-14 16:13:48.061329048 +1000
+@@ -1,3 +1,4 @@
++> {-#LANGUAGE FlexibleContexts#-}
+ > module Epic.CodegenC where
+
+ > import Control.Monad.State
+@@ -98,10 +99,11 @@
+ > if (x>max) then put x else return ()
+
+ > cgs [] = return ""
++
+ > cgs (x:xs) = do xc <- cg x
+ > xsc <- cgs xs
+ > return $ xc ++ "\n" ++ xsc
+-
++> cg:: (MonadState Int m) => ByteOp -> m [Char]
+ > cg (CALL t fn args) = return $ tmp t ++ " = " ++ quickcall fn ++
+ > targs "(" args ++ ");"
+ > cg (TAILCALL t fn args)