summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-08-22 13:42:39 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-08-22 13:42:39 +0000
commit7dc5b0c4ab564402c8b9ef74c424c80b606c0505 (patch)
treeea3274be73cb5b6762efbe7ad7e6cbf4154eca87 /dev-lang
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo in bug... (diff)
downloadgentoo-2-7dc5b0c4ab564402c8b9ef74c424c80b606c0505.tar.gz
gentoo-2-7dc5b0c4ab564402c8b9ef74c424c80b606c0505.tar.bz2
gentoo-2-7dc5b0c4ab564402c8b9ef74c424c80b606c0505.zip
Disable installing suhosin extension on use suhosin for 5.2.17. Should always be installed manually. Same behaviour as all other versions of php
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/files/eblits/pkg_postinst-v1.eblit11
-rw-r--r--dev-lang/php/php-5.2.17.ebuild7
3 files changed, 17 insertions, 8 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index b74cfe92a93d..75a2e6e914c9 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.502 2011/08/21 14:06:56 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.503 2011/08/22 13:42:39 olemarkus Exp $
+
+ 22 Aug 2011; Ole Markus With <olemarkus@gentoo.org>
+ files/eblits/pkg_postinst-v1.eblit, php-5.2.17.ebuild:
+ Disable installing suhosin extension on use suhosin for 5.2.17. Should always
+ be installed manually. Same behaviour as all other versions of php
21 Aug 2011; Ole Markus With <olemarkus@gentoo.org> -php-5.3.7_rc2.ebuild,
-php-5.3.7_rc3.ebuild, -php-5.3.7.ebuild, -php-5.4.0_alpha1.ebuild,
diff --git a/dev-lang/php/files/eblits/pkg_postinst-v1.eblit b/dev-lang/php/files/eblits/pkg_postinst-v1.eblit
index c19dd9a452e7..6a4bf86b1999 100644
--- a/dev-lang/php/files/eblits/pkg_postinst-v1.eblit
+++ b/dev-lang/php/files/eblits/pkg_postinst-v1.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/pkg_postinst-v1.eblit,v 1.4 2011/02/16 08:12:28 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/pkg_postinst-v1.eblit,v 1.5 2011/08/22 13:42:39 olemarkus Exp $
eblit-php-pkg_postinst() {
# Output some general info to the user
@@ -71,6 +71,13 @@ eblit-php-pkg_postinst() {
ewarn
ewarn "Please read the upgrade guide: http://www.gentoo.org/proj/en/php/php-upgrading.xml"
ewarn
+
+ if ( [[ -z SUHOSIN_VERSION ]] && use suhosin ) ; then
+ ewarn "The suhosin USE flag now only installs the suhosin patch!"
+ ewarn "If you want the suhosin extension, make sure you install"
+ ewarn " dev-php5/suhosin"
+ ewarn
+ fi
}
diff --git a/dev-lang/php/php-5.2.17.ebuild b/dev-lang/php/php-5.2.17.ebuild
index d080444ca881..73d495220a8e 100644
--- a/dev-lang/php/php-5.2.17.ebuild
+++ b/dev-lang/php/php-5.2.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.17.ebuild,v 1.13 2011/04/19 16:44:56 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.17.ebuild,v 1.14 2011/08/22 13:42:39 olemarkus Exp $
EAPI=2
@@ -236,10 +236,7 @@ DEPEND="${DEPEND}
>=sys-devel/libtool-1.5.18"
# They are in PDEPEND because we need PHP installed first!
-PDEPEND="doc? ( app-doc/php-docs )
- suhosin? ( dev-php${PHP_MV}/suhosin )"
-
-[[ -n $SUHOSIN_VERSION ]] && PDEPEND="${PDEPEND} suhosin? ( dev-php${PHP_MV}/suhosin )"
+PDEPEND="doc? ( app-doc/php-docs )"
SLOT="$(get_version_component_range 1-2)"
S="${WORKDIR}/${PHP_P}"