summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-12-13 05:08:41 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-12-13 05:08:41 +0000
commit7d746ccd014bd4b3036dae0b82d89ba927138c23 (patch)
tree7883076629e2e6bff67f8f02358a8620eb258067 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-7d746ccd014bd4b3036dae0b82d89ba927138c23.tar.gz
gentoo-2-7d746ccd014bd4b3036dae0b82d89ba927138c23.tar.bz2
gentoo-2-7d746ccd014bd4b3036dae0b82d89ba927138c23.zip
migrate the live ebuild to git instead of mercurial to follow upstream
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog5
-rw-r--r--dev-lang/go/go-9999.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index aa841d7f1679..5b610729f901 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.58 2014/12/12 18:23:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.59 2014/12/13 05:08:41 williamh Exp $
+
+ 13 Dec 2014; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
+ migrate the live ebuild to git instead of mercurial to follow upstream
12 Dec 2014; William Hubbs <williamh@gentoo.org> go-1.3.3.ebuild,
go-1.4.ebuild, go-9999.ebuild:
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 5043cba8d55f..209a7172c9a5 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.22 2014/12/12 18:23:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.23 2014/12/13 05:08:41 williamh Exp $
EAPI=5
@@ -9,8 +9,8 @@ export CTARGET=${CTARGET:-${CHOST}}
inherit eutils toolchain-funcs
if [[ ${PV} = 9999 ]]; then
- EHG_REPO_URI="https://go.googlecode.com/hg"
- inherit mercurial
+ EGIT_REPO_URI="git://github.com/golang/go.git"
+ inherit git-r3
else
SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
# Upstream only supports go on amd64, arm and x86 architectures.