summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-05-16 00:26:13 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-05-16 00:26:13 +0000
commit7cb057dfc2e09d272a4097bc6331b297e805c493 (patch)
tree4735178305f41847eb42a0eb16ed1cdd0625ca8b /dev-lang
parentkeyword ~amd64-fbsd (compile tested only) (diff)
downloadgentoo-2-7cb057dfc2e09d272a4097bc6331b297e805c493.tar.gz
gentoo-2-7cb057dfc2e09d272a4097bc6331b297e805c493.tar.bz2
gentoo-2-7cb057dfc2e09d272a4097bc6331b297e805c493.zip
sync live ebuild and test repoman commit
(Portage version: 2.2.0_alpha105/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog5
-rw-r--r--dev-lang/go/go-9999.ebuild23
2 files changed, 13 insertions, 15 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index f148488fe1b2..4280f66762ba 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.1 2012/05/15 18:11:26 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.2 2012/05/16 00:26:13 williamh Exp $
+
+ 16 May 2012; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
+ sync live ebuild and test repoman commit
*go-9999 (15 May 2012)
*go-1.0.1 (15 May 2012)
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 600ab5096d2e..ac9f6d2e22b8 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.2 2012/05/15 20:03:48 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.3 2012/05/16 00:26:13 williamh Exp $
EAPI=4
@@ -13,7 +13,7 @@ inherit $vcs bash-completion-r1 elisp-common eutils
if [[ ${PV} != 9999 ]]; then
SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
# Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* ~x86"
+ KEYWORDS="-* ~amd64 ~x86"
fi
DESCRIPTION="A concurrent garbage collected and typesafe programming language"
@@ -42,15 +42,6 @@ STRIP_MASK="/usr/lib/go/pkg/linux*/*.a"
[[ ${PV} == 9999 ]] || S="${WORKDIR}"/go
-export_settings()
-{
- export HOST_EXTRA_CFLAGS="${CFLAGS}"
- export HOST_EXTRA_LDFLAGS="${LDFLAGS}"
- export GOROOT_FINAL=/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
-}
-
src_prepare()
{
if [[ ${PV} != 9999 ]]; then
@@ -60,7 +51,12 @@ src_prepare()
src_compile()
{
- export_settings
+ export HOST_EXTRA_CFLAGS="${CFLAGS}"
+ export HOST_EXTRA_LDFLAGS="${LDFLAGS}"
+ export GOROOT_FINAL=/usr/lib/go
+ export GOROOT="$(pwd)"
+ export GOBIN="${GOROOT}/bin"
+
if [[ ${PV} != 9999 ]]; then
use pax_kernel && opts="--pax-kernel"
fi
@@ -75,9 +71,8 @@ src_compile()
src_test()
{
- export_settings
cd src
- ./run.bash --no-rebuild --banner || die "tests failed"
+ PATH="$GOBIN:${PATH}" ./run.bash --no-rebuild --banner || die "tests failed"
}
src_install()