summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-19 03:33:57 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-19 03:33:57 +0000
commit78088b5c66abc4ec23283a27b78ff1d341fff3c5 (patch)
tree5be4618e6dd746a05178550d2c1849b80bff0b56 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-78088b5c66abc4ec23283a27b78ff1d341fff3c5.tar.gz
gentoo-2-78088b5c66abc4ec23283a27b78ff1d341fff3c5.tar.bz2
gentoo-2-78088b5c66abc4ec23283a27b78ff1d341fff3c5.zip
Set ac_cv_buggy_getaddrinfo=no when cross-compiling.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.7.3-r2.ebuild5
-rw-r--r--dev-lang/python/python-2.7.3-r3.ebuild5
-rw-r--r--dev-lang/python/python-3.2.3-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.2.3-r2.ebuild5
-rw-r--r--dev-lang/python/python-3.2.3.ebuild5
-rw-r--r--dev-lang/python/python-3.3.0-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.3.0.ebuild5
8 files changed, 34 insertions, 8 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 2a413404508f..ae958de7ac92 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.632 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.633 2013/03/19 03:33:57 vapier Exp $
+
+ 19 Mar 2013; Mike Frysinger <vapier@gentoo.org> python-2.7.3-r2.ebuild,
+ python-2.7.3-r3.ebuild, python-3.2.3-r1.ebuild, python-3.2.3-r2.ebuild,
+ python-3.2.3.ebuild, python-3.3.0-r1.ebuild, python-3.3.0.ebuild:
+ Set ac_cv_buggy_getaddrinfo=no when cross-compiling.
19 Mar 2013; Mike Frysinger <vapier@gentoo.org> python-2.5.4-r4.ebuild,
python-2.5.4-r5.ebuild, python-2.6.8-r1.ebuild, python-2.6.8.ebuild,
diff --git a/dev-lang/python/python-2.7.3-r2.ebuild b/dev-lang/python/python-2.7.3-r2.ebuild
index d050ef1c1481..1fc7b60d61a6 100644
--- a/dev-lang/python/python-2.7.3-r2.ebuild
+++ b/dev-lang/python/python-2.7.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r2.ebuild,v 1.13 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r2.ebuild,v 1.14 2013/03/19 03:33:57 vapier Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -160,6 +160,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python2.X/config/Makefile.
diff --git a/dev-lang/python/python-2.7.3-r3.ebuild b/dev-lang/python/python-2.7.3-r3.ebuild
index 64c38f9632dc..8b2ba56ea4b5 100644
--- a/dev-lang/python/python-2.7.3-r3.ebuild
+++ b/dev-lang/python/python-2.7.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.10 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.11 2013/03/19 03:33:57 vapier Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -165,6 +165,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python2.X/config/Makefile.
diff --git a/dev-lang/python/python-3.2.3-r1.ebuild b/dev-lang/python/python-3.2.3-r1.ebuild
index 2155324a2f90..5b5f4b2dfe1a 100644
--- a/dev-lang/python/python-3.2.3-r1.ebuild
+++ b/dev-lang/python/python-3.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r1.ebuild,v 1.10 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r1.ebuild,v 1.11 2013/03/19 03:33:57 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -144,6 +144,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
diff --git a/dev-lang/python/python-3.2.3-r2.ebuild b/dev-lang/python/python-3.2.3-r2.ebuild
index 839aa95cd25b..e99f79977939 100644
--- a/dev-lang/python/python-3.2.3-r2.ebuild
+++ b/dev-lang/python/python-3.2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.10 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.11 2013/03/19 03:33:57 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -148,6 +148,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
diff --git a/dev-lang/python/python-3.2.3.ebuild b/dev-lang/python/python-3.2.3.ebuild
index fe6fe135dac8..723646940017 100644
--- a/dev-lang/python/python-3.2.3.ebuild
+++ b/dev-lang/python/python-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.18 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.19 2013/03/19 03:33:57 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -144,6 +144,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
diff --git a/dev-lang/python/python-3.3.0-r1.ebuild b/dev-lang/python/python-3.3.0-r1.ebuild
index 7d7b8e81b48f..231ecad5d1ba 100644
--- a/dev-lang/python/python-3.3.0-r1.ebuild
+++ b/dev-lang/python/python-3.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.6 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.7 2013/03/19 03:33:57 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -139,6 +139,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
diff --git a/dev-lang/python/python-3.3.0.ebuild b/dev-lang/python/python-3.3.0.ebuild
index 0492a8390967..ff3895eec305 100644
--- a/dev-lang/python/python-3.3.0.ebuild
+++ b/dev-lang/python/python-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0.ebuild,v 1.4 2013/03/19 02:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0.ebuild,v 1.5 2013/03/19 03:33:57 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -133,6 +133,9 @@ src_configure() {
-e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
-e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
Makefile.pre.in || die "sed failed"
+
+ # The configure script assumes it's buggy when cross-compiling.
+ export ac_cv_buggy_getaddrinfo=no
fi
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.