summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-10 17:08:38 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-10 17:08:38 +0000
commit76413615dd79d74054d412c54fdf8647c96c4710 (patch)
tree650c5e2e95b1618845c06d44a8e0eddc4501959d /dev-lang
parentRevbump for app-crypt/gpa. Adds updated gpa.desktop patch wrt bug 340747. (diff)
downloadgentoo-2-76413615dd79d74054d412c54fdf8647c96c4710.tar.gz
gentoo-2-76413615dd79d74054d412c54fdf8647c96c4710.tar.bz2
gentoo-2-76413615dd79d74054d412c54fdf8647c96c4710.zip
Version bump. Remove old.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.4.9.14.ebuild (renamed from dev-lang/v8/v8-2.5.4.ebuild)2
-rw-r--r--dev-lang/v8/v8-2.5.2.ebuild77
-rw-r--r--dev-lang/v8/v8-2.5.6.ebuild81
4 files changed, 8 insertions, 160 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index f69c67e242d3..044342f4ac0d 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.16 2010/12/02 10:09:16 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.17 2010/12/10 17:08:38 phajdan.jr Exp $
+
+*v8-2.4.9.14 (10 Dec 2010)
+
+ 10 Dec 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> +v8-2.4.9.14.ebuild,
+ -v8-2.5.2.ebuild, -v8-2.5.4.ebuild, -v8-2.5.6.ebuild:
+ Version bump. Remove old.
*v8-2.5.9.1 (02 Dec 2010)
diff --git a/dev-lang/v8/v8-2.5.4.ebuild b/dev-lang/v8/v8-2.4.9.14.ebuild
index 52057f7c41c7..695b3da5f661 100644
--- a/dev-lang/v8/v8-2.5.4.ebuild
+++ b/dev-lang/v8/v8-2.4.9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.4.ebuild,v 1.2 2010/11/11 11:06:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.14.ebuild,v 1.1 2010/12/10 17:08:38 phajdan.jr Exp $
EAPI="2"
diff --git a/dev-lang/v8/v8-2.5.2.ebuild b/dev-lang/v8/v8-2.5.2.ebuild
deleted file mode 100644
index dbd3867b58e4..000000000000
--- a/dev-lang/v8/v8-2.5.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.2.ebuild,v 1.1 2010/11/03 17:54:27 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils subversion toolchain-funcs
-
-ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on"
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-2.5.6.ebuild b/dev-lang/v8/v8-2.5.6.ebuild
deleted file mode 100644
index bf7f8f0610e7..000000000000
--- a/dev-lang/v8/v8-2.5.6.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.6.ebuild,v 1.2 2010/11/19 13:46:37 maekke Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}