summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2010-02-09 09:47:40 +0000
committerGeorge Shapovalov <george@gentoo.org>2010-02-09 09:47:40 +0000
commit6a22e5db832bea5d464fc04bb1a1d1bb223c676a (patch)
treed8cfec02f52a4d4a203d8243adab8720e42a0aa7 /dev-lang
parentBump monodoc to match mono 2.4.3. (diff)
downloadgentoo-2-6a22e5db832bea5d464fc04bb1a1d1bb223c676a.tar.gz
gentoo-2-6a22e5db832bea5d464fc04bb1a1d1bb223c676a.tar.bz2
gentoo-2-6a22e5db832bea5d464fc04bb1a1d1bb223c676a.zip
fixed bootstrap for sparc and repacked one for x86. Issuing -r2 to force mirror pick up proper bootstraps.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog9
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3.3-r2.ebuild64
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 2be7916422e5..44ed568921c5 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.34 2010/02/04 19:42:39 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.35 2010/02/09 09:47:40 george Exp $
+
+*gnat-gcc-4.3.3-r2 (09 Feb 2010)
+
+ 09 Feb 2010; George Shapovalov <george@gentoo.org>
+ +gnat-gcc-4.3.3-r2.ebuild:
+ fixed bootstrap for sparc and repacked one for x86. Issuing -r2 to force
+ mirror pick up proper bootstraps.
04 Feb 2010; George Shapovalov <george@gentoo.org>
gnat-gcc-4.3.3-r1.ebuild:
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r2.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r2.ebuild
new file mode 100644
index 000000000000..d0d25db03179
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r2.ebuild,v 1.1 2010/02/09 09:47:40 george Exp $
+
+# Need to let configure know where to find stddef.h
+#EXTRA_CONFGCC="${WORKDIR}/usr/lib/include/"
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+# using new bootstrap
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
+ sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i586.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+DEPEND=">=dev-libs/mpfr-2.3.1
+ >=dev-libs/gmp-4.2.2"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # looks like wrapper has problems with all the quotation
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}