summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-03 20:32:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-03 20:32:41 +0000
commit661fb3ffb6a5b1b611fe7602ce33d639a07249f5 (patch)
tree830971a9bda0d159cbd019be8158643103b32501 /dev-lang
parentfixed mistake for emake:-all emake:-install between old and new plugin makefi... (diff)
downloadgentoo-2-661fb3ffb6a5b1b611fe7602ce33d639a07249f5.tar.gz
gentoo-2-661fb3ffb6a5b1b611fe7602ce33d639a07249f5.tar.bz2
gentoo-2-661fb3ffb6a5b1b611fe7602ce33d639a07249f5.zip
Added a patch for netcdf-4 support, bug #449984
(Portage version: 2.2.01.21476-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gdl/ChangeLog6
-rw-r--r--dev-lang/gdl/files/0.9.3-netcdf-cxx.patch36
-rw-r--r--dev-lang/gdl/gdl-0.9.3.ebuild4
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-lang/gdl/ChangeLog b/dev-lang/gdl/ChangeLog
index 0cb8d3135dc4..f841155ba9a5 100644
--- a/dev-lang/gdl/ChangeLog
+++ b/dev-lang/gdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gdl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.36 2013/01/03 05:06:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.37 2013/01/03 20:32:40 bicatali Exp $
+
+ 03 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/0.9.3-netcdf-cxx.patch, gdl-0.9.3.ebuild:
+ Added a patch for netcdf-4 support, bug #449984
03 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> gdl-0.9.2-r2.ebuild,
gdl-0.9.3.ebuild:
diff --git a/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch b/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch
new file mode 100644
index 000000000000..2239d46c74c0
--- /dev/null
+++ b/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch
@@ -0,0 +1,36 @@
+--- CMakeModules/FindNetCDF.cmake.orig 2013-01-03 11:27:52.373435387 -0800
++++ CMakeModules/FindNetCDF.cmake 2013-01-03 12:23:04.710333638 -0800
+@@ -9,16 +9,29 @@
+ #
+
+
+-find_path(NETCDFPKG netcdf.pc PATH_SUFFIXES lib lib/pkgconfig)
++find_path(NETCDFPKG netcdf-cxx4.pc PATH_SUFFIXES lib lib/pkgconfig)
++if(NETCDFPKG)
++ set(netcdfpc netcdf-cxx4)
++else(NETCDFPKG)
++ find_path(NETCDFPKG netcdf.pc PATH_SUFFIXES lib lib/pkgconfig)
++ set(netcdfpc netcdf)
++endif(NETCDFPKG)
++
+ include(FindPackageHandleStandardArgs)
+ if(NETCDFPKG)
+ set(ENV{PKG_CONFIG_PATH} ${NETCDFPKG}) # pkg search path
+ include(FindPkgConfig)
+- pkg_check_modules(NETCDF netcdf)
++ pkg_check_modules(NETCDF ${netcdfpc})
+ if(NETCDF_FOUND)
+- find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
++ if(NETCDF_INCLUDE_DIRS)
++ find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
++ else(NETCDF_INCLUDE_DIRS)
++ find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES)
++ endif(NETCDF_INCLUDE_DIRS)
++ message("-- Found NETCDF_LIBRARIES = ${NETCDF_LIBRARIES}")
++ message("-- Found NETCDF_INCLUDE_DIRS = ${NETCDF_INCLUDE_DIRS}")
+ endif(NETCDF_FOUND)
+-else(NETCDFPKG) # no netcdf.pc file
++else(NETCDFPKG) # no pc file
+ find_library(NETCDF_LIBRARIES NAMES netcdf)
+ find_path(NETCDF_INCLUDE_DIRS NAMES netcdfcpp.h PATH_SUFFIXES netcdf-3)
+ find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
diff --git a/dev-lang/gdl/gdl-0.9.3.ebuild b/dev-lang/gdl/gdl-0.9.3.ebuild
index 37468c28d466..16be3329acc1 100644
--- a/dev-lang/gdl/gdl-0.9.3.ebuild
+++ b/dev-lang/gdl/gdl-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9.3.ebuild,v 1.2 2013/01/03 05:06:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9.3.ebuild,v 1.3 2013/01/03 20:32:40 bicatali Exp $
EAPI=4
@@ -60,7 +60,7 @@ src_prepare() {
use hdf5 && has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
epatch "${FILESDIR}"/0.9.2-{antlr,proj4,include,tests,semaphore}.patch
- epatch "${FILESDIR}"/0.9.3-sstream.patch
+ epatch "${FILESDIR}"/0.9.3-{sstream,netcdf-cxx}.patch
# make sure antlr includes are from system and rebuild the sources with it
# https://sourceforge.net/tracker/?func=detail&atid=618685&aid=3465878&group_id=97659