summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-08-06 17:04:32 +0000
committerAlex Legler <a3li@gentoo.org>2010-08-06 17:04:32 +0000
commit63fd66388b94921c9d30e5ff1c22e2013510534e (patch)
tree76445d946af0df9932d6225f10b3051a157edfbb /dev-lang
parentVersion bump. Package now builds correctly against OpenSSL-1 (bug 326633). Fi... (diff)
downloadgentoo-2-63fd66388b94921c9d30e5ff1c22e2013510534e.tar.gz
gentoo-2-63fd66388b94921c9d30e5ff1c22e2013510534e.tar.bz2
gentoo-2-63fd66388b94921c9d30e5ff1c22e2013510534e.zip
Adapting dev-libs/openssl dependency for older ebuild, fixing rubytests installation path. Cleaning up even older ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby-enterprise/ChangeLog8
-rw-r--r--dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r1.ebuild191
-rw-r--r--dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild6
3 files changed, 10 insertions, 195 deletions
diff --git a/dev-lang/ruby-enterprise/ChangeLog b/dev-lang/ruby-enterprise/ChangeLog
index 97044741e905..82ee09bb4b64 100644
--- a/dev-lang/ruby-enterprise/ChangeLog
+++ b/dev-lang/ruby-enterprise/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ruby-enterprise
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-enterprise/ChangeLog,v 1.5 2010/08/06 17:00:59 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-enterprise/ChangeLog,v 1.6 2010/08/06 17:04:32 a3li Exp $
+
+ 06 Aug 2010; Alex Legler <a3li@gentoo.org>
+ -ruby-enterprise-1.8.7.2010.01-r1.ebuild,
+ ruby-enterprise-1.8.7.2010.01-r2.ebuild:
+ Adapting dev-libs/openssl dependency for older ebuild, fixing rubytests
+ installation path. Cleaning up even older ebuild.
*ruby-enterprise-1.8.7.2010.02 (06 Aug 2010)
diff --git a/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r1.ebuild b/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r1.ebuild
deleted file mode 100644
index a4c1b01ead25..000000000000
--- a/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r1.ebuild
+++ /dev/null
@@ -1,191 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r1.ebuild,v 1.1 2010/05/13 16:31:19 a3li Exp $
-
-EAPI="2"
-inherit autotools eutils flag-o-matic multilib versionator
-
-MY_PV=$(replace_version_separator 3 '-')
-S="${WORKDIR}/${PN}-${MY_PV}/source"
-
-SLOT=$(get_version_component_range 1-2)
-MY_VSUFFIX="ee$(delete_version_separator 1 ${SLOT})"
-MY_SUFFIX="ee"
-
-DESCRIPTION="Ruby Enterprise Edition is a branch of Ruby including various enhancements"
-HOMEPAGE="http://www.rubyenterpriseedition.com/"
-SRC_URI="mirror://rubyforge/emm-ruby/${PN}-${MY_PV}.tar.gz
- http://dev.a3li.li/gentoo/distfiles/ruby-patches-ee-${PVR}.tar.bz2"
-
-LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~amd64 ~x86"
-IUSE="+berkdb debug doc emacs examples +gdbm ipv6 rubytests socks5 ssl tcmalloc
-threads tk xemacs"
-
-RDEPEND="
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=app-admin/eselect-ruby-20100402
- tcmalloc? ( dev-util/google-perftools )"
-DEPEND="${REPEND}"
-# TODO rubygems
-PDEPEND="emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-pkg_setup() {
- use tk || return
-
- # Note for EAPI-2 lovers: We'd like to show that custom message.
- # *If* you can make USE dependencies show that, too, feel free to migrate.
- if (use threads && ! built_with_use dev-lang/tk threads) \
- || (! use threads && built_with_use dev-lang/tk threads) ; then
- eerror
- eerror "You have Tk support enabled."
- eerror
- eerror "Ruby and Tk need the same 'threads' USE flag settings."
- eerror "Either change the USE flag on dev-lang/ruby or on dev-lang/tk"
- eerror "and recompile tk."
-
- die "threads USE flag mismatch"
- fi
-}
-
-src_prepare() {
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}/patches-ee-${PVR}"
-
- if use tcmalloc ; then
- sed -i 's:^EXTLIBS.*:EXTLIBS = -ltcmalloc_minimal:' Makefile.in
- fi
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=
-
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- # ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="--with-lookup-order-hack=INET"
-
- econf \
- --program-suffix="${MY_VSUFFIX}" \
- --enable-shared \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- --enable-ipv6 \
- $(use_enable debug) \
- $(use_with berkdb dbm) \
- $(use_with gdbm) \
- $(use_with ssl openssl) \
- $(use_with tk) \
- ${myconf} \
- --with-sitedir=/usr/$(get_libdir)/ruby${MY_SUFFIX}/site_ruby \
- --with-vendordir=/usr/$(get_libdir)/ruby${MY_SUFFIX}/vendor_ruby \
- --enable-option-checking=no \
- || die "econf failed"
-}
-
-src_compile() {
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake -j1 test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby${MY_VSUFFIX} -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- # Ruby is involved in the install process, we don't want interference here.
- unset RUBYOPT
-
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/rubyee/${SLOT}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)' | make -f - getminiruby)
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc ChangeLog NEWS README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
- fi
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_VSUFFIX}
- fi
-
- ewarn
- ewarn "Ruby Enterprise Edition is not guaranteed to be binary-compatible to"
- ewarn "MRI (dev-lang/ruby). Exercise care especially with C extensions!"
- ewarn "Gentoo does *not* accept any bugs regarding such failures."
- ewarn
-
- elog
- elog "To switch between available Ruby profiles, execute as root:"
- elog "\teselect ruby set ruby(18|19|...)"
- elog
-}
-
-pkg_postrm() {
- eselect ruby cleanup
-}
diff --git a/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild b/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild
index 974fa7e4229d..5f003e3b6ef1 100644
--- a/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild
+++ b/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild,v 1.2 2010/05/20 19:15:39 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-enterprise/ruby-enterprise-1.8.7.2010.01-r2.ebuild,v 1.3 2010/08/06 17:04:32 a3li Exp $
EAPI=2
@@ -26,7 +26,7 @@ IUSE="tcmalloc +berkdb debug doc examples +gdbm ipv6 rubytests ssl threads tk xe
RDEPEND="
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
- ssl? ( >=dev-libs/openssl-0.9.8m )
+ ssl? ( >=dev-libs/openssl-0.9.8m <dev-libs/openssl-1 )
tk? ( dev-lang/tk[threads=] )
ncurses? ( sys-libs/ncurses )
libedit? ( dev-libs/libedit )
@@ -154,7 +154,7 @@ src_install() {
if use rubytests; then
pushd test
- insinto /usr/share/${PN}-${SLOT}
+ insinto /usr/share/${PN}-${SLOT}/test
doins -r .
popd
fi