summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-07-23 15:02:04 +0000
committerTorsten Veller <tove@gentoo.org>2010-07-23 15:02:04 +0000
commit635d7f3252b221b4ca7e9e12237e41f5c9f8f0eb (patch)
tree6024c4b1452d9e1ea9c6db81c6523381700005a2 /dev-lang
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-635d7f3252b221b4ca7e9e12237e41f5c9f8f0eb.tar.gz
gentoo-2-635d7f3252b221b4ca7e9e12237e41f5c9f8f0eb.tar.bz2
gentoo-2-635d7f3252b221b4ca7e9e12237e41f5c9f8f0eb.zip
Version bump
(Portage version: 2.2_rc67_p240/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/parrot/ChangeLog7
-rw-r--r--dev-lang/parrot/parrot-2.6.0.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index d0c5e87f46cd..4ab65922a4fc 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.33 2010/06/18 08:08:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.34 2010/07/23 15:02:04 tove Exp $
+
+*parrot-2.6.0 (23 Jul 2010)
+
+ 23 Jul 2010; Torsten Veller <tove@gentoo.org> +parrot-2.6.0.ebuild:
+ Version bump
18 Jun 2010; Patrick Lauer <patrick@gentoo.org> -parrot-1.3.0.ebuild,
-parrot-1.4.0.ebuild, -parrot-1.7.0.ebuild, -parrot-1.9.0.ebuild,
diff --git a/dev-lang/parrot/parrot-2.6.0.ebuild b/dev-lang/parrot/parrot-2.6.0.ebuild
new file mode 100644
index 000000000000..48282c7cd08a
--- /dev/null
+++ b/dev-lang/parrot/parrot-2.6.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.6.0.ebuild,v 1.1 2010/07/23 15:02:04 tove Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
+
+RDEPEND="sys-libs/readline
+ opengl? ( virtual/glut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_configure() {
+ myconf="--disable-rpath"
+ use unicode || myconf+=" --without-icu"
+ use ssl || myconf+=" --without-crypto"
+ use gdbm || myconf+=" --without-gdbm"
+ use nls || myconf+=" --without-gettext"
+ use gmp || myconf+=" --without-gmp"
+ use opengl || myconf+=" --without-opengl"
+ use pcre || myconf+=" --without-pcre"
+
+ perl Configure.pl \
+ --ccflags="${CFLAGS}" \
+ --linkflags="${LDFLAGS}" \
+ --prefix="${EROOT}"/usr \
+ --libdir="${EROOT}"/usr/$(get_libdir) \
+ --sysconfdir="${EROOT}"/etc \
+ --sharedstatedir="${EROOT}"/var/lib/parrot \
+ --pkgconfigdir=pkgconfig \
+ $myconf || die
+}
+
+src_compile() {
+ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
+ # occasionally dies in parallel make
+ emake -j1 || die
+ if use doc ; then
+ emake -j1 html || die
+ fi
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${ED}" DOC_DIR="${EROOT}/usr/share/doc/${PF}" || die
+ dodoc CREDITS DEPRECATED.pod DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
+ if use examples; then
+ insinto "${EROOT}/usr/share/doc/${PF}/examples"
+ doins -r examples/* || die
+ fi
+ if use doc; then
+ insinto "${EROOT}/usr/share/doc/${PF}/editor"
+ doins -r editor || die
+ cd docs/html
+ dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
+ pmc.html tools.html docs src tools || die
+ fi
+}