summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-01 19:28:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-01 19:28:57 +0000
commit632c5531abe135a545ce47dd4c0acc7d44037276 (patch)
tree68c5ad292695d06a97194fdf391bdb55f5372ac6 /dev-lang
parentRemove qemu-0.8 series (diff)
downloadgentoo-2-632c5531abe135a545ce47dd4c0acc7d44037276.tar.gz
gentoo-2-632c5531abe135a545ce47dd4c0acc7d44037276.tar.bz2
gentoo-2-632c5531abe135a545ce47dd4c0acc7d44037276.zip
Version bump
(Portage version: 2.1.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/icc/ChangeLog9
-rw-r--r--dev-lang/icc/icc-10.1.012.ebuild96
-rw-r--r--dev-lang/icc/metadata.xml24
3 files changed, 115 insertions, 14 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index c9a37142e6c9..c072706aad8f 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/icc
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.57 2007/12/25 13:55:33 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.58 2008/02/01 19:28:57 bicatali Exp $
+
+*icc-10.1.012 (01 Feb 2008)
+
+ 01 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org> +icc-10.1.012.ebuild:
+ Version bump
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Fixing the unsigned Manifest.
diff --git a/dev-lang/icc/icc-10.1.012.ebuild b/dev-lang/icc/icc-10.1.012.ebuild
new file mode 100644
index 000000000000..fc881fd0f218
--- /dev/null
+++ b/dev-lang/icc/icc-10.1.012.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.1.012.ebuild,v 1.1 2008/02/01 19:28:57 bicatali Exp $
+
+inherit rpm eutils
+
+PID=952
+PB=cc
+PEXEC="icc icpc"
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKID="l_${PB}_p_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_COM="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKID}"
+SRC_URI="amd64? ( ${SRC_COM}_intel64.tar.gz )
+ ia64? ( ${SRC_COM}_ia64.tar.gz )
+ x86? ( ${SRC_COM}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE=""
+DEPEND=""
+RDEPEND="virtual/libstdc++
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -e 's|export -n IA32ROOT;||g' \
+ -i ${PEXEC} *sh \
+ || die "sed fixing shells and paths failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "Copying ${PN} failed"
+
+ local env_file=05${PN}
+ cat > ${env_file} <<-EOF
+ PATH=${INSTALL_DIR}/bin
+ ROOTPATH=${INSTALL_DIR}/bin
+ LDPATH=${INSTALL_DIR}/lib
+ MANPATH=${INSTALL_DIR}/man
+ EOF
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+}
+
+pkg_postinst () {
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} \
+ || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN},"
+ elog "you cannot run ${PN} without a license file."
+ elog "To receive a non-commercial license, you need to register."
+ elog "Read the website for more information on this license:"
+ elog "${HOMEPAGE}"
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses."
+ elog "\nTo use ${PN} issue first \n\tsource /etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
+}
diff --git a/dev-lang/icc/metadata.xml b/dev-lang/icc/metadata.xml
index 9748fbec6a30..878bf1f668f9 100644
--- a/dev-lang/icc/metadata.xml
+++ b/dev-lang/icc/metadata.xml
@@ -2,16 +2,16 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>bicatali@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
- The Intel® C++ Compiler is a full featured C/C++ compiler for Intel
- based architectures. The compiler supports multi-threading, automatic
- processor dispatch, vectorization, auto-parallelization, OpenMP, data
- prefetching, loop unrolling. The package comes with extensive
- documentation. The product can be installed as a non-commercial as
- well. License, terms of qualifications can be found on the web site.
- </longdescription>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ The Intel® C++ Compiler is a full featured C/C++ compiler for Intel
+ based architectures. The compiler supports multi-threading, automatic
+ processor dispatch, vectorization, auto-parallelization, OpenMP, data
+ prefetching, loop unrolling. The package comes with extensive
+ documentation. The product can be installed as a non-commercial as
+ well. License, terms of qualifications can be found on the web site.
+</longdescription>
</pkgmetadata>