summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2013-06-08 21:35:23 +0000
committerJory Pratt <anarchy@gentoo.org>2013-06-08 21:35:23 +0000
commit6033483d33d1da53a23208643ea950100ed6e218 (patch)
tree495a539756c7f4f9fd64a89211df5587b3e62e12 /dev-lang
parentDrop ~x86 keyword since it isn't supported yet. (diff)
downloadgentoo-2-6033483d33d1da53a23208643ea950100ed6e218.tar.gz
gentoo-2-6033483d33d1da53a23208643ea950100ed6e218.tar.bz2
gentoo-2-6033483d33d1da53a23208643ea950100ed6e218.zip
Add uclibc support, bug #431560
(Portage version: 2.1.12.3/cvs/Linux x86_64, signed Manifest commit with key 0xB4D088B4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/spidermonkey/ChangeLog6
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-1.8.5-isfinite.patch11
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-lang/spidermonkey/ChangeLog b/dev-lang/spidermonkey/ChangeLog
index 40be807cc949..234eefe9a17f 100644
--- a/dev-lang/spidermonkey/ChangeLog
+++ b/dev-lang/spidermonkey/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/spidermonkey
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.116 2013/04/13 20:48:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.117 2013/06/08 21:35:23 anarchy Exp $
+
+ 08 Jun 2013; Jory A. Pratt <anarchy@gentoo.org> spidermonkey-1.8.5-r4.ebuild,
+ +files/spidermonkey-1.8.5-isfinite.patch:
+ Add uclibc support, bug #431560
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org> spidermonkey-1.8.5-r4.ebuild:
Stable for s390, wrt bug #461508
diff --git a/dev-lang/spidermonkey/files/spidermonkey-1.8.5-isfinite.patch b/dev-lang/spidermonkey/files/spidermonkey-1.8.5-isfinite.patch
new file mode 100644
index 000000000000..edf4d01e64bd
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-1.8.5-isfinite.patch
@@ -0,0 +1,11 @@
+--- js/src/jsnum.h 2011-03-03 05:43:06.000000000 -0500
++++ js/src/jsnum.h.new 2012-08-16 14:58:04.000000000 -0400
+@@ -97,6 +97,8 @@
+ {
+ #ifdef WIN32
+ return _finite(d);
++#elif defined(__UCLIBC__)
++ return isfinite(d);
+ #else
+ return finite(d);
+ #endif
diff --git a/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild b/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
index 3cd668d17423..a0c145b4c092 100644
--- a/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild,v 1.17 2013/04/13 20:48:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild,v 1.18 2013/06/08 21:35:23 anarchy Exp $
EAPI="5"
WANT_AUTOCONF="2.1"
@@ -53,6 +53,8 @@ src_prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=441934
epatch "${FILESDIR}"/${PN}-1.8.5-ia64-fix.patch
epatch "${FILESDIR}"/${PN}-1.8.5-ia64-static-strings.patch
+ # https://bugs.gentoo.org/show_bug.cgi?id=431560
+ epatch "${FILESDIR}"/${PN}-1.8.5-isfinite.patch
epatch_user