summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-28 16:57:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-28 16:57:18 +0000
commit5ddcef9e3dfe372bc5b3e07236cb92572da0ab03 (patch)
tree8d246bc644718e939e3bedf6bba0d810479c8029 /dev-lang
parentAdd einfo informing about the test that might fail. (diff)
downloadgentoo-2-5ddcef9e3dfe372bc5b3e07236cb92572da0ab03.tar.gz
gentoo-2-5ddcef9e3dfe372bc5b3e07236cb92572da0ab03.tar.bz2
gentoo-2-5ddcef9e3dfe372bc5b3e07236cb92572da0ab03.zip
Ignore 3.1 slot.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild6
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 4a8691551157..9d9e7f5698da 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.8 2009/05/27 15:53:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.9 2009/05/28 16:57:18 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -230,14 +230,14 @@ src_install() {
}
pkg_postrm() {
- eselect python update --ignore 3.0
+ eselect python update --ignore 3.0 --ignore 3.1
python_mod_cleanup /usr/lib/python${PYVER}
[[ "$(get_libdir)" == "lib" ]] || \
python_mod_cleanup /usr/$(get_libdir)/python${PYVER}
}
pkg_postinst() {
- eselect python update --ignore 3.0
+ eselect python update --ignore 3.0 --ignore 3.1
python_mod_optimize
python_mod_optimize -x "(site-packages|test)" \
/usr/lib/python${PYVER}
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index e35d5f87153d..18b115259ce1 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.1 2009/05/25 17:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.2 2009/05/28 16:57:18 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -248,14 +248,14 @@ src_install() {
}
pkg_postrm() {
- eselect python update --ignore 3.0
+ eselect python update --ignore 3.0 --ignore 3.1
python_mod_cleanup /usr/lib/python${PYVER}
[[ "$(get_libdir)" != "lib" ]] && python_mod_cleanup /usr/$(get_libdir)/python${PYVER}
}
pkg_postinst() {
- eselect python update --ignore 3.0
+ eselect python update --ignore 3.0 --ignore 3.1
python_mod_optimize -x "(site-packages|test)" /usr/lib/python${PYVER}
[[ "$(get_libdir)" != "lib" ]] && python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}