summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-04-08 08:07:01 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-04-08 08:07:01 +0000
commit50ee53e6c9d6b0f9e2b4c91507409e9a1f4a52ff (patch)
treec805834e899f39a0dc74e9eefbbcbad4da425d2c /dev-lang
parentRemove message about sourcing setup scripts. (diff)
downloadgentoo-2-50ee53e6c9d6b0f9e2b4c91507409e9a1f4a52ff.tar.gz
gentoo-2-50ee53e6c9d6b0f9e2b4c91507409e9a1f4a52ff.tar.bz2
gentoo-2-50ee53e6c9d6b0f9e2b4c91507409e9a1f4a52ff.zip
Rev bumping. Fixing bug #212436
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog8
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.1-r1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 8f38de5e1629..c6cc7456f3a7 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.35 2008/03/04 14:11:44 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.36 2008/04/08 08:07:01 araujo Exp $
+
+*gnu-smalltalk-3.0.1-r1 (08 Apr 2008)
+
+ 08 Apr 2008; Luis F. Araujo <araujo@gentoo.org>
+ +gnu-smalltalk-3.0.1-r1.ebuild:
+ Fixing bug #212436
*gnu-smalltalk-3.0.1 (04 Mar 2008)
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.1-r1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..e67f39c9fe49
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.1-r1.ebuild,v 1.1 2008/04/08 08:07:01 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl /usr/lib` \
+ `use_with tk tk /usr/lib` \
+ `use_enable gtk gtk` \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make prefix="${D}/usr" mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ lispdir="${D}/usr/share/emacs/site-lisp/gnu-smalltalk" \
+ libdir="${D}/usr/lib" install || die
+ # Remove libsigsegv
+ rm -rf "${D}/usr/include/sigsegv.h" \
+ "${D}/usr/include/snprintfv" \
+ "${D}/usr/share/aclocal/snprintfv.m4"
+ rm "${D}"/usr/lib/libsigsegv*
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}