summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
commit500c03b1a177d64c30246fae46d7bc8e0d89475c (patch)
tree62833a55b666dc22cf4c51cc77ac36adb22896e8 /dev-lang
parentglibc ----------------------------> libc ! (Manifest recommit) (diff)
downloadgentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.tar.gz
gentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.tar.bz2
gentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.zip
QA - fix use invocation and a bug in the 2.3.4 ebuilds: [ -z "use X" -o -z "use tcltk" ] doesn't do what you meant it to do
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.2.2.ebuild4
-rw-r--r--dev-lang/python/python-2.2.3-r5.ebuild4
-rw-r--r--dev-lang/python/python-2.3.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.3.3.ebuild6
-rw-r--r--dev-lang/python/python-2.3.4.ebuild6
-rw-r--r--dev-lang/python/python-2.3.4_rc1.ebuild6
7 files changed, 22 insertions, 16 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 98fe8da1547a..2e4dd604ea14 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.102 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.103 2004/06/25 18:13:57 agriffis Exp $
+
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org> python-2.2.2.ebuild,
+ python-2.2.3-r5.ebuild, python-2.3.3-r1.ebuild, python-2.3.3.ebuild,
+ python-2.3.4.ebuild, python-2.3.4_rc1.ebuild:
+ QA - fix use invocation and a bug in the 2.3.4 ebuilds:
+ [ -z "use X" -o -z "use tcltk" ] doesn't do what you meant it to do
20 Jun 2004; Gustavo Zacarias <gustavoz@gentoo.org> python-2.3.3-r1.ebuild:
Sparc happy stable
diff --git a/dev-lang/python/python-2.2.2.ebuild b/dev-lang/python/python-2.2.2.ebuild
index 5173d7bff7ee..b71fc65bb01c 100644
--- a/dev-lang/python/python-2.2.2.ebuild
+++ b/dev-lang/python/python-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.2.ebuild,v 1.13 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.2.ebuild,v 1.14 2004/06/25 18:13:57 agriffis Exp $
IUSE="readline tcltk berkdb bootstrap"
@@ -55,7 +55,7 @@ src_compile() {
local myopts
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
+ if use build && ! use bootstrap
then
myopts="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.2.3-r5.ebuild b/dev-lang/python/python-2.2.3-r5.ebuild
index e42d60366069..031c4a94f212 100644
--- a/dev-lang/python/python-2.2.3-r5.ebuild
+++ b/dev-lang/python/python-2.2.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.21 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.22 2004/06/25 18:13:57 agriffis Exp $
inherit flag-o-matic eutils python
@@ -82,7 +82,7 @@ src_compile() {
local myopts
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
+ if use build && ! use bootstrap
then
myopts="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.3-r1.ebuild b/dev-lang/python/python-2.3.3-r1.ebuild
index 25bd3764864d..dc9ba53334fd 100644
--- a/dev-lang/python/python-2.3.3-r1.ebuild
+++ b/dev-lang/python/python-2.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.16 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.17 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -95,7 +95,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index b9195edae985..7423206eb082 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.26 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.27 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -70,7 +70,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "`use X`" -o -z "`use tcltk`" ] \
+ ( use !X || use !tcltk ) \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
@@ -92,7 +92,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.4.ebuild b/dev-lang/python/python-2.3.4.ebuild
index 1cc5967497dc..86199238c206 100644
--- a/dev-lang/python/python-2.3.4.ebuild
+++ b/dev-lang/python/python-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4.ebuild,v 1.4 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4.ebuild,v 1.5 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -71,7 +71,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "use X" -o -z "use tcltk" ] \
+ ( use !X || use !tcltk ) \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
@@ -93,7 +93,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.4_rc1.ebuild b/dev-lang/python/python-2.3.4_rc1.ebuild
index 2074aefc34e5..af90097e6f11 100644
--- a/dev-lang/python/python-2.3.4_rc1.ebuild
+++ b/dev-lang/python/python-2.3.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.7 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.8 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -72,7 +72,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "use X" -o -z "use tcltk" ] \
+ ( use !X || use !tcltk ) \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
@@ -94,7 +94,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi