summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-08-05 11:39:01 +0000
committerNaohiro Aota <naota@gentoo.org>2011-08-05 11:39:01 +0000
commit3ef49df096cf5e191e51de5085b087bb1ba3c4f6 (patch)
tree510542d125f858d807ca91ad1c18a8e3fcbe8099 /dev-lang
parentRemoved deprecated -oknodo, bug #377773 (diff)
downloadgentoo-2-3ef49df096cf5e191e51de5085b087bb1ba3c4f6.tar.gz
gentoo-2-3ef49df096cf5e191e51de5085b087bb1ba3c4f6.tar.bz2
gentoo-2-3ef49df096cf5e191e51de5085b087bb1ba3c4f6.zip
Move linux3 compat hack into kernel_linux check. Bug #374579
(Portage version: 2.2.0_alpha43/cvs/FreeBSD i386)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.6.7-r2.ebuild6
-rw-r--r--dev-lang/python/python-2.7.2-r2.ebuild6
-rw-r--r--dev-lang/python/python-3.1.4-r2.ebuild6
-rw-r--r--dev-lang/python/python-3.2-r2.ebuild6
5 files changed, 21 insertions, 9 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index f6dda82f5b92..8967eba7444d 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.540 2011/07/24 15:06:30 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.541 2011/08/05 11:39:01 naota Exp $
+
+ 05 Aug 2011; Naohiro Aota <naota@gentoo.org> python-2.6.7-r2.ebuild,
+ python-2.7.2-r2.ebuild, python-3.1.4-r2.ebuild, python-3.2-r2.ebuild:
+ Move linux3 compat hack into kernel_linux check. Bug #374579
*python-3.2-r2 (24 Jul 2011)
*python-3.1.4-r2 (24 Jul 2011)
diff --git a/dev-lang/python/python-2.6.7-r2.ebuild b/dev-lang/python/python-2.6.7-r2.ebuild
index 26f7191de680..cd85d2f6d2a1 100644
--- a/dev-lang/python/python-2.6.7-r2.ebuild
+++ b/dev-lang/python/python-2.6.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.1 2011/07/24 15:06:30 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.2 2011/08/05 11:39:01 naota Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -145,7 +145,9 @@ src_prepare() {
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
#Linux-3 compat. Bug #374579 (upstream issue12571)
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ if use kernel_linux; then
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ fi
eautoreconf
}
diff --git a/dev-lang/python/python-2.7.2-r2.ebuild b/dev-lang/python/python-2.7.2-r2.ebuild
index a1f2575e5c0d..75f05f0d9989 100644
--- a/dev-lang/python/python-2.7.2-r2.ebuild
+++ b/dev-lang/python/python-2.7.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r2.ebuild,v 1.1 2011/07/24 15:06:30 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r2.ebuild,v 1.2 2011/08/05 11:39:01 naota Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -149,7 +149,9 @@ src_prepare() {
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
#Linux-3 compat. Bug #374579 (upstream issue12571)
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ if use kernel_linux; then
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ fi
eautoreconf
}
diff --git a/dev-lang/python/python-3.1.4-r2.ebuild b/dev-lang/python/python-3.1.4-r2.ebuild
index e0742a090d6f..3ff16bc42f99 100644
--- a/dev-lang/python/python-3.1.4-r2.ebuild
+++ b/dev-lang/python/python-3.1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r2.ebuild,v 1.1 2011/07/24 15:06:30 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r2.ebuild,v 1.2 2011/08/05 11:39:01 naota Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -115,7 +115,9 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
#Linux-3 compat. Bug #374579 (upstream issue12571)
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ if use kernel_linux; then
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ fi
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
diff --git a/dev-lang/python/python-3.2-r2.ebuild b/dev-lang/python/python-3.2-r2.ebuild
index ff461aa2f72a..e5c5fccbf34f 100644
--- a/dev-lang/python/python-3.2-r2.ebuild
+++ b/dev-lang/python/python-3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.1 2011/07/24 15:06:30 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.2 2011/08/05 11:39:01 naota Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -107,7 +107,9 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
#Linux-3 compat. Bug #374579 (upstream issue12571)
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ if use kernel_linux; then
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
+ fi
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \